aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2012-06-15 09:56:13 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2012-06-15 09:56:13 +0000
commit6b45d74427350b307d125a65300dd7c6429e7c20 (patch)
tree23b23ac3373140072142b0daf643f4d5de85c1c6
parent11be97e555ca541e44ad4422fc5323fbf547332e (diff)
downloadports-6b45d74427350b307d125a65300dd7c6429e7c20.tar.gz
ports-6b45d74427350b307d125a65300dd7c6429e7c20.zip
Notes
-rw-r--r--audio/gtick/Makefile16
-rw-r--r--emulators/pcsxr/Makefile10
-rw-r--r--games/blobby/Makefile8
-rw-r--r--games/flightgear/Makefile18
-rw-r--r--games/openalchemist/Makefile14
5 files changed, 37 insertions, 29 deletions
diff --git a/audio/gtick/Makefile b/audio/gtick/Makefile
index c89775b612c3..ac818c43445f 100644
--- a/audio/gtick/Makefile
+++ b/audio/gtick/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gtick
PORTVERSION= 0.5.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.antcom.de/gtick/download/ CENKES
@@ -16,8 +16,8 @@ COMMENT= A metronome application
LICENSE= GPLv3
-LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
- pulse-simple.0:${PORTSDIR}/audio/pulseaudio
+LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile \
+ pulse-simple:${PORTSDIR}/audio/pulseaudio
GNU_CONFIGURE= yes
USE_GNOME= gtk20
@@ -25,13 +25,15 @@ LDFLAGS+= -L${LOCALBASE}/lib
MAN1= gtick.1
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
post-patch:
diff --git a/emulators/pcsxr/Makefile b/emulators/pcsxr/Makefile
index ec5e9ac450a9..ff172511da9e 100644
--- a/emulators/pcsxr/Makefile
+++ b/emulators/pcsxr/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pcsxr
PORTVERSION= 1.9.92.r76026
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= http://contribs.martymac.org/FreeBSD-ports/distfiles/ \
LOCAL/martymac
@@ -19,8 +19,8 @@ COMMENT= Playstation (PSX) emulator
LICENSE= GPLv2
BUILD_DEPENDS= gawk:${PORTSDIR}/lang/gawk
-LIB_DEPENDS= vorbis.4:${PORTSDIR}/audio/libvorbis \
- cdio.13:${PORTSDIR}/sysutils/libcdio
+LIB_DEPENDS= vorbis:${PORTSDIR}/audio/libvorbis \
+ cdio:${PORTSDIR}/sysutils/libcdio
ONLY_FOR_ARCHS= i386 amd64
@@ -56,7 +56,7 @@ DEFAULT_DVD_DEVICE?= /dev/cd0
CONFIGURE_ARGS+= --enable-dynarec=x86_64
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
CONFIGURE_ARGS+= --enable-nls
PLIST_SUB+= NLS=""
@@ -76,7 +76,7 @@ pre-configure:
@(cd ${WRKSRC} && ${AUTORECONF} -fi)
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
diff --git a/games/blobby/Makefile b/games/blobby/Makefile
index a3561202ec7f..bb383385ab53 100644
--- a/games/blobby/Makefile
+++ b/games/blobby/Makefile
@@ -7,7 +7,7 @@
PORTNAME= blobby
PORTVERSION= 0.9c
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/Blobby%20Volley%202%20%28Linux%29/Beta%20${PORTVERSION}
DISTNAME= blobby2-linux-${PORTVERSION}
@@ -17,7 +17,7 @@ COMMENT= Official continuation of the famous Blobby Volley 1.x game
LICENSE= GPLv2
-LIB_DEPENDS= physfs.1:${PORTSDIR}/devel/physfs \
+LIB_DEPENDS= physfs:${PORTSDIR}/devel/physfs \
drm:${PORTSDIR}/graphics/libdrm
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip \
${LOCALBASE}/include/boost/crc.hpp:${PORTSDIR}/devel/boost-libs
@@ -34,8 +34,10 @@ DOS2UNIX_REGEX= .*\.(c|h|cpp)
PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README TODO
+.include <bsd.port.options.mk>
+
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index e6c44d3c9fea..bb36aa4d54f5 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -7,7 +7,7 @@
PORTNAME= flightgear
PORTVERSION= 2.6.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= games
# see http://www.flightgear.org/templates.js
MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/ \
@@ -21,10 +21,10 @@ COMMENT= The FlightGear flight simulator
LICENSE= GPLv2
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- boost_thread.4:${PORTSDIR}/devel/boost-libs \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- osg.80:${PORTSDIR}/graphics/osg
+LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
+ boost_thread:${PORTSDIR}/devel/boost-libs \
+ fltk:${PORTSDIR}/x11-toolkits/fltk \
+ osg:${PORTSDIR}/graphics/osg
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
@@ -43,12 +43,14 @@ CMAKE_ARGS+= -DJPEG_FACTORY:BOOL=ON \
PORTDOCS= README README.OSG README.OpenAL README.SimGear README.plib
-.if defined(NOPORTDOCS)
+MAN1= js_demo.1 fgjs.1 gl-info.1 fgfs.1 fgpanel.1 terrasync.1
+
+.include <bsd.port.options.mk>
+
+.if empty(PORT_OPTIONS:MDOCS)
CMAKE_ARGS+= -DNOPORTDOCS:BOOL=ON
.endif
-MAN1= js_demo.1 fgjs.1 gl-info.1 fgfs.1 fgpanel.1 terrasync.1
-
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/utils/js_server/js_server ${PREFIX}/bin
@${CAT} ${PKGMESSAGE}
diff --git a/games/openalchemist/Makefile b/games/openalchemist/Makefile
index 3ea2e38a840f..bc1174d1749b 100644
--- a/games/openalchemist/Makefile
+++ b/games/openalchemist/Makefile
@@ -7,7 +7,7 @@
PORTNAME= openalchemist
PORTVERSION= 0.3
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -22,8 +22,8 @@ LICENSE_FILE_CCbySA= ${WRKSRC}/GRAPHICS-LICENSE
LICENSE_PERMS_CCbySA= ${_LICENSE_PERMS_DEFAULT}
BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
-LIB_DEPENDS= clanCore-0.8:${PORTSDIR}/devel/clanlib \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= clanCore:${PORTSDIR}/devel/clanlib \
+ jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
USE_AUTOTOOLS= aclocal automake autoconf
@@ -40,16 +40,18 @@ USE_ICONV= yes
PORTDOCS= AUTHORS ChangeLog README TODO
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -E -e 's|^%|#|g' ${WRKSRC}/configure.ac
@${REINPLACE_CMD} -E -e 's|^dist_pkgdata_DATA =.*|dist_pkgdata_DATA = data/* skins/aqua.zip skins/brushed.zip skins/vectoriel.zip|g' ${WRKSRC}/Makefile.am
@${REINPLACE_CMD} -E -e 's|^#!/usr/bin/python|#!${LOCALBASE}/bin/python|g' ${WRKSRC}/openalchemist-config
-.if !defined(NOPORTDOCS)
post-install:
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
-.for f in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
.endfor
.endif