aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2014-11-18 13:45:56 +0000
committerMathieu Arnold <mat@FreeBSD.org>2014-11-18 13:45:56 +0000
commit6be72a854bd069acc31460fde915f2dcb08400b0 (patch)
treedacd4bdd948d88c77d0511e17cad399108077a97
parentf322cda34a4132453b3d9a3df802ee321d88acb3 (diff)
downloadports-6be72a854bd069acc31460fde915f2dcb08400b0.tar.gz
ports-6be72a854bd069acc31460fde915f2dcb08400b0.zip
Introduce the SITE_ARCH variable containing SITE_PERL/PERL_ARCH.
With hat: perl@, portmgr@ Sponsored by: Absolight
Notes
Notes: svn path=/head/; revision=372718
-rw-r--r--CHANGES6
-rw-r--r--Mk/Uses/perl5.mk7
2 files changed, 12 insertions, 1 deletions
diff --git a/CHANGES b/CHANGES
index 653d28701107..9bd9e371d9cf 100644
--- a/CHANGES
+++ b/CHANGES
@@ -10,6 +10,12 @@ in the release notes and/or placed into UPDATING.
All ports committers are allowed to commit to this file.
+20141118:
+AUTHOR: mat@FreeBSD.org
+
+ To ease future work, a new SITE_ARCH variable and PLIST_SUB replacement
+ containing SITE_PERL/PERL_ARCH has been added.
+
20141102:
AUTHOR: bdrewery@FreeBSD.org
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index f61836ec5454..440f8f035bb6 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -23,6 +23,8 @@
# (value: perl5.14)
# SITE_PERL - Directory name where site specific perl packages go.
# This value is added to PLIST_SUB.
+# SITE_ARCH - Directory name where arch site specific perl packages go.
+# This value is added to PLIST_SUB.
# USE_PERL5 - If set, this port uses perl5 in one or more of the extract,
# patch, build, install or run phases. The fixpacklist is
# needed in some cases, when a .packlist is created, it may
@@ -96,6 +98,8 @@ PERL_PORT?= perl5.14
SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
+SITE_ARCH_REL?= ${SITE_PERL_REL}/${PERL_ARCH}
+SITE_ARCH?= ${LOCALBASE}/${SITE_ARCH_REL}
PERL5= ${LOCALBASE}/bin/perl${PERL_VERSION}
PERL= ${LOCALBASE}/bin/perl
@@ -156,6 +160,7 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
PERL_VER=${PERL_VER} \
PERL_ARCH=${PERL_ARCH} \
PERL5_MAN3=lib/perl5/${PERL_VER}/man/man3 \
+ SITE_ARCH=${SITE_ARCH_REL} \
SITE_PERL=${SITE_PERL_REL}
# handle perl5 specific manpages
@@ -170,7 +175,7 @@ MANDIRS+= ${PREFIX}/lib/perl5/${PERL_VER}
_USE_PERL5+= configure
ALL_TARGET?= # empty
CONFIGURE_ARGS+=--install_path lib="${PREFIX}/${SITE_PERL_REL}" \
- --install_path arch="${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}" \
+ --install_path arch="${PREFIX}/${SITE_ARCH_REL}" \
--install_path script="${PREFIX}/bin" \
--install_path bin="${PREFIX}/bin" \
--install_path libdoc="${MAN3PREFIX}/man/man3" \