aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2016-12-26 14:56:02 +0000
committerThomas Zander <riggs@FreeBSD.org>2016-12-26 14:56:02 +0000
commit6cfe79ca6f0d9074be72671794297db20ebf2a7e (patch)
tree5c4bcb67e4ee65e0c9462621fbb59cd33ef8d04a
parent5c242295502fc8bb5434160985ad11afe69c13ee (diff)
downloadports-6cfe79ca6f0d9074be72671794297db20ebf2a7e.tar.gz
ports-6cfe79ca6f0d9074be72671794297db20ebf2a7e.zip
Notes
-rw-r--r--MOVED1
-rw-r--r--net-mgmt/Makefile2
-rw-r--r--net-mgmt/seafile-client/Makefile78
-rw-r--r--net-mgmt/seafile-client/distinfo3
-rw-r--r--net-mgmt/seafile-client/files/patch-common_obj-backend-fs.c (renamed from net-mgmt/seafile/files/patch-common_obj-backend-fs.c)0
-rw-r--r--net-mgmt/seafile-client/files/patch-configure.ac (renamed from net-mgmt/seafile/files/patch-configure.ac)0
-rw-r--r--net-mgmt/seafile-client/files/patch-controller_seafile-controller.c (renamed from net-mgmt/seafile/files/patch-controller_seafile-controller.c)0
-rw-r--r--net-mgmt/seafile-client/files/patch-daemon_Makefile.am (renamed from net-mgmt/seafile/files/patch-daemon_Makefile.am)0
-rw-r--r--net-mgmt/seafile-client/files/patch-daemon_http-tx-mgr.c (renamed from net-mgmt/seafile/files/patch-daemon_http-tx-mgr.c)0
-rw-r--r--net-mgmt/seafile-client/files/patch-daemon_vc-utils.c (renamed from net-mgmt/seafile/files/patch-daemon_vc-utils.c)13
-rw-r--r--net-mgmt/seafile-client/files/patch-lib_Makefile.am (renamed from net-mgmt/seafile/files/patch-lib_Makefile.am)0
-rw-r--r--net-mgmt/seafile-client/files/patch-lib_net.c (renamed from net-mgmt/seafile/files/patch-lib_net.c)0
-rw-r--r--net-mgmt/seafile-client/files/patch-lib_utils.c (renamed from net-mgmt/seafile/files/patch-lib_utils.c)0
-rw-r--r--net-mgmt/seafile-client/files/patch-lib_utils.h (renamed from net-mgmt/seafile/files/patch-lib_utils.h)0
-rw-r--r--net-mgmt/seafile-client/files/patch-scripts_setup-seafile.sh (renamed from net-mgmt/seafile/files/patch-scripts_setup-seafile.sh)0
-rw-r--r--net-mgmt/seafile-client/files/patch-scripts_upgrade_regenerate__secret__key.sh (renamed from net-mgmt/seafile/files/patch-scripts_upgrade_regenerate__secret__key.sh)0
-rw-r--r--net-mgmt/seafile-client/files/patch-server_access-file.c (renamed from net-mgmt/seafile/files/patch-server_access-file.c)0
-rw-r--r--net-mgmt/seafile-client/pkg-descr (renamed from net-mgmt/seafile/pkg-descr)0
-rw-r--r--net-mgmt/seafile-client/pkg-plist28
-rw-r--r--net-mgmt/seafile-gui/Makefile2
-rw-r--r--net-mgmt/seafile/Makefile134
-rw-r--r--net-mgmt/seafile/distinfo3
-rw-r--r--net-mgmt/seafile/files/patch-daemon_repo-mgr.c47
-rw-r--r--net-mgmt/seafile/files/pkg-message.in12
-rw-r--r--net-mgmt/seafile/files/seafile.in147
-rw-r--r--net-mgmt/seafile/pkg-plist113
26 files changed, 114 insertions, 469 deletions
diff --git a/MOVED b/MOVED
index 85180a79976f..29f470423b69 100644
--- a/MOVED
+++ b/MOVED
@@ -8849,3 +8849,4 @@ www/py33-requests|www/py3-requests|2016-12-26|No need for 4 versions of py-reque
www/py34-requests|www/py3-requests|2016-12-26|No need for 4 versions of py-requests
www/py35-requests|www/py3-requests|2016-12-26|No need for 4 versions of py-requests
net-mgmt/ccnet|net-mgmt/ccnet-client|2016-12-26|Split into -client and -server parts
+net-mgmt/seafile|net-mgmt/seafile-client|2016-12-26|Split into -client and -server parts
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index c90727584ba9..5fa68f0da0b7 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -304,7 +304,7 @@
SUBDIR += sblim-wbemcli
SUBDIR += scli
SUBDIR += sdig
- SUBDIR += seafile
+ SUBDIR += seafile-client
SUBDIR += seafile-gui
SUBDIR += seafile-server
SUBDIR += send
diff --git a/net-mgmt/seafile-client/Makefile b/net-mgmt/seafile-client/Makefile
new file mode 100644
index 000000000000..ffaddc7c58c4
--- /dev/null
+++ b/net-mgmt/seafile-client/Makefile
@@ -0,0 +1,78 @@
+# $FreeBSD$
+
+PORTNAME= seafile-client
+PORTVERSION= 6.0.1
+DISTVERSIONPREFIX= v
+CATEGORIES= net-mgmt
+
+MAINTAINER= ultima1252@gmail.com
+COMMENT= Open Source Cloud Storage (Client)
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+BUILD_DEPENDS= valac:lang/vala
+LIB_DEPENDS= libsearpc.so:devel/libsearpc \
+ libevhtp.so:www/libevhtp \
+ libzdb.so:databases/libzdb \
+ libcurl.so:ftp/curl \
+ libinotify.so:devel/libinotify \
+ libccnet.so:net-mgmt/ccnet-client \
+ libevent.so:devel/libevent2 \
+ libuuid.so:misc/e2fsprogs-libuuid \
+ libjansson.so:devel/jansson
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3 \
+ bash:shells/bash
+
+CONFLICTS= seafile-server-[0-9]*
+
+USE_GITHUB= yes
+GH_ACCOUNT= haiwen
+GH_PROJECT= seafile
+
+USES= autoreconf gettext iconv libarchive libtool mysql pathfix \
+ pkgconfig python:-2.7 shebangfix sqlite ssl
+USE_GNOME= glib20
+SHEBANG_FILES= scripts/*.sh scripts/upgrade/*.sh tests/*.py tests/basic/*.sh \
+ tests/sync-auto-test/*.template *.sh scripts/build/*.py \
+ scripts/*.py *.py scripts/upgrade/*.py app/seaf-cli \
+ tools/seafile-admin
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ENV= SSL_CFLAGS="${OPENSSLINC}" SSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
+
+INSTALL_TARGET= install-strip
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/evhtp
+LDFLAGS+= -L${LOCALBASE}/lib
+
+OPTIONS_DEFINE= FUSE RIAK
+OPTIONS_SUB= yes
+
+FUSE_DESC= Use file system in userspace
+RIAK_DESC= Use distributed noSQL database
+
+FUSE_CONFIGURE_ENABLE= fuse
+FUSE_LIB_DEPENDS= libfuse.so:sysutils/fusefs-libs
+
+RIAK_CONFIGURE_ENABLE= riak
+RIAK_RUN_DEPENDS= riak:databases/riak
+
+OPTIONS_DEFAULT= FUSE
+OPTIONS_EXCLUDE_DragonFly= FUSE
+
+.include <bsd.port.options.mk>
+
+post-patch:
+# Fix P_KTHREAD r295435
+.if ${OSVERSION} >= 1100097
+ ${REINPLACE_CMD} 's/P_KTHREAD/P_KPROC/' ${WRKSRC}/lib/utils.c
+.endif
+ ${REINPLACE_CMD} 's/python/${PYTHON_VERSION}/' \
+ ${WRKSRC}/scripts/upgrade/regenerate_secret_key.sh
+ ${REINPLACE_CMD} -e 's|^INSTALL.*|INSTALLPATH="${PREFIX}/${SEAFILE_SERVER}/seafile"|' \
+ ${WRKSRC}/scripts/seaf-cli-wrapper.sh
+ ${REINPLACE_CMD} 's/<evhtp.h>/<evhtp\/evhtp.h>/' ${WRKSRC}/server/upload-file.c \
+ ${WRKSRC}/server/access-file.c ${WRKSRC}/server/http-server.c
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/seafile-client/distinfo b/net-mgmt/seafile-client/distinfo
new file mode 100644
index 000000000000..055f4627454d
--- /dev/null
+++ b/net-mgmt/seafile-client/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1481772891
+SHA256 (haiwen-seafile-v6.0.1_GH0.tar.gz) = c212833ff21af19554d216ab3f5c01c3a5878d4bd30b4f71c67ec9b71416a095
+SIZE (haiwen-seafile-v6.0.1_GH0.tar.gz) = 1154256
diff --git a/net-mgmt/seafile/files/patch-common_obj-backend-fs.c b/net-mgmt/seafile-client/files/patch-common_obj-backend-fs.c
index da586db2e4c1..da586db2e4c1 100644
--- a/net-mgmt/seafile/files/patch-common_obj-backend-fs.c
+++ b/net-mgmt/seafile-client/files/patch-common_obj-backend-fs.c
diff --git a/net-mgmt/seafile/files/patch-configure.ac b/net-mgmt/seafile-client/files/patch-configure.ac
index 8ce4aed3f861..8ce4aed3f861 100644
--- a/net-mgmt/seafile/files/patch-configure.ac
+++ b/net-mgmt/seafile-client/files/patch-configure.ac
diff --git a/net-mgmt/seafile/files/patch-controller_seafile-controller.c b/net-mgmt/seafile-client/files/patch-controller_seafile-controller.c
index ca60f151f95b..ca60f151f95b 100644
--- a/net-mgmt/seafile/files/patch-controller_seafile-controller.c
+++ b/net-mgmt/seafile-client/files/patch-controller_seafile-controller.c
diff --git a/net-mgmt/seafile/files/patch-daemon_Makefile.am b/net-mgmt/seafile-client/files/patch-daemon_Makefile.am
index cf201fb90e04..cf201fb90e04 100644
--- a/net-mgmt/seafile/files/patch-daemon_Makefile.am
+++ b/net-mgmt/seafile-client/files/patch-daemon_Makefile.am
diff --git a/net-mgmt/seafile/files/patch-daemon_http-tx-mgr.c b/net-mgmt/seafile-client/files/patch-daemon_http-tx-mgr.c
index 5d25c4ef1e7c..5d25c4ef1e7c 100644
--- a/net-mgmt/seafile/files/patch-daemon_http-tx-mgr.c
+++ b/net-mgmt/seafile-client/files/patch-daemon_http-tx-mgr.c
diff --git a/net-mgmt/seafile/files/patch-daemon_vc-utils.c b/net-mgmt/seafile-client/files/patch-daemon_vc-utils.c
index c715ec6873f1..4bd0a41445b9 100644
--- a/net-mgmt/seafile/files/patch-daemon_vc-utils.c
+++ b/net-mgmt/seafile-client/files/patch-daemon_vc-utils.c
@@ -1,15 +1,6 @@
---- daemon/vc-utils.c.orig 2016-04-05 08:38:26 UTC
+--- daemon/vc-utils.c.orig 2016-12-03 06:02:47 UTC
+++ daemon/vc-utils.c
-@@ -664,7 +664,7 @@ error:
-
- #endif /* defined WIN32 || defined __APPLE__ */
-
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__) || defined(__DragonFly__) || defined(__NetBSD__) || defined(__OpenBSD__)
-
- char *
- build_checkout_path (const char *worktree, const char *ce_name, int len)
-@@ -724,7 +724,7 @@ checkout_entry (struct cache_entry *ce,
+@@ -736,7 +736,7 @@ checkout_entry (struct cache_entry *ce,
gboolean force_conflict = FALSE;
path_in = g_build_path ("/", o->base, ce->name, NULL);
diff --git a/net-mgmt/seafile/files/patch-lib_Makefile.am b/net-mgmt/seafile-client/files/patch-lib_Makefile.am
index 3e2d623e92d3..3e2d623e92d3 100644
--- a/net-mgmt/seafile/files/patch-lib_Makefile.am
+++ b/net-mgmt/seafile-client/files/patch-lib_Makefile.am
diff --git a/net-mgmt/seafile/files/patch-lib_net.c b/net-mgmt/seafile-client/files/patch-lib_net.c
index 37f1311bbc6f..37f1311bbc6f 100644
--- a/net-mgmt/seafile/files/patch-lib_net.c
+++ b/net-mgmt/seafile-client/files/patch-lib_net.c
diff --git a/net-mgmt/seafile/files/patch-lib_utils.c b/net-mgmt/seafile-client/files/patch-lib_utils.c
index 15b418068b1a..15b418068b1a 100644
--- a/net-mgmt/seafile/files/patch-lib_utils.c
+++ b/net-mgmt/seafile-client/files/patch-lib_utils.c
diff --git a/net-mgmt/seafile/files/patch-lib_utils.h b/net-mgmt/seafile-client/files/patch-lib_utils.h
index 6d9d2709e1a0..6d9d2709e1a0 100644
--- a/net-mgmt/seafile/files/patch-lib_utils.h
+++ b/net-mgmt/seafile-client/files/patch-lib_utils.h
diff --git a/net-mgmt/seafile/files/patch-scripts_setup-seafile.sh b/net-mgmt/seafile-client/files/patch-scripts_setup-seafile.sh
index bdf527e66527..bdf527e66527 100644
--- a/net-mgmt/seafile/files/patch-scripts_setup-seafile.sh
+++ b/net-mgmt/seafile-client/files/patch-scripts_setup-seafile.sh
diff --git a/net-mgmt/seafile/files/patch-scripts_upgrade_regenerate__secret__key.sh b/net-mgmt/seafile-client/files/patch-scripts_upgrade_regenerate__secret__key.sh
index c46ad93cb7bf..c46ad93cb7bf 100644
--- a/net-mgmt/seafile/files/patch-scripts_upgrade_regenerate__secret__key.sh
+++ b/net-mgmt/seafile-client/files/patch-scripts_upgrade_regenerate__secret__key.sh
diff --git a/net-mgmt/seafile/files/patch-server_access-file.c b/net-mgmt/seafile-client/files/patch-server_access-file.c
index 176867cac46f..176867cac46f 100644
--- a/net-mgmt/seafile/files/patch-server_access-file.c
+++ b/net-mgmt/seafile-client/files/patch-server_access-file.c
diff --git a/net-mgmt/seafile/pkg-descr b/net-mgmt/seafile-client/pkg-descr
index 8a51d18bbb8c..8a51d18bbb8c 100644
--- a/net-mgmt/seafile/pkg-descr
+++ b/net-mgmt/seafile-client/pkg-descr
diff --git a/net-mgmt/seafile-client/pkg-plist b/net-mgmt/seafile-client/pkg-plist
new file mode 100644
index 000000000000..346992b0ef6f
--- /dev/null
+++ b/net-mgmt/seafile-client/pkg-plist
@@ -0,0 +1,28 @@
+bin/seaf-cli
+bin/seaf-daemon
+include/seafile/monitor-rpc.h
+include/seafile/seafile-object.h
+include/seafile/seafile-rpc.h
+include/seafile/seafile.h
+lib/libseafile.a
+lib/libseafile.so
+lib/libseafile.so.0
+lib/libseafile.so.0.0.0
+%%PYTHON_SITELIBDIR%%/seafile/__init__.py
+%%PYTHON_SITELIBDIR%%/seafile/__init__.pyc
+%%PYTHON_SITELIBDIR%%/seafile/__init__.pyo
+%%PYTHON_SITELIBDIR%%/seafile/rpcclient.py
+%%PYTHON_SITELIBDIR%%/seafile/rpcclient.pyc
+%%PYTHON_SITELIBDIR%%/seafile/rpcclient.pyo
+%%PYTHON_SITELIBDIR%%/seaserv/__init__.py
+%%PYTHON_SITELIBDIR%%/seaserv/__init__.pyc
+%%PYTHON_SITELIBDIR%%/seaserv/__init__.pyo
+%%PYTHON_SITELIBDIR%%/seaserv/api.py
+%%PYTHON_SITELIBDIR%%/seaserv/api.pyc
+%%PYTHON_SITELIBDIR%%/seaserv/api.pyo
+%%PYTHON_SITELIBDIR%%/seaserv/service.py
+%%PYTHON_SITELIBDIR%%/seaserv/service.pyc
+%%PYTHON_SITELIBDIR%%/seaserv/service.pyo
+libdata/pkgconfig/libseafile.pc
+man/man1/seaf-cli.1.gz
+man/man1/seaf-daemon.1.gz
diff --git a/net-mgmt/seafile-gui/Makefile b/net-mgmt/seafile-gui/Makefile
index 71c7003fe811..f02dfcbd4371 100644
--- a/net-mgmt/seafile-gui/Makefile
+++ b/net-mgmt/seafile-gui/Makefile
@@ -13,7 +13,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libglib-2.0.so:devel/glib20 \
libsearpc.so:devel/libsearpc \
- libseafile.so:net-mgmt/seafile \
+ libseafile.so:net-mgmt/seafile-client \
libsqlite3.so:databases/sqlite3 \
libccnet.so:net-mgmt/ccnet-client \
libjansson.so:devel/jansson \
diff --git a/net-mgmt/seafile/Makefile b/net-mgmt/seafile/Makefile
deleted file mode 100644
index 152853f0414b..000000000000
--- a/net-mgmt/seafile/Makefile
+++ /dev/null
@@ -1,134 +0,0 @@
-# $FreeBSD$
-
-PORTNAME= seafile
-PORTVERSION= 6.0.0
-PORTREVISION= 1
-DISTVERSIONPREFIX= v
-DISTVERSIONSUFFIX= -server
-CATEGORIES= net-mgmt
-
-MAINTAINER= ultima1252@gmail.com
-COMMENT= Open Source Cloud Storage (Server)
-
-LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/LICENSE.txt
-
-BUILD_DEPENDS= valac:lang/vala
-LIB_DEPENDS= libsearpc.so:devel/libsearpc \
- libevhtp.so:www/libevhtp \
- libzdb.so:databases/libzdb \
- libcurl.so:ftp/curl \
- libinotify.so:devel/libinotify \
- libccnet.so:net-mgmt/ccnet \
- libevent.so:devel/libevent2 \
- libuuid.so:misc/e2fsprogs-libuuid \
- libjansson.so:devel/jansson
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
- ${PYTHON_PKGNAMEPREFIX}urllib3>0:net/py-urllib3 \
- bash:shells/bash
-
-CONFLICTS= seafile-server-[0-9]*
-
-USE_GITHUB= yes
-GH_ACCOUNT= haiwen
-
-USES= autoreconf gettext iconv libarchive libtool mysql pathfix \
- pkgconfig python:-2.7 shebangfix sqlite ssl
-USE_GNOME= glib20
-SHEBANG_FILES= scripts/*.sh scripts/upgrade/*.sh tests/*.py tests/basic/*.sh \
- tests/sync-auto-test/*.template *.sh scripts/build/*.py \
- scripts/*.py *.py scripts/upgrade/*.py app/seaf-cli \
- tools/seafile-admin
-GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-CONFIGURE_ENV= SSL_CFLAGS="${OPENSSLINC}" SSL_LIBS="-L${OPENSSLLIB} -lssl -lcrypto"
-
-CONFIGURE_ARGS= --enable-server
-INSTALL_TARGET= install-strip
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/evhtp
-LDFLAGS+= -L${LOCALBASE}/lib
-
-HAIWENDIR= www/haiwen
-SEAFILE_SERVER= ${HAIWENDIR}/seafile-server
-SEABIN= ${SEAFILE_SERVER}/seafile/bin
-SEALIB= ${SEAFILE_SERVER}/seafile/lib
-
-USERS= seafile
-GROUPS= ${USERS}
-
-USE_RC_SUBR= ${PORTNAME}
-PLIST_SUB= USERS=${USERS} \
- GROUPS=${GROUPS} \
- SEAFILE_SERVER=${SEAFILE_SERVER} \
- HAIWENDIR=${HAIWENDIR}
-
-SUB_FILES= pkg-message
-
-SUB_LIST+= USERS=${USERS} \
- GROUPS=${GROUPS} \
- SEAFILE_SERVER=${SEAFILE_SERVER} \
- HAIWENDIR=${HAIWENDIR}
-
-MAKE_JOBS_UNSAFE= yes
-
-OPTIONS_DEFINE= FUSE RIAK
-OPTIONS_SUB= yes
-
-FUSE_DESC= Use file system in userspace
-RIAK_DESC= Use distributed noSQL database
-
-FUSE_CONFIGURE_ENABLE= fuse
-FUSE_LIB_DEPENDS= libfuse.so:sysutils/fusefs-libs
-
-RIAK_CONFIGURE_ENABLE= riak
-RIAK_RUN_DEPENDS= riak:databases/riak
-
-OPTIONS_DEFAULT= FUSE
-OPTIONS_EXCLUDE_DragonFly= FUSE
-
-.include <bsd.port.options.mk>
-
-post-patch:
-# Fix P_KTHREAD r295435
-.if ${OSVERSION} >= 1100097
- ${REINPLACE_CMD} 's/P_KTHREAD/P_KPROC/' ${WRKSRC}/lib/utils.c
-.endif
- ${REINPLACE_CMD} 's/python/${PYTHON_VERSION}/' \
- ${WRKSRC}/scripts/upgrade/regenerate_secret_key.sh
- ${REINPLACE_CMD} -e 's|^INSTALL.*|INSTALLPATH="${PREFIX}/${SEAFILE_SERVER}/seafile"|' \
- ${WRKSRC}/scripts/seaf-cli-wrapper.sh
- ${REINPLACE_CMD} 's/<evhtp.h>/<evhtp\/evhtp.h>/' ${WRKSRC}/server/upload-file.c \
- ${WRKSRC}/server/access-file.c ${WRKSRC}/server/http-server.c
-post-install:
- @${MKDIR} ${STAGEDIR}${PREFIX}/${SEABIN} ${STAGEDIR}${PREFIX}/${SEALIB} \
- ${STAGEDIR}${PREFIX}/${SEAFILE_SERVER}/seafile/share/doc/seafile \
- ${STAGEDIR}${PREFIX}/${SEAFILE_SERVER}/upgrade
-.for SERVPROG in seaf-fsck seafserv-gc seaf-fuse seaf-migrate \
- seaf-server seaf-server-init seafile-controller
- if [ -e "${STAGEDIR}${PREFIX}/bin/${SERVPROG}" ]; then \
- ${INSTALL_PROGRAM} ${STAGEDIR}${PREFIX}/bin/${SERVPROG} ${STAGEDIR}${PREFIX}/${SEABIN}; \
- ${RM} ${STAGEDIR}${PREFIX}/bin/${SERVPROG}; \
- fi
-.endfor
-.for SERVPROG in seafile-controller seaf-server
- ${LN} -s ${PREFIX}/${SEABIN}/${SERVPROG} ${STAGEDIR}${PREFIX}/bin/
-.endfor
-
- ${INSTALL_SCRIPT} ${STAGEDIR}${PREFIX}/bin/seaf-cli ${STAGEDIR}${PREFIX}/${SEABIN}/seaf-cli.py
- ${INSTALL_SCRIPT} ${WRKSRC}/scripts/seaf-cli-wrapper.sh ${STAGEDIR}${PREFIX}/bin/seaf-cli
- (cd ${STAGEDIR}${PREFIX}/lib && \
- ${COPYTREE_SHARE} ${PYTHON_VERSION} ${STAGEDIR}${PREFIX}/${SEALIB})
- @${RM} -r ${STAGEDIR}${PREFIX}/lib/${PYTHON_VERSION} \
- ${WRKSRC}/scripts/seaf-cli-wrapper.sh \
- ${WRKSRC}/scripts/sqlite2mysql.[ps][yh] \
- ${WRKSRC}/scripts/setup-seafile.sh \
- ${STAGEDIR}${PREFIX}/bin/seafile-admin
- ${INSTALL_SCRIPT} ${WRKSRC}/scripts/*.[ps][yh] ${STAGEDIR}${PREFIX}/${SEAFILE_SERVER}
- ${INSTALL_SCRIPT} ${WRKSRC}/scripts/upgrade/*.[ps][yh] \
- ${STAGEDIR}${PREFIX}/${SEAFILE_SERVER}/upgrade
- ${INSTALL_DATA} ${WRKSRC}/doc/seafile-tutorial.doc \
- ${STAGEDIR}${PREFIX}/${SEAFILE_SERVER}/seafile/share/doc/seafile/
- (cd ${WRKSRC}/scripts/upgrade && \
- ${COPYTREE_SHARE} sql ${STAGEDIR}${PREFIX}/${SEAFILE_SERVER}/upgrade)
-
-.include <bsd.port.mk>
diff --git a/net-mgmt/seafile/distinfo b/net-mgmt/seafile/distinfo
deleted file mode 100644
index b2db8cd1ca27..000000000000
--- a/net-mgmt/seafile/distinfo
+++ /dev/null
@@ -1,3 +0,0 @@
-TIMESTAMP = 1470238743
-SHA256 (haiwen-seafile-v6.0.0-server_GH0.tar.gz) = 778b4248c6596f25d337ea18b9422eeb6950c9b86456ac535c0f7c2fd5e8148f
-SIZE (haiwen-seafile-v6.0.0-server_GH0.tar.gz) = 1149598
diff --git a/net-mgmt/seafile/files/patch-daemon_repo-mgr.c b/net-mgmt/seafile/files/patch-daemon_repo-mgr.c
deleted file mode 100644
index ff9bc918dae9..000000000000
--- a/net-mgmt/seafile/files/patch-daemon_repo-mgr.c
+++ /dev/null
@@ -1,47 +0,0 @@
---- daemon/repo-mgr.c.orig 2016-05-10 12:25:35 UTC
-+++ daemon/repo-mgr.c
-@@ -4441,7 +4441,7 @@ checkout_file (const char *repo_id,
- gboolean force_conflict = FALSE;
- gboolean update_mode_only = FALSE;
-
--#ifndef __linux__
-+#if !defined(__linux__) && !defined(__FreeBSD__) && !defined(__DragonFly__) && !defined(__NetBSD__) && !defined(__OpenBSD__)
- path = build_case_conflict_free_path (worktree, name,
- conflict_hash, no_conflict_hash,
- &case_conflict,
-@@ -4617,7 +4617,7 @@ checkout_empty_dir (const char *worktree
- char *path;
- gboolean case_conflict = FALSE;
-
--#ifndef __linux__
-+#if !defined(__linux__) && !defined(__FreeBSD__) && !defined(__DragonFly__) && !defined(__NetBSD__) && !defined(__OpenBSD__)
- path = build_case_conflict_free_path (worktree, name,
- conflict_hash, no_conflict_hash,
- &case_conflict,
-@@ -5038,7 +5038,7 @@ schedule_file_fetch (GThreadPool *tpool,
- }
-
- if (!skip_fetch) {
--#ifndef __linux__
-+#if !defined(__linux__) && !defined(__FreeBSD__) && !defined(__DragonFly__) && !defined(__NetBSD__) && !defined(__OpenBSD__)
- gboolean case_conflict = FALSE;
- path = build_case_conflict_free_path (worktree, de->name,
- conflict_hash, no_conflict_hash,
-@@ -5185,7 +5185,7 @@ checkout_file_http (FileTxData *data,
- * A.txt to checkout, we can only detect case conflict after one file is checkecd
- * out. So we need to generate a new one here.
- */
--#ifndef __linux__
-+#if !defined(__linux__) && !defined(__FreeBSD__) && !defined(__DragonFly__) && !defined(__NetBSD__) && !defined(__OpenBSD__)
- path = build_case_conflict_free_path (worktree, de->name,
- conflict_hash, no_conflict_hash,
- &case_conflict,
-@@ -5567,7 +5567,7 @@ do_rename_in_worktree (DiffEntry *de, co
- old_path = g_build_filename (worktree, de->name, NULL);
-
- if (seaf_util_exists (old_path)) {
--#ifndef __linux__
-+#if !defined(__linux__) && !defined(__FreeBSD__) && !defined(__DragonFly__) && !defined(__NetBSD__) && !defined(__OpenBSD__)
- gboolean case_conflict;
- new_path = build_case_conflict_free_path (worktree, de->new_name,
- conflict_hash, no_conflict_hash,
diff --git a/net-mgmt/seafile/files/pkg-message.in b/net-mgmt/seafile/files/pkg-message.in
deleted file mode 100644
index 4c8229b86d58..000000000000
--- a/net-mgmt/seafile/files/pkg-message.in
+++ /dev/null
@@ -1,12 +0,0 @@
-For an existing config, or creating a new one, fix the UID/GID.
-Do not change %%PREFIX%%/%%SEAFILE_SERVER%% unless your front
-end is using the seafile UID/GID as well.
-
-chown -R seafile:seafile %%PREFIX%%/%%HAIWENDIR%%/conf \
- %%PREFIX%%/%%HAIWENDIR%%/ccnet %%PREFIX%%/%%HAIWENDIR%%/seafile-data \
- %%PREFIX%%/%%HAIWENDIR%%/pids %%PREFIX%%/%%HAIWENDIR%%/logs
-
-Don't forget to run update scripts after every minor and major update located in
- %%PREFIX%%/%%SEAFILE_SERVER%%/upgrade
-
-Patch updates (5.1.x) don't require these scripts, however do required a restarted.
diff --git a/net-mgmt/seafile/files/seafile.in b/net-mgmt/seafile/files/seafile.in
deleted file mode 100644
index 2288682ac65f..000000000000
--- a/net-mgmt/seafile/files/seafile.in
+++ /dev/null
@@ -1,147 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-
-# PROVIDE: seafile
-# REQUIRE: LOGIN cleanvar mysql
-# KEYWORD: shutdown
-#
-
-#
-# Add the following lines to /etc/rc.conf to enable seafile:
-#
-# seafile_enable (bool): Set to "NO" by default.
-# Set it to "YES" to enable seafile.
-# seafile_user (str): User to run seafile as
-# Default to "%%USERS%%" created by the port
-# seafile_group (str): Group to run seafile as
-# Default to "%%GROUPS%%" created by the port
-# seafile_path (str): Set to "" by default will use the path
-# %%PREFIX%%/%%SEAFILE_SERVER%%.
-# Set it to a different path.
-# seafile_ccnet (str): Set to "" by default will use the path
-# %%PREFIX%%/%%HAIWENDIR%%/ccnet.
-# Set it to a different path.
-# seafile_conf (str): Set to "" by default will use the path
-# %%PREFIX%%/%%HAIWENDIR%%/conf.
-# Set it to a different path.
-# seafile_datadir (str): Set to "" by default will use the path
-# in file %%PREFIX%%/%%HAIWENDIR%%/ccnet/seafile.ini.
-# Set it to a different path.
-# seafile_logdir (str): Set to "" by default will use the path
-# %%PREFIX%%/%%HAIWENDIR%%/logs
-# Set it to a different path.
-# seafile_loglevel (str): Set to "info" by default.
-# Possible values are debug, warning, info.
-
-. /etc/rc.subr
-
-name="seafile"
-rcvar="seafile_enable"
-
-load_rc_config $name
-
-start_cmd="seafile_start"
-restart_cmd="seafile_restart"
-stop_cmd="seafile_stop"
-
-: ${seafile_enable="NO"}
-: ${seafile_user:="%%USERS%%"}
-: ${seafile_group:="%%GROUPS%%"}
-: ${seafile_path:="%%PREFIX%%/%%SEAFILE_SERVER%%"}
-: ${seafile_ccnet:="%%PREFIX%%/%%HAIWENDIR%%/ccnet"}
-: ${seafile_conf:="%%PREFIX%%/%%HAIWENDIR%%/conf"}
-: ${seafile_datadir:="`cat ${seafile_ccnet}/seafile.ini 2>/dev/null`"}
-: ${seafile_logdir:="%%PREFIX%%/%%HAIWENDIR%%/logs"}
-: ${seafile_loglevel:="info"}
-
-command="%%PREFIX%%/%%SEAFILE_SERVER%%/seafile/bin/seafile-controller"
-command_args="-c \"${seafile_ccnet}\" -d \"${seafile_datadir}\" -F \"${seafile_conf}\" -L \"${seafile_logdir}\" -g \"${seafile_loglevel}\" -G \"${seafile_loglevel}\""
-
-required_dirs="${seafile_ccnet} ${seafile_conf} ${seafile_datadir}"
-required_files="${seafile_ccnet}/seafile.ini"
-
-test_config() {
- if ! su -m ${seafile_user} -c "${command} -t ${command_args}" ; then
- exit 1;
- fi
-}
-
-check_component_running() {
- name=$1
- cmd=$2
- if pid=$(pgrep -f "$cmd" 2>/dev/null); then
- echo "{$name} is running, pid $pid. You can stop it by: "
- echo
- echo " kill $pid"
- echo
- echo "Stop it and try again."
- echo
- exit
- fi
-}
-
-validate_already_running() {
- if pid=$(pgrep -f "seafile-controller -c ${seafile_ccnet}" 2>/dev/null); then
- echo "Seafile controller is already running, pid $pid"
- echo
- exit 1;
- fi
-
- check_component_running "ccnet-server" "ccnet-server -c ${seafile_ccnet}"
- check_component_running "seaf-server" "seaf-server -c ${seafile_ccnet}"
- check_component_running "fileserver" "fileserver -c ${seafile_ccnet}"
- check_component_running "seafdav" "wsgidav.server.run_server"
-}
-
-prepare_env() {
-export PATH=${seafile_path}/seafile/bin:$PATH
-export LD_LIBRARY_PATH=${seafile_path}/seafile/lib/:${seafile_path}/seafile/lib64:${LD_LIBRARY_PATH}
-}
-
-seafile_start() {
- check_required_before;
- validate_already_running;
- test_config;
-
- echo "Starting seafile server, please wait ..."
-
- su -m "${seafile_user}" -c "mkdir -p $seafile_logdir"
- su -m "${seafile_user}" -c "$command $command_args"
-
- sleep 3
-
- # check if seafile server started successfully
- if ! pgrep -f "seafile-controller -c ${seafile_ccnet}" 2>/dev/null 1>&2; then
- echo "Failed to start seafile server"
- exit 1;
- fi
-
- echo "Seafile server started"
- echo
-}
-
-seafile_stop() {
- if ! pgrep -f "seafile-controller -c ${seafile_ccnet}" 2>/dev/null 1>&2; then
- echo "Seafile is not running"
- return 1;
- fi
-
- echo "Stopping ${name}."
- pkill -SIGTERM -f "seafile-controller -c ${seafile_ccnet}"
- pkill -f "ccnet-server -c ${seafile_ccnet}"
- pkill -f "seaf-server -c ${seafile_ccnet}"
- pkill -f "fileserver -c ${seafile_ccnet}"
- pkill -f "soffice.*--invisible --nocrashreport"
- pkill -f "wsgidav.server.run_server"
- return 0
-}
-
-seafile_restart() {
- seafile_stop;
- sleep 2
- seafile_start;
-}
-
-run_rc_command "$1"
diff --git a/net-mgmt/seafile/pkg-plist b/net-mgmt/seafile/pkg-plist
deleted file mode 100644
index b424d80e85c4..000000000000
--- a/net-mgmt/seafile/pkg-plist
+++ /dev/null
@@ -1,113 +0,0 @@
-bin/seaf-cli
-bin/seaf-daemon
-bin/seafile-controller
-bin/seaf-server
-include/seafile/monitor-rpc.h
-include/seafile/seafile-object.h
-include/seafile/seafile-rpc.h
-include/seafile/seafile.h
-lib/libseafile.a
-lib/libseafile.so
-lib/libseafile.so.0
-lib/libseafile.so.0.0.0
-libdata/pkgconfig/libseafile.pc
-man/man1/seaf-cli.1.gz
-man/man1/seaf-daemon.1.gz
-%%SEAFILE_SERVER%%/check_init_admin.py
-%%SEAFILE_SERVER%%/reset-admin.sh
-%%SEAFILE_SERVER%%/seaf-fuse.sh
-%%SEAFILE_SERVER%%/seaf-gc.sh
-%%SEAFILE_SERVER%%/seafile.sh
-%%SEAFILE_SERVER%%/seafile/bin/seaf-fsck
-%%FUSE%%%%SEAFILE_SERVER%%/seafile/bin/seaf-fuse
-%%SEAFILE_SERVER%%/seafile/bin/seaf-cli.py
-%%SEAFILE_SERVER%%/seafile/bin/seaf-migrate
-%%SEAFILE_SERVER%%/seafile/bin/seaf-server
-%%SEAFILE_SERVER%%/seafile/bin/seaf-server-init
-%%SEAFILE_SERVER%%/seafile/bin/seafile-controller
-%%SEAFILE_SERVER%%/seafile/bin/seafserv-gc
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seafile/__init__.py
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seafile/__init__.pyc
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seafile/__init__.pyo
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seafile/rpcclient.py
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seafile/rpcclient.pyc
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seafile/rpcclient.pyo
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seaserv/__init__.py
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seaserv/__init__.pyc
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seaserv/__init__.pyo
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seaserv/api.py
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seaserv/api.pyc
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seaserv/api.pyo
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seaserv/service.py
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seaserv/service.pyc
-%%SEAFILE_SERVER%%/seafile/%%PYTHON_SITELIBDIR%%/seaserv/service.pyo
-%%PORTDOCS%%%%SEAFILE_SERVER%%/seafile/%%DOCSDIR%%/seafile-tutorial.doc
-%%SEAFILE_SERVER%%/breakpad.py
-%%SEAFILE_SERVER%%/seahub.sh
-%%SEAFILE_SERVER%%/setup-seafile-mysql.py
-%%SEAFILE_SERVER%%/setup-seafile-mysql.sh
-%%SEAFILE_SERVER%%/upgrade/add_collate.sh
-%%SEAFILE_SERVER%%/upgrade/db_update_1.3_1.4.py
-%%SEAFILE_SERVER%%/upgrade/db_update_helper.py
-%%SEAFILE_SERVER%%/upgrade/minor-upgrade.sh
-%%SEAFILE_SERVER%%/seaf-fsck.sh
-%%SEAFILE_SERVER%%/upgrade/fix_mysql_user.py
-%%SEAFILE_SERVER%%/upgrade/regenerate_secret_key.sh
-%%SEAFILE_SERVER%%/upgrade/sql/1.6.0/mysql/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/1.6.0/sqlite3/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/1.7.0/mysql/seafile.sql
-%%SEAFILE_SERVER%%/upgrade/sql/1.7.0/mysql/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/1.7.0/sqlite3/seafile.sql
-%%SEAFILE_SERVER%%/upgrade/sql/1.7.0/sqlite3/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/1.8.0/mysql/ccnet.sql
-%%SEAFILE_SERVER%%/upgrade/sql/1.8.0/mysql/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/1.8.0/sqlite3/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/2.0.0/mysql/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/2.0.0/sqlite3/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/2.1.0/mysql/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/2.1.0/sqlite3/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/2.2.0/mysql/ccnet.sql
-%%SEAFILE_SERVER%%/upgrade/sql/3.0.0/mysql/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/3.0.0/sqlite3/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/3.1.0/mysql/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/3.1.0/sqlite3/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/4.1.0/mysql/ccnet.sql
-%%SEAFILE_SERVER%%/upgrade/sql/4.1.0/mysql/seafile.sql
-%%SEAFILE_SERVER%%/upgrade/sql/4.1.0/sqlite3/ccnet/groupmgr.sql
-%%SEAFILE_SERVER%%/upgrade/sql/4.1.0/sqlite3/seafile.sql
-%%SEAFILE_SERVER%%/upgrade/sql/4.2.0/mysql/seafile.sql
-%%SEAFILE_SERVER%%/upgrade/sql/4.2.0/mysql/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/4.2.0/sqlite3/seafile.sql
-%%SEAFILE_SERVER%%/upgrade/sql/4.2.0/sqlite3/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/4.3.0/mysql/.gitkeep
-%%SEAFILE_SERVER%%/upgrade/sql/4.3.0/sqlite3/.gitkeep
-%%SEAFILE_SERVER%%/upgrade/sql/4.4.0/mysql/.gitkeep
-%%SEAFILE_SERVER%%/upgrade/sql/4.4.0/sqlite3/.gitkeep
-%%SEAFILE_SERVER%%/upgrade/upgrade_1.2_1.3.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_1.3_1.4.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_1.4_1.5.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_1.5_1.6.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_1.6_1.7.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_1.7_1.8.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_1.8_2.0.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_2.0_2.1.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_2.1_2.2.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_2.2_3.0.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_3.0_3.1.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_3.1_4.0.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_4.0_4.1.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_4.1_4.2.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_4.2_4.3.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_4.3_4.4.sh
-%%SEAFILE_SERVER%%/upgrade/sql/5.0.0/mysql/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/5.0.0/sqlite3/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/5.1.0/mysql/seafile.sql
-%%SEAFILE_SERVER%%/upgrade/sql/5.1.0/mysql/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/5.1.0/sqlite3/seafile.sql
-%%SEAFILE_SERVER%%/upgrade/sql/5.1.0/sqlite3/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/6.0.0/mysql/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/sql/6.0.0/sqlite3/seahub.sql
-%%SEAFILE_SERVER%%/upgrade/upgrade_5.1_6.0.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_5.0_5.1.sh
-%%SEAFILE_SERVER%%/upgrade/upgrade_4.4_5.0.sh
-@dir(%%USERS%%,%%GROUPS%%,755) %%HAIWENDIR%%