aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-28 10:42:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-28 10:42:36 +0000
commit6d1757413f12822c95b5a71e243bf6e322a311ab (patch)
tree0fd7d7ecd8790dc231317e05dc004d8c907a04c2
parentb51d0320af3b448f097c4ed68a823f304cfbfc68 (diff)
downloadports-6d1757413f12822c95b5a71e243bf6e322a311ab.tar.gz
ports-6d1757413f12822c95b5a71e243bf6e322a311ab.zip
Notes
-rw-r--r--games/Makefile1
-rw-r--r--games/openalchemist/Makefile27
-rw-r--r--games/openalchemist/distinfo3
-rw-r--r--games/openalchemist/files/patch-KeyboardKey.h11
-rw-r--r--games/openalchemist/files/patch-Makefile48
-rw-r--r--games/openalchemist/files/patch-game.h82
-rw-r--r--games/openalchemist/files/patch-piece.h17
-rw-r--r--games/openalchemist/pkg-descr6
-rw-r--r--games/openalchemist/pkg-plist6
9 files changed, 201 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 0cee1ed4c6e3..e22d29730730 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -538,6 +538,7 @@
SUBDIR += oneko-sakura
SUBDIR += oolite
SUBDIR += oonsoo
+ SUBDIR += openalchemist
SUBDIR += openarena
SUBDIR += openastromenace
SUBDIR += opencity
diff --git a/games/openalchemist/Makefile b/games/openalchemist/Makefile
new file mode 100644
index 000000000000..ee28f04e7a21
--- /dev/null
+++ b/games/openalchemist/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: openalchemist
+# Date created: Sat Oct 01 09:30:00 UTC 2003
+# Whom: Ganael LAPLANCHE <ganael.laplanche@martymac.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openalchemist
+PORTVERSION= 0.2
+CATEGORIES= games
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}-${PORTVERSION}-src
+
+MAINTAINER= ganael.laplanche@martymac.com
+COMMENT= Tetris-like game
+
+BUILD_DEPENDS= zip:${PORTSDIR}/archivers/zip
+LIB_DEPENDS= clanCore-0.8:${PORTSDIR}/devel/clanlib
+
+USE_GNOME= pkgconfig
+MAKE_ENV+= PTHREAD_LIBS="${PTHREAD_LIBS}"
+
+# Allow relocation of skins (by default, must be in the skins/ sub-dir)
+post-patch:
+ @${REINPLACE_CMD} -E -e 's|CL_System::get_exe_path\(\) \+ "skins/|"${PREFIX}/share/games/${PORTNAME}/skins/|g' ${WRKSRC}/src/*.cpp
+
+.include <bsd.port.mk>
diff --git a/games/openalchemist/distinfo b/games/openalchemist/distinfo
new file mode 100644
index 000000000000..92bf227bb413
--- /dev/null
+++ b/games/openalchemist/distinfo
@@ -0,0 +1,3 @@
+MD5 (openalchemist-0.2-src.tar.gz) = fc2ddfa6b37a6573fb262363804f0c84
+SHA256 (openalchemist-0.2-src.tar.gz) = 5b81dead3532394683a3cec3f5164543ba9fd191ad54f5c1d8329442cea89b29
+SIZE (openalchemist-0.2-src.tar.gz) = 2468509
diff --git a/games/openalchemist/files/patch-KeyboardKey.h b/games/openalchemist/files/patch-KeyboardKey.h
new file mode 100644
index 000000000000..09feb62199a1
--- /dev/null
+++ b/games/openalchemist/files/patch-KeyboardKey.h
@@ -0,0 +1,11 @@
+--- includes/KeyboardKey.h.orig 2008-03-18 17:51:54.744835728 +0100
++++ includes/KeyboardKey.h 2008-03-18 17:52:13.290787518 +0100
+@@ -38,7 +38,7 @@
+ /**
+ * Constructor
+ */
+- KeyboardKey::KeyboardKey(int key, bool repeat = false)
++ KeyboardKey(int key, bool repeat = false)
+ {
+ this->key = key;
+ this->repeat = repeat;
diff --git a/games/openalchemist/files/patch-Makefile b/games/openalchemist/files/patch-Makefile
new file mode 100644
index 000000000000..be4c2f6ef8d2
--- /dev/null
+++ b/games/openalchemist/files/patch-Makefile
@@ -0,0 +1,48 @@
+--- Makefile.orig 2006-08-13 19:18:16.000000000 +0200
++++ Makefile 2008-03-26 19:27:29.000000000 +0100
+@@ -1,15 +1,13 @@
+ PACKAGES = clanCore-0.8 clanDisplay-0.8 clanApp-0.8 clanGL-0.8 clanSDL-0.8
+-LIBS = `pkg-config --libs $(PACKAGES)`
+-OPTIONS = -Iincludes -Wall -g
++LIBS = `pkg-config --libs $(PACKAGES)` $(PTHREAD_LIBS)
++OPTIONS = -Iincludes -I/usr/local/include -Wall -g
+ LINKER_OPTIONS = #-u malloc -lefence
+ STATIC_LIBS = `pkg-config --libs $(PACKAGES) --static`
+ CFLAGS = `pkg-config --cflags $(PACKAGES)`
+
+-INSTALL_DIR = /usr/local/games/openalchemist
+-
+ all: openalchemist
+ @echo "OK"
+-
++
+ test:
+ @echo "Test dependances installation"
+ pkg-config --exists $(PACKAGES)
+@@ -60,20 +58,13 @@
+ -rm openalchemist
+ -rm skins/aqua.zip
+ -rm skins/brushed.zip
+-
++
+ install: openalchemist
+- mkdir $(INSTALL_DIR)
+- mkdir $(INSTALL_DIR)/skins
+- cp openalchemist $(INSTALL_DIR)/
+- cp skins/aqua.zip $(INSTALL_DIR)/skins/aqua.zip
+- cp skins/brushed.zip $(INSTALL_DIR)/skins/brushed.zip
+- ln -s $(INSTALL_DIR)/openalchemist /usr/local/bin/openalchemist
+-
+-uninstall: $(INSTALL_DIR)
+- rm $(INSTALL_DIR)/* -R
+- rmdir $(INSTALL_DIR)
+- rm /usr/local/bin/openalchemist
+-
++ mkdir -p $(PREFIX)/bin
++ mkdir -p $(PREFIX)/share/games/openalchemist/skins
++ cp openalchemist $(PREFIX)/bin/
++ cp skins/aqua.zip $(PREFIX)/share/games/openalchemist/skins/aqua.zip
++ cp skins/brushed.zip $(PREFIX)/share/games/openalchemist/skins/brushed.zip
+
+ static: includes/*.h bin/main.o bin/game.o bin/key_events.o bin/detect_to_destroy.o bin/detect_to_fall.o bin/drawing.o bin/hightscores.o bin/pause.o bin/preferences.o bin/skins-selector.o skins/aqua.zip skins/brushed.zip
+ @echo "On assemble le fichier final"
diff --git a/games/openalchemist/files/patch-game.h b/games/openalchemist/files/patch-game.h
new file mode 100644
index 000000000000..e01c655c3aba
--- /dev/null
+++ b/games/openalchemist/files/patch-game.h
@@ -0,0 +1,82 @@
+--- includes/game.h.orig 2008-03-18 17:50:34.816043102 +0100
++++ includes/game.h 2008-03-18 17:50:57.531984095 +0100
+@@ -219,47 +219,47 @@
+ public:
+
+ //Constructor
+- Game::Game(CL_DisplayWindow *window, bool opengl);
++ Game(CL_DisplayWindow *window, bool opengl);
+ //Destructor
+- Game::~Game();
++ ~Game();
+
+ // Some methods
+- void Game::choose_skin();
+- void Game::load_gfx();
+- void Game::unload_gfx();
+- void Game::toggle_screen();
+- void Game::main_loop();
++ void choose_skin();
++ void load_gfx();
++ void unload_gfx();
++ void toggle_screen();
++ void main_loop();
+
+ // Methods to draw the game
+- void Game::draw_game();
+- void Game::draw_playing();
+- void Game::draw_falling();
+- void Game::draw_destroying();
+- void Game::draw_to_playing();
+- void Game::draw_game_over();
+- void Game::draw_new_hightscore();
+- void Game::draw_pause();
++ void draw_game();
++ void draw_playing();
++ void draw_falling();
++ void draw_destroying();
++ void draw_to_playing();
++ void draw_game_over();
++ void draw_new_hightscore();
++ void draw_pause();
+
+- void Game::draw_progress_bar();
+- void Game::draw_skins_selector();
++ void draw_progress_bar();
++ void draw_skins_selector();
+
+- void Game::calc_score();
++ void calc_score();
+
+- void Game::load_preferences();
+- void Game::save_preferences();
+- void Game::read_scores();
+- void Game::save_scores();
+- void Game::key_events();
+- void Game::key_events_playing();
+- void Game::key_events_pause();
+- void Game::key_events_skins_selector();
+- void Game::undo_last();
+- void Game::new_game(short difficulty);
+- void Game::fall();
+- void Game::detect_to_destroy();
+- void Game::detect_to_fall();
++ void load_preferences();
++ void save_preferences();
++ void read_scores();
++ void save_scores();
++ void key_events();
++ void key_events_playing();
++ void key_events_pause();
++ void key_events_skins_selector();
++ void undo_last();
++ void new_game(short difficulty);
++ void fall();
++ void detect_to_destroy();
++ void detect_to_fall();
+
+- void Game::stop();
++ void stop();
+
+ };
+
diff --git a/games/openalchemist/files/patch-piece.h b/games/openalchemist/files/patch-piece.h
new file mode 100644
index 000000000000..df77222a0af5
--- /dev/null
+++ b/games/openalchemist/files/patch-piece.h
@@ -0,0 +1,17 @@
+--- includes/piece.h.orig 2008-03-18 17:51:15.254937990 +0100
++++ includes/piece.h 2008-03-18 17:51:38.315878696 +0100
+@@ -81,12 +81,12 @@
+ }
+
+ // Methods to display - be carefull, if current_prite is not initialized
+- void Piece::draw(CL_GraphicContext* context = 0)
++ void draw(CL_GraphicContext* context = 0)
+ {
+ current_sprite -> draw(x, y, context);
+ }
+
+- void Piece::draw_mini(CL_GraphicContext* context = 0)
++ void draw_mini(CL_GraphicContext* context = 0)
+ {
+ mini_sprite -> draw(x, y, context);
+ }
diff --git a/games/openalchemist/pkg-descr b/games/openalchemist/pkg-descr
new file mode 100644
index 000000000000..8dff95a8b1bf
--- /dev/null
+++ b/games/openalchemist/pkg-descr
@@ -0,0 +1,6 @@
+OpenAlchemist is a Tetris-like game developped with
+the Clanlib framework. Its goal is to reimplement the
+game www.naturalchimie.com with free software and
+free licenses.
+
+WWW: http://openalchemist.sourceforge.net
diff --git a/games/openalchemist/pkg-plist b/games/openalchemist/pkg-plist
new file mode 100644
index 000000000000..f224fe4cf4ba
--- /dev/null
+++ b/games/openalchemist/pkg-plist
@@ -0,0 +1,6 @@
+bin/openalchemist
+share/games/openalchemist/skins/aqua.zip
+share/games/openalchemist/skins/brushed.zip
+@dirrm share/games/openalchemist/skins
+@dirrm share/games/openalchemist
+@dirrmtry share/games