aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2016-09-01 13:25:49 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2016-09-01 13:25:49 +0000
commit6d46f34aa3485070a91240ecd48c7d027266837c (patch)
treeff53f4571dcb5d0e31b2c1e4a761d292dbd2e8f7
parente9d553e07835bba537349f4b86cbe3478606432c (diff)
downloadports-6d46f34aa3485070a91240ecd48c7d027266837c.tar.gz
ports-6d46f34aa3485070a91240ecd48c7d027266837c.zip
Notes
-rw-r--r--math/cryptominisat/Makefile6
-rw-r--r--math/cryptominisat/distinfo5
-rw-r--r--math/cryptominisat/files/patch-src_dimacsparser.cpp11
-rw-r--r--math/cryptominisat/files/patch-src_dimacsparser.h10
-rw-r--r--math/cryptominisat/pkg-descr2
-rw-r--r--math/cryptominisat/pkg-plist19
-rw-r--r--math/py-cryptominisat/Makefile5
-rw-r--r--math/py-cryptominisat/distinfo5
-rw-r--r--math/py-cryptominisat/files/patch-setup.py.in33
9 files changed, 43 insertions, 53 deletions
diff --git a/math/cryptominisat/Makefile b/math/cryptominisat/Makefile
index 2a4a38f1c2de..dc966946f86c 100644
--- a/math/cryptominisat/Makefile
+++ b/math/cryptominisat/Makefile
@@ -1,14 +1,14 @@
# $FreeBSD$
PORTNAME= cryptominisat
-PORTVERSION= 4.5.3
+PORTVERSION= 5.0.0
CATEGORIES= math
MAINTAINER= 6yearold@gmail.com
COMMENT= General-purpose award-winning SAT solver
LICENSE= LGPL3
-LICENSE_FILE= ${WRKSRC}/LICENSE-LGPL
+LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= xxd:editors/vim-lite # for xxd tool
LIB_DEPENDS= libboost_program_options.so:devel/boost-libs
@@ -19,6 +19,6 @@ GH_ACCOUNT= msoos
USES= cmake compiler:c++11-lib
USE_LDCONFIG= yes
-CMAKE_ARGS= -DNOMYSQL=1 -DNOM4RI=1 -DPYTHON_EXECUTABLE=0
+CMAKE_ARGS= -DNOM4RI=1 -DENABLE_PYTHON_INTERFACE=OFF
.include <bsd.port.mk>
diff --git a/math/cryptominisat/distinfo b/math/cryptominisat/distinfo
index 0991145bbc4c..57e3fb7a58df 100644
--- a/math/cryptominisat/distinfo
+++ b/math/cryptominisat/distinfo
@@ -1,2 +1,3 @@
-SHA256 (msoos-cryptominisat-4.5.3_GH0.tar.gz) = 114da20e25734dc368dada47afd8cb7d44717f2159ad66d5bac742062fa3eb4c
-SIZE (msoos-cryptominisat-4.5.3_GH0.tar.gz) = 467221
+TIMESTAMP = 1469882294
+SHA256 (msoos-cryptominisat-5.0.0_GH0.tar.gz) = 4c000daf9886e7c55f05b00247688ed0341a19cda13de49e2f35f40e95cc9910
+SIZE (msoos-cryptominisat-5.0.0_GH0.tar.gz) = 596712
diff --git a/math/cryptominisat/files/patch-src_dimacsparser.cpp b/math/cryptominisat/files/patch-src_dimacsparser.cpp
deleted file mode 100644
index cda2ef6fa3e5..000000000000
--- a/math/cryptominisat/files/patch-src_dimacsparser.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/dimacsparser.cpp.orig 2015-08-26 23:32:30 UTC
-+++ src/dimacsparser.cpp
-@@ -126,7 +126,7 @@ void DimacsParser::readClause(StreamBuff
- for (;;) {
- parsed_lit = parseInt(in);
- if (parsed_lit == 0) break;
-- var = abs(parsed_lit)-1;
-+ var = std::abs(parsed_lit)-1;
- if (var >= (1ULL<<28)) {
- std::cerr
- << "ERROR! "
diff --git a/math/cryptominisat/files/patch-src_dimacsparser.h b/math/cryptominisat/files/patch-src_dimacsparser.h
deleted file mode 100644
index cde87f7a8b13..000000000000
--- a/math/cryptominisat/files/patch-src_dimacsparser.h
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/dimacsparser.h.orig 2016-01-05 09:44:15 UTC
-+++ src/dimacsparser.h
-@@ -25,6 +25,7 @@ THE SOFTWARE.
- #define DIMACSPARSER_H
-
- #include <string>
-+#include <cstdlib>
- #include "streambuffer.h"
- #include "cryptominisat4/cryptominisat.h"
-
diff --git a/math/cryptominisat/pkg-descr b/math/cryptominisat/pkg-descr
index 8b829dd0a584..0c9c807e4365 100644
--- a/math/cryptominisat/pkg-descr
+++ b/math/cryptominisat/pkg-descr
@@ -3,4 +3,4 @@ solver, featuring over 100 configurable parameters to tune to specific
need, collection of statistical data to MySQL database + javascript-based
visualization of it and clean C++ and python interfaces.
-WWW: http://www.msoos.org/cryptominisat4/
+WWW: https://github.com/msoos/cryptominisat/
diff --git a/math/cryptominisat/pkg-plist b/math/cryptominisat/pkg-plist
index cecaefc10e18..aad11be2fc33 100644
--- a/math/cryptominisat/pkg-plist
+++ b/math/cryptominisat/pkg-plist
@@ -1,10 +1,9 @@
-bin/cryptominisat4
-bin/cryptominisat4_simple
-include/cryptominisat4/cryptominisat.h
-include/cryptominisat4/solvertypesmini.h
-lib/cmake/cryptominisat4/cryptominisat4Config.cmake
-lib/cmake/cryptominisat4/cryptominisat4Targets-%%CMAKE_BUILD_TYPE%%.cmake
-lib/cmake/cryptominisat4/cryptominisat4Targets.cmake
-lib/libcryptominisat4.a
-lib/libcryptominisat4.so
-lib/libcryptominisat4.so.4.5
+bin/cryptominisat5
+bin/cryptominisat5_simple
+include/cryptominisat5/cryptominisat.h
+include/cryptominisat5/solvertypesmini.h
+lib/cmake/cryptominisat5/cryptominisat5Config.cmake
+lib/cmake/cryptominisat5/cryptominisat5Targets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/cryptominisat5/cryptominisat5Targets.cmake
+lib/libcryptominisat5.so
+lib/libcryptominisat5.so.5.0
diff --git a/math/py-cryptominisat/Makefile b/math/py-cryptominisat/Makefile
index e3ed2b38094a..bbdd0e6e2e14 100644
--- a/math/py-cryptominisat/Makefile
+++ b/math/py-cryptominisat/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= cryptominisat
-PORTVERSION= 4.5.3
+PORTVERSION= 5.0.0
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,7 +11,7 @@ COMMENT= Bindings to CryptoMiniSat (a SAT solver)
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libcryptominisat4.so:math/cryptominisat
+LIB_DEPENDS= libcryptominisat5.so:math/cryptominisat
USES= compiler:c++11-lang python:-2.7
USE_PYTHON= autoplist distutils
@@ -24,6 +24,7 @@ WRKSRC_SUBDIR= python
PYDISTUTILS_BUILDTARGET= build_ext --include-dirs=${LOCALBASE}/include
post-patch:
+ ${REINPLACE_CMD} -e 's|@PROJECT_VERSION@|${PORTVERSION}|' ${WRKSRC}/setup.py.in
${CP} ${WRKSRC}/setup.py.in ${WRKSRC}/setup.py
post-install:
diff --git a/math/py-cryptominisat/distinfo b/math/py-cryptominisat/distinfo
index 0991145bbc4c..91a4e803148a 100644
--- a/math/py-cryptominisat/distinfo
+++ b/math/py-cryptominisat/distinfo
@@ -1,2 +1,3 @@
-SHA256 (msoos-cryptominisat-4.5.3_GH0.tar.gz) = 114da20e25734dc368dada47afd8cb7d44717f2159ad66d5bac742062fa3eb4c
-SIZE (msoos-cryptominisat-4.5.3_GH0.tar.gz) = 467221
+TIMESTAMP = 1469896511
+SHA256 (msoos-cryptominisat-5.0.0_GH0.tar.gz) = 4c000daf9886e7c55f05b00247688ed0341a19cda13de49e2f35f40e95cc9910
+SIZE (msoos-cryptominisat-5.0.0_GH0.tar.gz) = 596712
diff --git a/math/py-cryptominisat/files/patch-setup.py.in b/math/py-cryptominisat/files/patch-setup.py.in
index 660ac75c2a82..a4aebe2d558c 100644
--- a/math/py-cryptominisat/files/patch-setup.py.in
+++ b/math/py-cryptominisat/files/patch-setup.py.in
@@ -1,28 +1,37 @@
---- setup.py.in.orig 2015-08-26 23:32:30 UTC
+--- setup.py.in.orig 2016-07-06 12:22:54 UTC
+++ setup.py.in
-@@ -51,15 +51,15 @@ def _init_posix(init):
- return wrapper
- sysconfig._init_posix = _init_posix(sysconfig._init_posix)
+@@ -26,9 +26,9 @@ import sys
+ from distutils.core import setup, Extension
+ from distutils import sysconfig
--__version__ = '@PROJECT_VERSION@'
-+__version__ = '4.5.3'
+-cconf = """${PY_C_CONFIG}""".split(" ")
+-ldconf = """${PY_LD_CONFIG}""".split(" ")
+-is_apple = """${APPLE}"""
++cconf = """""".split(" ")
++ldconf = """""".split(" ")
++is_apple = """"""
+
+ def cleanup(dat):
+ ret = []
+@@ -81,12 +81,12 @@ __version__ = '@PROJECT_VERSION@'
ext_kwds = dict(
name = "pycryptosat",
- sources = ["${CMAKE_CURRENT_SOURCE_DIR}/pycryptosat.cpp"],
+ sources = ["pycryptosat.cpp"],
define_macros = [],
-- extra_compile_args = ['-I${PROJECT_SOURCE_DIR}', '-I${PROJECT_BINARY_DIR}/cmsat4-src'],
-+ extra_compile_args = ['-I/usr/local/include', '-I..cmsat4-src'],
+- extra_compile_args = cconf + ['-I${PROJECT_SOURCE_DIR}', '-I${PROJECT_BINARY_DIR}/cmsat5-src'],
++ extra_compile_args = cconf + ['-I/usr/local/include', '-I../cmsat5-src'],
+ extra_link_args = ldconf,
language = "c++",
-- library_dirs=['.', '/usr/local/lib', '${PROJECT_BINARY_DIR}/lib'],
+- library_dirs=['.', '${PROJECT_BINARY_DIR}/lib'],
+ library_dirs=['.', '/usr/local/lib'],
- libraries = ['cryptominisat4']
+ libraries = ['cryptominisat5']
)
-@@ -84,5 +84,5 @@ setup(
+@@ -111,5 +111,5 @@ setup(
ext_modules = [Extension(**ext_kwds)],
- py_modules = ['test_pycryptosat'],
+ py_modules = ['pycryptosat'],
description = "bindings to CryptoMiniSat (a SAT solver)",
- long_description = open('${CMAKE_CURRENT_SOURCE_DIR}/README.rst').read(),
+ long_description = open('README.rst').read(),