aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-07-27 14:59:08 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-07-27 14:59:08 +0000
commit6df2d7e29ff48b1a71a086f1bbe165bc39871843 (patch)
tree2827165c2f9be9f8076cf5420461d22b02bc0809
parent5c99b95cb18d8341a59dcbe76fa1d2585aca84de (diff)
downloadports-6df2d7e29ff48b1a71a086f1bbe165bc39871843.tar.gz
ports-6df2d7e29ff48b1a71a086f1bbe165bc39871843.zip
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Cisco-IPPhone/Makefile22
-rw-r--r--net/p5-Cisco-IPPhone/distinfo3
-rw-r--r--net/p5-Cisco-IPPhone/pkg-descr10
-rw-r--r--net/p5-Cisco-IPPhone/pkg-plist5
5 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f51ff3168a13..9de037be2715 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -415,6 +415,7 @@
SUBDIR += p5-BBS-UserInfo-Ptt
SUBDIR += p5-BBS-UserInfo-SOB
SUBDIR += p5-BBS-UserInfo-Wretch
+ SUBDIR += p5-Cisco-IPPhone
SUBDIR += p5-EasyTCP
SUBDIR += p5-File-Rsync
SUBDIR += p5-File-RsyncP
diff --git a/net/p5-Cisco-IPPhone/Makefile b/net/p5-Cisco-IPPhone/Makefile
new file mode 100644
index 000000000000..279a31aa1e07
--- /dev/null
+++ b/net/p5-Cisco-IPPhone/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Cisco-IPPhone
+# Date created: July 27th 2007
+# Whom: Simun Mikecin < numisemis at yahoo dot com >
+#
+# $FreeBSD$
+#
+
+PORTNAME= Cisco-IPPhone
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Cisco
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= numisemis@yahoo.com
+COMMENT= Package for creating Cisco IPPhone XML objects
+
+PERL_CONFIGURE= yes
+
+MAN3= Cisco::IPPhone.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Cisco-IPPhone/distinfo b/net/p5-Cisco-IPPhone/distinfo
new file mode 100644
index 000000000000..1f940abec02b
--- /dev/null
+++ b/net/p5-Cisco-IPPhone/distinfo
@@ -0,0 +1,3 @@
+MD5 (Cisco-IPPhone-0.05.tar.gz) = baeafa8bd0a35b1af5156c63e180fef1
+SHA256 (Cisco-IPPhone-0.05.tar.gz) = b03ca263f8f41a6ec545c5393213a3146d36bd45335ade99af51dd42ab6ee16d
+SIZE (Cisco-IPPhone-0.05.tar.gz) = 175465
diff --git a/net/p5-Cisco-IPPhone/pkg-descr b/net/p5-Cisco-IPPhone/pkg-descr
new file mode 100644
index 000000000000..88bab2bfe9d4
--- /dev/null
+++ b/net/p5-Cisco-IPPhone/pkg-descr
@@ -0,0 +1,10 @@
+This Cisco IPPhone module was created to provide a simple convenient
+method to display Cisco IP Phone objects and gather input from a Cisco
+7940 or 7960 IP Phone. This module supports all known Cisco XML objects
+for 7940 and 7960 phones. Knowledge of Cisco XML syntax is not a
+requirement.
+
+This Perl module gives the ability to use simple PERL objects to display XML
+on the IP Phone unlike to Cisco Software Development Kit (SDK) which uses
+Microsoft IIS Server, ASP's, JSP's, Javascript, COM Objects, and requires
+knowledge of XML syntax.
diff --git a/net/p5-Cisco-IPPhone/pkg-plist b/net/p5-Cisco-IPPhone/pkg-plist
new file mode 100644
index 000000000000..4667a02dd649
--- /dev/null
+++ b/net/p5-Cisco-IPPhone/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco/IPPhone/.packlist
+%%SITE_PERL%%/Cisco/IPPhone.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco/IPPhone
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Cisco
+@dirrmtry %%SITE_PERL%%/Cisco