aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>2002-05-08 09:43:25 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>2002-05-08 09:43:25 +0000
commit6e00646ed6ba2d5355fa406f1be533968491c303 (patch)
tree0baa969ac6b8ca8fa5fad43ea09297862e842cce
parentb338c943c00c6074d0ed053832da4bc4fdbc0deb (diff)
downloadports-6e00646ed6ba2d5355fa406f1be533968491c303.tar.gz
ports-6e00646ed6ba2d5355fa406f1be533968491c303.zip
Notes
-rw-r--r--security/Makefile1
-rw-r--r--security/authforce/Makefile29
-rw-r--r--security/authforce/distinfo1
-rw-r--r--security/authforce/files/patch-aa11
-rw-r--r--security/authforce/files/patch-ab10
-rw-r--r--security/authforce/files/patch-ac10
-rw-r--r--security/authforce/files/patch-ad11
-rw-r--r--security/authforce/pkg-comment1
-rw-r--r--security/authforce/pkg-descr8
-rw-r--r--security/authforce/pkg-plist12
10 files changed, 94 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index bc5c01c9250a..fba30cc518ef 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -10,6 +10,7 @@
SUBDIR += apg
SUBDIR += arirang
SUBDIR += audit
+ SUBDIR += authforce
SUBDIR += bcwipe
SUBDIR += beecrypt
SUBDIR += bfbtester
diff --git a/security/authforce/Makefile b/security/authforce/Makefile
new file mode 100644
index 000000000000..967e43cbf80b
--- /dev/null
+++ b/security/authforce/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: authforce
+# Date created: 08.05.2002
+# Whom: Andrey A. Chernov <ache@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= authforce
+PORTVERSION= 0.9.6
+CATEGORIES= security www
+MASTER_SITES= http://kapheine.hypa.net/authforce/
+
+MAINTAINER= ache@FreeBSD.org
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ curl.2:${PORTSDIR}/ftp/curl \
+ intl.2:${PORTSDIR}/devel/gettext
+
+USE_BZIP2= yes
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib" \
+ LIBS="-lgnugetopt -lintl"
+
+MAN1= authforce.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/security/authforce/distinfo b/security/authforce/distinfo
new file mode 100644
index 000000000000..2510302e6cd3
--- /dev/null
+++ b/security/authforce/distinfo
@@ -0,0 +1 @@
+MD5 (authforce-0.9.6.tar.bz2) = 80afaa64afb43ddbecf0209e4d109124
diff --git a/security/authforce/files/patch-aa b/security/authforce/files/patch-aa
new file mode 100644
index 000000000000..bc229b43722a
--- /dev/null
+++ b/security/authforce/files/patch-aa
@@ -0,0 +1,11 @@
+--- src/extract.c.bak Wed Feb 14 01:54:53 2001
++++ src/extract.c Wed May 8 12:34:16 2002
+@@ -20,7 +20,7 @@
+ #include <config.h>
+ #include <stdio.h>
+ #include <string.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #ifdef MEMWATCH
+ #include "memwatch.h"
+ #endif /* MEMWATCH */
diff --git a/security/authforce/files/patch-ab b/security/authforce/files/patch-ab
new file mode 100644
index 000000000000..693aa76d1a45
--- /dev/null
+++ b/security/authforce/files/patch-ab
@@ -0,0 +1,10 @@
+--- src/methods.c.bak Mon May 7 01:02:47 2001
++++ src/methods.c Wed May 8 12:34:16 2002
+@@ -5,7 +5,6 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
+-#include <malloc.h>
+ #ifdef MEMWATCH
+ #include "memwatch.h"
+ #endif /* MEMWATCH */
diff --git a/security/authforce/files/patch-ac b/security/authforce/files/patch-ac
new file mode 100644
index 000000000000..79ed97718441
--- /dev/null
+++ b/security/authforce/files/patch-ac
@@ -0,0 +1,10 @@
+--- src/misc.c.bak Wed Feb 14 01:54:53 2001
++++ src/misc.c Wed May 8 12:34:16 2002
+@@ -3,7 +3,6 @@
+ #include <config.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+-#include <malloc.h>
+ #include <string.h>
+ #include <ctype.h>
+ #ifdef MEMWATCH
diff --git a/security/authforce/files/patch-ad b/security/authforce/files/patch-ad
new file mode 100644
index 000000000000..00b13bd45400
--- /dev/null
+++ b/security/authforce/files/patch-ad
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.bak Sat May 12 22:37:55 2001
++++ doc/Makefile.in Wed May 8 13:15:17 2002
+@@ -101,7 +101,7 @@
+ INFO_DEPS = authforce.info
+ DVIS = authforce.dvi
+ TEXINFOS = authforce.texi
+-mangdir = $(mandir)/mang
++mangdir = $(mandir)/man1
+ MANS = $(man_MANS)
+
+ NROFF = nroff
diff --git a/security/authforce/pkg-comment b/security/authforce/pkg-comment
new file mode 100644
index 000000000000..5645b38a9f6e
--- /dev/null
+++ b/security/authforce/pkg-comment
@@ -0,0 +1 @@
+HTTP authentication brute forcer
diff --git a/security/authforce/pkg-descr b/security/authforce/pkg-descr
new file mode 100644
index 000000000000..ad178746099b
--- /dev/null
+++ b/security/authforce/pkg-descr
@@ -0,0 +1,8 @@
+Authforce is an HTTP authentication brute forcer. Using various methods,
+it attempts brute force username and password pairs for a site. It has
+the ability to try common username and passwords, username derivations,
+and common username/password pairs. It is used to both test the security
+of your site and to prove the insecurity of HTTP authentication based on
+the fact that users just don't pick good passwords.
+
+WWW: http://kapheine.hypa.net/authforce/
diff --git a/security/authforce/pkg-plist b/security/authforce/pkg-plist
new file mode 100644
index 000000000000..f96434bb9d14
--- /dev/null
+++ b/security/authforce/pkg-plist
@@ -0,0 +1,12 @@
+bin/authforce
+@unexec install-info --delete %D/info/authforce.info %D/info/dir
+info/authforce.info
+@exec install-info %D/info/authforce.info %D/info/dir
+share/authforce/data/blank.lst
+share/authforce/data/dummy.lst
+share/authforce/data/password.lst
+share/authforce/data/username.lst
+share/authforce/data/userpass.lst
+share/locale/nl/LC_MESSAGES/authforce.mo
+@dirrm share/authforce/data
+@dirrm share/authforce