aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-07-06 07:04:10 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-07-06 07:04:10 +0000
commit6e7a0fc2d7dd80c321935125e7424a354f5e2475 (patch)
treeb2d24dce6dba67101c281c6825acef0055a9a906
parentb9e237260cf0e15e231b5d939400865dbe60cf4e (diff)
downloadports-6e7a0fc2d7dd80c321935125e7424a354f5e2475.tar.gz
ports-6e7a0fc2d7dd80c321935125e7424a354f5e2475.zip
Notes
-rw-r--r--net/wireshark-lite/Makefile2
-rw-r--r--net/wireshark/Makefile9
-rw-r--r--net/wireshark/distinfo6
-rw-r--r--net/wireshark/files/patch-epan_crypt_airpdcap_interop.h14
-rw-r--r--net/wireshark/files/patch-tools_lemon_lemon.c10
-rw-r--r--net/wireshark/files/patch-wiretap_configure16
-rw-r--r--net/wireshark/pkg-plist9
7 files changed, 24 insertions, 42 deletions
diff --git a/net/wireshark-lite/Makefile b/net/wireshark-lite/Makefile
index bc645e095f58..5c82bf152fea 100644
--- a/net/wireshark-lite/Makefile
+++ b/net/wireshark-lite/Makefile
@@ -6,7 +6,7 @@
#
LITE= yes
-PORTREVISION?= 1
+PORTREVISION?= 0
PKGNAMESUFFIX= -lite
MASTERDIR= ${.CURDIR}/../wireshark
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 666f3b3a7065..4fee2a46ad20 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME?= wireshark
-PORTVERSION= 0.99.5
-PORTREVISION?= 3
+PORTVERSION= 0.99.6
+PORTREVISION?= 0
CATEGORIES= net ipv6
MASTER_SITES= http://www.wireshark.org/download/src/
DISTNAME= ${DATADIR_NAME}-${PORTVERSION}
@@ -29,7 +29,8 @@ USE_OPENSSL= yes
CONFIGURE_ENV= MIBDIRS="/dev/null" \
LIBS="${WIRESHARK_LIBS}"
CONFIGURE_ARGS+= --program-transform-name="" \
- --with-ssl=${OPENSSLBASE}
+ --with-ssl=${OPENSSLBASE} \
+ --mandir=${MANPREFIX}/man
MAKE_ENV= MIBDIRS="/dev/null"
USE_LDCONFIG= yes
DATADIR= ${PREFIX}/share/${DATADIR_NAME}
@@ -93,7 +94,7 @@ GNU_CONFIGURE= yes
LIBTOOLFILES= configure wiretap/configure
PLIST_SUB+= PORTVERSION=${PORTVERSION}
-.if ${OSVERSION} >= 400014 && !defined(WITHOUT_IPV6)
+.if !defined(WITHOUT_IPV6)
CONFIGURE_ARGS+= --enable-ipv6=yes
.else
CONFIGURE_ARGS+= --enable-ipv6=no
diff --git a/net/wireshark/distinfo b/net/wireshark/distinfo
index 46a12346733d..5b4e65019314 100644
--- a/net/wireshark/distinfo
+++ b/net/wireshark/distinfo
@@ -1,3 +1,3 @@
-MD5 (wireshark-0.99.5.tar.bz2) = ff067e0f2a0e0e53362bc6a943ff8622
-SHA256 (wireshark-0.99.5.tar.bz2) = 9801c0c974a646606c56935dfd1aa503c9b007c76a3f1709f69ba038daf5860e
-SIZE (wireshark-0.99.5.tar.bz2) = 11007039
+MD5 (wireshark-0.99.6.tar.bz2) = e57a8c8b364c38df3da97e2ee9f0d0bc
+SHA256 (wireshark-0.99.6.tar.bz2) = 118c4a5bfef00651fbe248e1d5c4e4f907b5e2982f47ccfecca2f7f48ab9d3b8
+SIZE (wireshark-0.99.6.tar.bz2) = 11826043
diff --git a/net/wireshark/files/patch-epan_crypt_airpdcap_interop.h b/net/wireshark/files/patch-epan_crypt_airpdcap_interop.h
deleted file mode 100644
index d7241445d7e3..000000000000
--- a/net/wireshark/files/patch-epan_crypt_airpdcap_interop.h
+++ /dev/null
@@ -1,14 +0,0 @@
---- epan/crypt/airpdcap_interop.h.orig Thu Feb 15 01:26:42 2007
-+++ epan/crypt/airpdcap_interop.h Thu Feb 15 01:27:00 2007
-@@ -85,9 +85,9 @@ typedef gchar CHAR;
- typedef guchar UCHAR;
- #endif
-
--#ifndef size_t
-+/*#ifndef size_t
- typedef gsize size_t;
--#endif
-+#endif*/
-
- #ifdef WIN32
- #include <winsock2.h> /* ntohs() */
diff --git a/net/wireshark/files/patch-tools_lemon_lemon.c b/net/wireshark/files/patch-tools_lemon_lemon.c
deleted file mode 100644
index 3fbd409974c8..000000000000
--- a/net/wireshark/files/patch-tools_lemon_lemon.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- tools/lemon/lemon.c.orig Sat Feb 10 01:09:11 2007
-+++ tools/lemon/lemon.c Sat Feb 10 01:09:33 2007
-@@ -2146,6 +2146,7 @@ to follow the previous rule.");
- struct rule *rp;
- rp = (struct rule *)malloc( sizeof(struct rule) +
- sizeof(struct symbol*)*psp->nrhs + sizeof(char*)*psp->nrhs );
-+ memset(rp, 0, sizeof(struct rule));
- if( rp==0 ){
- ErrorMsg(psp->filename,psp->tokenlineno,
- "Can't allocate enough memory for this rule.");
diff --git a/net/wireshark/files/patch-wiretap_configure b/net/wireshark/files/patch-wiretap_configure
index 420db3bf111d..c6ee204ad026 100644
--- a/net/wireshark/files/patch-wiretap_configure
+++ b/net/wireshark/files/patch-wiretap_configure
@@ -1,6 +1,6 @@
---- wiretap/configure.orig Sat May 7 21:04:37 2005
-+++ wiretap/configure Sat May 7 21:05:31 2005
-@@ -20092,7 +20092,7 @@
+--- wiretap/configure.orig Thu Jul 5 15:26:36 2007
++++ wiretap/configure Fri Jul 6 01:49:03 2007
+@@ -20570,7 +20570,7 @@ echo $ECHO_N "checking for GLIB - versio
ac_save_CFLAGS="$CFLAGS"
ac_save_LIBS="$LIBS"
CFLAGS="$CFLAGS $GLIB_CFLAGS"
@@ -9,12 +9,12 @@
rm -f conf.glibtest
if test "$cross_compiling" = yes; then
echo $ac_n "cross compiling; assumed OK... $ac_c"
-@@ -20206,7 +20206,7 @@
+@@ -20694,7 +20694,7 @@ fi
if test "x$no_glib" = x ; then
- echo "$as_me:$LINENO: result: yes" >&5
- echo "${ECHO_T}yes" >&6
+ { echo "$as_me:$LINENO: result: yes (version $glib_config_major_version.$glib_config_minor_version.$glib_config_micro_version)" >&5
+ echo "${ECHO_T}yes (version $glib_config_major_version.$glib_config_minor_version.$glib_config_micro_version)" >&6; }
- CFLAGS="$CFLAGS $GLIB_CFLAGS" LIBS="$LIBS $GLIB_LIBS"
+ CFLAGS="$CFLAGS $GLIB_CFLAGS" LIBS="$LIBS -liconv $GLIB_LIBS"
else
- echo "$as_me:$LINENO: result: no" >&5
- echo "${ECHO_T}no" >&6
+ { echo "$as_me:$LINENO: result: no" >&5
+ echo "${ECHO_T}no" >&6; }
diff --git a/net/wireshark/pkg-plist b/net/wireshark/pkg-plist
index e2885db72e51..8d80d9c78d71 100644
--- a/net/wireshark/pkg-plist
+++ b/net/wireshark/pkg-plist
@@ -32,12 +32,14 @@ lib/wireshark/plugins/%%PORTVERSION%%/irda.la
lib/wireshark/plugins/%%PORTVERSION%%/irda.so
lib/wireshark/plugins/%%PORTVERSION%%/lwres.la
lib/wireshark/plugins/%%PORTVERSION%%/lwres.so
+lib/wireshark/plugins/%%PORTVERSION%%/m2m.la
+lib/wireshark/plugins/%%PORTVERSION%%/m2m.so
lib/wireshark/plugins/%%PORTVERSION%%/mate.la
lib/wireshark/plugins/%%PORTVERSION%%/mate.so
-lib/wireshark/plugins/%%PORTVERSION%%/megaco.la
-lib/wireshark/plugins/%%PORTVERSION%%/megaco.so
lib/wireshark/plugins/%%PORTVERSION%%/mgcp.la
lib/wireshark/plugins/%%PORTVERSION%%/mgcp.so
+lib/wireshark/plugins/%%PORTVERSION%%/opcua.la
+lib/wireshark/plugins/%%PORTVERSION%%/opcua.so
lib/wireshark/plugins/%%PORTVERSION%%/opsi.la
lib/wireshark/plugins/%%PORTVERSION%%/opsi.so
lib/wireshark/plugins/%%PORTVERSION%%/parlay.la
@@ -60,6 +62,8 @@ lib/wireshark/plugins/%%PORTVERSION%%/tango.la
lib/wireshark/plugins/%%PORTVERSION%%/tango.so
lib/wireshark/plugins/%%PORTVERSION%%/v5ua.la
lib/wireshark/plugins/%%PORTVERSION%%/v5ua.so
+lib/wireshark/plugins/%%PORTVERSION%%/wimax.la
+lib/wireshark/plugins/%%PORTVERSION%%/wimax.so
lib/libwireshark.la
lib/libwireshark.so
lib/libwireshark.so.0
@@ -77,6 +81,7 @@ lib/libwiretap.so.0
%%DATADIR%%/diameter/chargecontrol.xml
%%DATADIR%%/diameter/dictionary.dtd
%%DATADIR%%/diameter/dictionary.xml
+%%DATADIR%%/diameter/gqpolicy.xml
%%DATADIR%%/diameter/imscxdx.xml
%%DATADIR%%/diameter/mobileipv4.xml
%%DATADIR%%/diameter/nasreq.xml