aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-01 14:41:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-01 14:41:49 +0000
commit6e85147f508ce8c9ff82290fef2c7fabd9c923c5 (patch)
tree5eca784850e9c1daf8cd5ef7844df6bdaacce9d0
parent244d3c2210a4fab03e5061a4f2b23edbe7033339 (diff)
Notes
-rw-r--r--finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile10
-rw-r--r--math/p5-Math-Random-ISAAC-XS/Makefile3
-rw-r--r--math/p5-Math-Random-ISAAC-XS/pkg-plist1
-rw-r--r--math/p5-Math-Vec/Makefile2
-rw-r--r--math/p5-Math-Vec/pkg-plist1
5 files changed, 6 insertions, 11 deletions
diff --git a/finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile b/finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile
index 0d476a0ff101..c046ef50c027 100644
--- a/finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile
+++ b/finance/p5-Business-MaxMind-CreditCardFraudDetection/Makefile
@@ -20,17 +20,16 @@ BUILD_DEPENDS+= p5-libwww>0.0:${PORTSDIR}/www/p5-libwww
USES= perl5
USE_PERL5= configure
-MAN3= Business::MaxMind::CreditCardFraudDetection.3 \
- Business::MaxMind::HTTPBase.3 \
- Business::MaxMind::TelephoneVerification.3 \
-
PLIST_FILES= \
%%SITE_PERL%%/Business/MaxMind/CreditCardFraudDetection.pm \
%%SITE_PERL%%/Business/MaxMind/HTTPBase.pm \
%%SITE_PERL%%/Business/MaxMind/TelephoneVerification.pm \
%%SITE_PERL%%/Business/example.pl \
%%SITE_PERL%%/Business/example_telv.pl \
- %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/MaxMind/.packlist
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/MaxMind/.packlist \
+ %%PERL5_MAN3%%/Business::MaxMind::CreditCardFraudDetection.3.gz \
+ %%PERL5_MAN3%%/Business::MaxMind::HTTPBase.3.gz \
+ %%PERL5_MAN3%%/Business::MaxMind::TelephoneVerification.3.gz
PLIST_DIRS= \
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Business/MaxMind \
@@ -38,5 +37,4 @@ PLIST_DIRS= \
%%SITE_PERL%%/Business/MaxMind \
%%SITE_PERL%%/Business
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/p5-Math-Random-ISAAC-XS/Makefile b/math/p5-Math-Random-ISAAC-XS/Makefile
index ca08613e226f..069a551f4168 100644
--- a/math/p5-Math-Random-ISAAC-XS/Makefile
+++ b/math/p5-Math-Random-ISAAC-XS/Makefile
@@ -17,7 +17,4 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= perl5
USE_PERL5= modbuild
-MAN3= Math::Random::ISAAC::XS.3
-
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/p5-Math-Random-ISAAC-XS/pkg-plist b/math/p5-Math-Random-ISAAC-XS/pkg-plist
index d09862bf2e4f..e11546323713 100644
--- a/math/p5-Math-Random-ISAAC-XS/pkg-plist
+++ b/math/p5-Math-Random-ISAAC-XS/pkg-plist
@@ -1,6 +1,7 @@
%%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/ISAAC/XS.pm
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/ISAAC/XS/XS.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/ISAAC/XS/XS.so
+%%PERL5_MAN3%%/Math::Random::ISAAC::XS.3.gz
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/ISAAC
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Random
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math
diff --git a/math/p5-Math-Vec/Makefile b/math/p5-Math-Vec/Makefile
index 58a9347ca9b6..1a2c00647a2b 100644
--- a/math/p5-Math-Vec/Makefile
+++ b/math/p5-Math-Vec/Makefile
@@ -11,7 +11,5 @@ COMMENT= Object-Oriented Vector Math Methods in Perl
USES= perl5
USE_PERL5= modbuild
-MAN3= Math::Vec.3
-NO_STAGE= yes
.include <bsd.port.mk>
diff --git a/math/p5-Math-Vec/pkg-plist b/math/p5-Math-Vec/pkg-plist
index b21d73f1e14c..222f8cb80d4d 100644
--- a/math/p5-Math-Vec/pkg-plist
+++ b/math/p5-Math-Vec/pkg-plist
@@ -1,2 +1,3 @@
%%SITE_PERL%%/Math/Vec.pm
+%%PERL5_MAN3%%/Math::Vec.3.gz
@dirrmtry %%SITE_PERL%%/Math