aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-08-13 08:37:19 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-08-13 08:37:19 +0000
commit6e926215f1c35d3bb7c4cf749673469676dbd268 (patch)
tree3e340567bb56145f1f815d846fc87f771606e67a
parent2543a0ea2780e0e9454101afe5d0a86cfdcd70d6 (diff)
downloadports-6e926215f1c35d3bb7c4cf749673469676dbd268.tar.gz
ports-6e926215f1c35d3bb7c4cf749673469676dbd268.zip
Notes
-rw-r--r--editors/winefish/Makefile20
-rw-r--r--editors/winefish/pkg-descr2
-rw-r--r--editors/winefish/pkg-plist3
3 files changed, 6 insertions, 19 deletions
diff --git a/editors/winefish/Makefile b/editors/winefish/Makefile
index a449889ef7be..ef4774cb19db 100644
--- a/editors/winefish/Makefile
+++ b/editors/winefish/Makefile
@@ -12,6 +12,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= LaTeX editor based on BlueFish
+LICENSE= GPLv2
+
LIB_DEPENDS= libaspell.so:${PORTSDIR}/textproc/aspell \
libpcre.so:${PORTSDIR}/devel/pcre
RUN_DEPENDS= dos2unix:${PORTSDIR}/converters/unix2dos \
@@ -19,12 +21,9 @@ RUN_DEPENDS= dos2unix:${PORTSDIR}/converters/unix2dos \
tidy:${PORTSDIR}/www/tidy-lib \
xpdf:${PORTSDIR}/graphics/xpdf
-MAN1= winefish.1
-MANCOMPRESSED= no
-
CONFIGURE_ARGS+= --with-freedesktop_org-menu=${GNOME_LOCALSTATEDIR}/applications --with-icon-path=${GNOME_LOCALSTATEDIR}/pixmaps
GNU_CONFIGURE= yes
-USES= gmake pkgconfig
+USES= gmake pkgconfig desktop-file-utils shared-mime-info
USE_GNOME= libgnomeui desktopfileutils gnomehier
USE_TEX= latex
@@ -32,14 +31,10 @@ OPTIONS_DEFINE= CONTEXT VNTEX UNIKEY_GTK NLS DOCS
CONTEXT_DESC= ConTexT support (Experimental)
VNTEX_DESC= Vietnamese TeX user
UNIKEY_GTK_DESC= Vietname Tex user with UnikeyGTK input method
+CONTEXT_CONFIGURE_WITH= context
-NO_STAGE= yes
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MCONTEXT}
-CONFIGURE_ARGS+= --with-context
-.endif
-
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB= IFNLS=
@@ -59,11 +54,4 @@ CONFIGURE_ARGS+= --disable-nls
PLIST_SUB= IFNLS="@comment "
.endif
-post-install:
- -@update-desktop-database
-.if ! ${PORT_OPTIONS:MDOCS}
- ${RM} ${DOCSDIR}/${PORTNAME}.html
- ${RMDIR} ${DOCSDIR}
-.endif
-
.include <bsd.port.mk>
diff --git a/editors/winefish/pkg-descr b/editors/winefish/pkg-descr
index b9f2772a000f..d5d441bf7f43 100644
--- a/editors/winefish/pkg-descr
+++ b/editors/winefish/pkg-descr
@@ -7,4 +7,4 @@ Main features:
(3) UTF8 support
Author: Ky Anh <kyanh@users.berlios.de>
-WWW: http://winefish.berlios.de/
+WWW: http://winefish.berlios.de/
diff --git a/editors/winefish/pkg-plist b/editors/winefish/pkg-plist
index 1f10aa077dda..5f730d71e27b 100644
--- a/editors/winefish/pkg-plist
+++ b/editors/winefish/pkg-plist
@@ -1,4 +1,5 @@
bin/winefish
+man/man1/winefish.1.gz
share/application-registry/winefish.applications
share/applications/winefish.desktop
share/applications/winefish-project.desktop
@@ -28,5 +29,3 @@ share/mime/packages/winefish.xml
%%DATADIR%%/words.default
%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%
-@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
-@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true