aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2006-05-01 16:39:52 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2006-05-01 16:39:52 +0000
commit6f4b4a12fb9c4b6f130fc66ca4a469b69b31a4f9 (patch)
tree903a0640c0c6256ee24bb3c7a5c62a82492c7dc0
parentf116339d4e55ea1acf8eda06aa007149263a26f3 (diff)
downloadports-6f4b4a12fb9c4b6f130fc66ca4a469b69b31a4f9.tar.gz
ports-6f4b4a12fb9c4b6f130fc66ca4a469b69b31a4f9.zip
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/aria2/Makefile28
-rw-r--r--www/aria2/distinfo3
-rw-r--r--www/aria2/pkg-descr13
4 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index ae8dda657148..b8f5c32b2dd1 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -27,6 +27,7 @@
SUBDIR += apache21
SUBDIR += apache22
SUBDIR += aria
+ SUBDIR += aria2
SUBDIR += ashe # requires Motif
SUBDIR += asp2php
SUBDIR += aswedit
diff --git a/www/aria2/Makefile b/www/aria2/Makefile
new file mode 100644
index 000000000000..1c34b2bcf4a7
--- /dev/null
+++ b/www/aria2/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: aria2
+# Date created: 1 May 2006
+# Whom: Andrew Pantyukhin <infofarmer@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= aria2
+PORTVERSION= 0.4.1
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= infofarmer@gmail.com
+COMMENT= Yet another download tool
+
+LIB_DEPENDS= gnutls.15:${PORTSDIR}/security/gnutls \
+ gcrypt.13:${PORTSDIR}/security/libgcrypt
+
+CONFIGURE_ARGS= --with-libintl-prefix=${LOCALBASE}
+
+USE_BZIP2= yes
+USE_GNOME= gnomehack
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+PLIST_FILES= bin/aria2c share/locale/ja/LC_MESSAGES/aria2c.mo
+
+.include <bsd.port.mk>
diff --git a/www/aria2/distinfo b/www/aria2/distinfo
new file mode 100644
index 000000000000..cdfcbf016485
--- /dev/null
+++ b/www/aria2/distinfo
@@ -0,0 +1,3 @@
+MD5 (aria2-0.4.1.tar.bz2) = 6bd81ab125f5f6c725b351703c3fff90
+SHA256 (aria2-0.4.1.tar.bz2) = 0645ec3c5f93b94c157750a5075567af366486a6c20898a36370775a5d14e88d
+SIZE (aria2-0.4.1.tar.bz2) = 301413
diff --git a/www/aria2/pkg-descr b/www/aria2/pkg-descr
new file mode 100644
index 000000000000..a0b5e7610037
--- /dev/null
+++ b/www/aria2/pkg-descr
@@ -0,0 +1,13 @@
+Aria2 is an utility for downloading files with nice features:
+* Command-line interface
+* Download files through HTTP/HTTPS/FTP/BitTorrent
+* HTTP Proxy support
+* FTP though HTTP proxy
+* HTTP BASIC authentication support
+* HTTP Proxy authentication support
+* Segmented downloading
+* Cookie support(currently aria2 ignores "expires")
+* Run as a daemon process.
+* Selective download in multi-file torrent
+
+WWW: http://aria2.sourceforge.net/