aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-11-19 03:31:33 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2017-11-19 03:31:33 +0000
commit6f992983dfab40a6a8ea5b94a9be9babf6d82f0c (patch)
tree7e121016e06b2df92aa32b59d2c7acd0581fcd53
parent5de1ec4251a0a294e150a391bf9422f13da9e382 (diff)
downloadports-6f992983dfab40a6a8ea5b94a9be9babf6d82f0c.tar.gz
ports-6f992983dfab40a6a8ea5b94a9be9babf6d82f0c.zip
Notes
-rw-r--r--devel/libpci/Makefile4
-rw-r--r--devel/libpci/distinfo6
-rw-r--r--devel/libpci/files/patch-lib-fbsd-device.c20
3 files changed, 25 insertions, 5 deletions
diff --git a/devel/libpci/Makefile b/devel/libpci/Makefile
index 1ff9dd409ade..f268d25a0f04 100644
--- a/devel/libpci/Makefile
+++ b/devel/libpci/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= libpci
-PORTVERSION= 3.5.5
+PORTVERSION= 3.5.6
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/utils/pciutils \
ftp://atrey.karlin.mff.cuni.cz/pub/linux/pci/ \
@@ -37,7 +37,7 @@ LIBPCI_FILES= include/pci/config.h \
post-patch:
@${LN} -s . ${WRKSRC}/lib/pci
@${REINPLACE_CMD} -e '/^CC=/d; /^CFLAGS=/ s|=|+=|; /^IDSDIR=/ s|$$|/pciids|; /^OPT=/d; /^PREFIX=/d' ${WRKSRC}/Makefile
- @${REINPLACE_CMD} 's|^#include "|&pci/|' ${WRKSRC}/lib/pci.h
+ @${REINPLACE_CMD} -e 's|^#include "|&pci/|' ${WRKSRC}/lib/pci.h
do-configure:
@cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} lib/config.h
diff --git a/devel/libpci/distinfo b/devel/libpci/distinfo
index 0c5824f66f3f..04efd47d6f50 100644
--- a/devel/libpci/distinfo
+++ b/devel/libpci/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1499364176
-SHA256 (pciutils-3.5.5.tar.xz) = 1d62f8fa192f90e61c35a6fc15ff3cb9a7a792f782407acc42ef67817c5939f5
-SIZE (pciutils-3.5.5.tar.xz) = 324676
+TIMESTAMP = 1511061060
+SHA256 (pciutils-3.5.6.tar.xz) = f346eeb90cce0910c05b877fe49eadc760fa084c0455fd313e39d4b2c2d4bb21
+SIZE (pciutils-3.5.6.tar.xz) = 328256
diff --git a/devel/libpci/files/patch-lib-fbsd-device.c b/devel/libpci/files/patch-lib-fbsd-device.c
new file mode 100644
index 000000000000..6f32908b6412
--- /dev/null
+++ b/devel/libpci/files/patch-lib-fbsd-device.c
@@ -0,0 +1,20 @@
+--- lib/fbsd-device.c.orig 2017-11-17 12:57:00 UTC
++++ lib/fbsd-device.c
+@@ -254,7 +254,7 @@ fbsd_read(struct pci_dev *d, int pos, by
+
+ if (d->access->fd_rw < 0)
+ {
+- d->access->warn("fbsd_read: missing permissions");
++ d->access->warning("fbsd_read: missing permissions");
+ return 0;
+ }
+
+@@ -303,7 +303,7 @@ fbsd_write(struct pci_dev *d, int pos, b
+
+ if (d->access->fd_rw < 0)
+ {
+- d->access->warn("fbsd_write: missing permissions");
++ d->access->warning("fbsd_write: missing permissions");
+ return 0;
+ }
+