aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-07-27 11:52:47 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-07-27 11:52:47 +0000
commit6fd284c26ed5aa435193e8ef7dcd819245e25969 (patch)
tree3447ba37f0db58f51792e69ea491309cf3a1adbd
parentc89dec7542da4eba60f61d4639f611760a5585a9 (diff)
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-jupyterlab/Makefile25
-rw-r--r--devel/py-jupyterlab/distinfo3
-rw-r--r--devel/py-jupyterlab/pkg-descr13
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2358140772ac..aacfc54e86e1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4555,6 +4555,7 @@
SUBDIR += py-jupyter_client
SUBDIR += py-jupyter_console
SUBDIR += py-jupyter_core
+ SUBDIR += py-jupyterlab
SUBDIR += py-jupyterlab_launcher
SUBDIR += py-jupyterlab_server
SUBDIR += py-kaitaistruct
diff --git a/devel/py-jupyterlab/Makefile b/devel/py-jupyterlab/Makefile
new file mode 100644
index 000000000000..474b7b4d56ec
--- /dev/null
+++ b/devel/py-jupyterlab/Makefile
@@ -0,0 +1,25 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= jupyterlab
+PORTVERSION= 1.0.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= JupyterLab notebook server extension
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jupyterlab_server>=1.0.0:devel/py-jupyterlab_server@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}notebook>=4.3.1:www/py-notebook@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}tornado>=0:www/py-tornado@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-jupyterlab/distinfo b/devel/py-jupyterlab/distinfo
new file mode 100644
index 000000000000..29b29410ae7d
--- /dev/null
+++ b/devel/py-jupyterlab/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1564157931
+SHA256 (jupyterlab-1.0.3.tar.gz) = b6bbc07b464d9b282a3a24d67c59959d0c5940442399642f400c62ea6dfc46af
+SIZE (jupyterlab-1.0.3.tar.gz) = 12071386
diff --git a/devel/py-jupyterlab/pkg-descr b/devel/py-jupyterlab/pkg-descr
new file mode 100644
index 000000000000..9505c3397ea5
--- /dev/null
+++ b/devel/py-jupyterlab/pkg-descr
@@ -0,0 +1,13 @@
+JupyterLab is an extensible environment for interactive and reproducible
+computing, based on the Jupyter Notebook and Architecture.
+
+JupyterLab is the next-generation user interface for Project Jupyter offering
+all the familiar building blocks of the classic Jupyter Notebook (notebook,
+terminal, text editor, file browser, rich outputs, etc.) in a flexible and
+powerful user interface. JupyterLab will eventually replace the classic Jupyter
+Notebook.
+
+The current JupyterLab releases are suitable for general usage, and the
+extension APIs will continue to evolve for JupyterLab extension developers.
+
+WWW: https://jupyter.org/