aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-09 00:01:54 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-09 00:01:54 +0000
commit6fef486f2502013b24eb5f59cc0d699eb365ba0f (patch)
tree44a9af5dce71520e4a0a647906834e0c8115dc05
parent37565365f244d76a0ea5a68784a0de3360e60af4 (diff)
downloadports-6fef486f2502013b24eb5f59cc0d699eb365ba0f.tar.gz
ports-6fef486f2502013b24eb5f59cc0d699eb365ba0f.zip
Notes
-rw-r--r--net-mgmt/ipv6mon/Makefile25
-rw-r--r--net-mgmt/ipv6mon/files/patch-Makefile2
-rw-r--r--net-mgmt/ipv6mon/pkg-plist6
3 files changed, 14 insertions, 19 deletions
diff --git a/net-mgmt/ipv6mon/Makefile b/net-mgmt/ipv6mon/Makefile
index 0bbe6e286dda..7752b4e00afc 100644
--- a/net-mgmt/ipv6mon/Makefile
+++ b/net-mgmt/ipv6mon/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ipv6mon
PORTVERSION= 1.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net-mgmt ipv6
MASTER_SITES= http://www.si6networks.com/tools/ipv6mon/
DISTNAME= ${PORTNAME}-v${PORTVERSION}
@@ -11,37 +11,32 @@ DISTNAME= ${PORTNAME}-v${PORTVERSION}
MAINTAINER= hrs@FreeBSD.org
COMMENT= Tool for monitoring IPv6 address usage
+OPTIONS_DEFINE= DOCS
+
LICENSE= GPLv3
-MAKE_ENV= DESTDIR=${PREFIX}/
+USES= uidfix
+#Ignore "normal" destdir from port infra
+DESTDIRNAME= IGNOREME
+MAKE_ENV= DESTDIR=${STAGEDIR}${PREFIX}/
CFLAGS+= -DIPV6MON_CONF=\\\"${PREFIX}/etc/ipv6mon.conf\\\"
USERS= ${PORTNAME}
GROUPS= ${PORTNAME}
USE_RC_SUBR= ${PORTNAME}
-MAN5= ipv6mon.conf.5
-MAN8= ipv6mon.8
-
PORTDOCS= README.TXT \
ipv6mon-installation-notes.odt \
ipv6mon-installation-notes.pdf \
ipv6mon-manual.odt \
ipv6mon-manual.pdf
-NO_STAGE= yes
post-extract:
${INSTALL_DATA} ${WRKSRC}/manuals/* ${WRKSRC}
post-install:
- if [ ! -r ${PREFIX}/etc/ipv6mon.conf ]; then \
- ${INSTALL_DATA} ${PREFIX}/etc/ipv6mon.conf.dist \
- ${PREFIX}/etc/ipv6mon.conf; \
- fi
- ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/etc/rc.d
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${STAGEDIR}${PREFIX}/etc/rc.d
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC} && \
- ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/net-mgmt/ipv6mon/files/patch-Makefile b/net-mgmt/ipv6mon/files/patch-Makefile
index 27ebd3bafbd3..61d6e50f446b 100644
--- a/net-mgmt/ipv6mon/files/patch-Makefile
+++ b/net-mgmt/ipv6mon/files/patch-Makefile
@@ -7,7 +7,7 @@
+LDADD= -lpcap
+
+FILES= ipv6mon.conf
-+FILESNAME= ipv6mon.conf.dist
++FILESNAME= ipv6mon.conf.sample
+FILESDIR= etc
+
+BINDIR= sbin
diff --git a/net-mgmt/ipv6mon/pkg-plist b/net-mgmt/ipv6mon/pkg-plist
index 3898fe183cd8..a2cfa4f432ab 100644
--- a/net-mgmt/ipv6mon/pkg-plist
+++ b/net-mgmt/ipv6mon/pkg-plist
@@ -1,4 +1,4 @@
-@unexec cmp -s %D/etc/ipv6mon.conf.dist %D/etc/ipv6mon.conf && rm -f %D/etc/ipv6mon.conf || true
-etc/ipv6mon.conf.dist
-@exec if [ ! -r %D/etc/ipv6mon.conf ]; then install -m 444 %D/etc/ipv6mon.conf.dist %D/etc/ipv6mon.conf; fi
+@sample etc/ipv6mon.conf.sample
sbin/ipv6mon
+man/man5/ipv6mon.conf.5.gz
+man/man8/ipv6mon.8.gz