aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Skvortsov <skv@FreeBSD.org>2010-06-11 14:27:51 +0000
committerSergey Skvortsov <skv@FreeBSD.org>2010-06-11 14:27:51 +0000
commit6ff7191dcf430170bd775df9469cc1436505c584 (patch)
tree79f8b40ff5b576cd15e0d3c30d35e8984d427dab
parent6c411c7524a1a640974c65e186f74ac78ba5287f (diff)
downloadports-6ff7191dcf430170bd775df9469cc1436505c584.tar.gz
ports-6ff7191dcf430170bd775df9469cc1436505c584.zip
Notes
-rw-r--r--devel/p5-POE/Makefile25
-rw-r--r--devel/p5-POE/distinfo6
-rw-r--r--devel/p5-POE/pkg-plist5
3 files changed, 14 insertions, 22 deletions
diff --git a/devel/p5-POE/Makefile b/devel/p5-POE/Makefile
index 169cbeb34ecf..e5fa6c2ec918 100644
--- a/devel/p5-POE/Makefile
+++ b/devel/p5-POE/Makefile
@@ -6,21 +6,18 @@
#
PORTNAME= POE
-PORTVERSION= 1.0070
-PORTREVISION= 1
+PORTVERSION= 1.289
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}-${PORTVERSION:C/0+$//}
-MAINTAINER= skv@FreeBSD.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Multitasking and networking framework for perl
-BUILD_DEPENDS= ${SITE_PERL}/Compress/Zlib.pm:${PORTSDIR}/archivers/p5-Compress-Zlib \
- ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event \
- ${SITE_PERL}/${PERL_ARCH}/Filter/Util/Call.pm:${PORTSDIR}/devel/p5-Filter \
+BUILD_DEPENDS= \
p5-IO-Tty>=1.08:${PORTSDIR}/devel/p5-IO-Tty \
- p5-POE-Test-Loops>=1.021:${PORTSDIR}/devel/p5-POE-Test-Loops
+ p5-POE-Test-Loops>=1.031:${PORTSDIR}/devel/p5-POE-Test-Loops
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
@@ -28,16 +25,16 @@ CONFIGURE_ARGS= --default
MAN3= POE.3 POE::Component.3 POE::Component::Client::TCP.3 \
POE::Component::Server::TCP.3 POE::Driver.3 \
- POE::Driver::SysRW.3 POE::Filter.3 POE::Filter::Block.3 \
- POE::Filter::Grep.3 POE::Filter::HTTPD.3 POE::Filter::Line.3 \
+ POE::Driver::SysRW.3 POE::Filter.3 \
+ POE::Filter::Block.3 POE::Filter::Grep.3 \
+ POE::Filter::HTTPD.3 POE::Filter::Line.3 \
POE::Filter::Map.3 POE::Filter::RecordBlock.3 \
POE::Filter::Reference.3 POE::Filter::Stackable.3 \
POE::Filter::Stream.3 POE::Kernel.3 POE::Loop.3 \
- POE::Loop::Event.3 POE::Loop::Gtk.3 POE::Loop::IO_Poll.3 \
- POE::Loop::PerlSignals.3 POE::Loop::Select.3 POE::Loop::Tk.3 \
- POE::Loop::TkActiveState.3 POE::Loop::TkCommon.3 POE::NFA.3 \
- POE::Pipe.3 POE::Pipe::OneWay.3 POE::Pipe::TwoWay.3 \
- POE::Queue.3 POE::Queue::Array.3 POE::Resource.3 \
+ POE::Loop::IO_Poll.3 POE::Loop::PerlSignals.3 \
+ POE::Loop::Select.3 POE::NFA.3 POE::Pipe.3 \
+ POE::Pipe::OneWay.3 POE::Pipe::TwoWay.3 POE::Queue.3 \
+ POE::Queue::Array.3 POE::Resource.3 \
POE::Resource::Aliases.3 POE::Resource::Events.3 \
POE::Resource::Extrefs.3 POE::Resource::FileHandles.3 \
POE::Resource::SIDs.3 POE::Resource::Sessions.3 \
diff --git a/devel/p5-POE/distinfo b/devel/p5-POE/distinfo
index a4236d9ab674..5a865a9e9384 100644
--- a/devel/p5-POE/distinfo
+++ b/devel/p5-POE/distinfo
@@ -1,3 +1,3 @@
-MD5 (POE-1.007.tar.gz) = c7e8822bd11ed36a2f716f60e58da2e6
-SHA256 (POE-1.007.tar.gz) = 5506b4e59aa455b026c4d92db083e7d6d36021b21a13be43d177276ab7d56a84
-SIZE (POE-1.007.tar.gz) = 356697
+MD5 (POE-1.289.tar.gz) = 2172566f98313658d5f6cce231476f07
+SHA256 (POE-1.289.tar.gz) = 1e16d214d14d2727df812de0073fbffee52fb25e50d654613e2d0302d2c194f8
+SIZE (POE-1.289.tar.gz) = 366482
diff --git a/devel/p5-POE/pkg-plist b/devel/p5-POE/pkg-plist
index bf1fcd1ee200..26e413223ae4 100644
--- a/devel/p5-POE/pkg-plist
+++ b/devel/p5-POE/pkg-plist
@@ -17,14 +17,9 @@
%%SITE_PERL%%/POE/Filter/Stream.pm
%%SITE_PERL%%/POE/Kernel.pm
%%SITE_PERL%%/POE/Loop.pm
-%%SITE_PERL%%/POE/Loop/Event.pm
-%%SITE_PERL%%/POE/Loop/Gtk.pm
%%SITE_PERL%%/POE/Loop/IO_Poll.pm
%%SITE_PERL%%/POE/Loop/PerlSignals.pm
%%SITE_PERL%%/POE/Loop/Select.pm
-%%SITE_PERL%%/POE/Loop/Tk.pm
-%%SITE_PERL%%/POE/Loop/TkActiveState.pm
-%%SITE_PERL%%/POE/Loop/TkCommon.pm
%%SITE_PERL%%/POE/NFA.pm
%%SITE_PERL%%/POE/Pipe.pm
%%SITE_PERL%%/POE/Pipe/OneWay.pm