aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-03-28 20:18:42 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-03-28 20:18:42 +0000
commit7009a8c15d67b81c23d5a712f8826c9ddcc01016 (patch)
treefb94204b49dd999129283ede516920e0ac86b639
parent3161624d84b34aa6a5049a8296e58832e21b8e6b (diff)
downloadports-7009a8c15d67b81c23d5a712f8826c9ddcc01016.tar.gz
ports-7009a8c15d67b81c23d5a712f8826c9ddcc01016.zip
Notes
-rw-r--r--textproc/libxml++26/Makefile6
-rw-r--r--textproc/libxml++26/distinfo5
-rw-r--r--textproc/libxml++26/files/patch-c++1146
-rw-r--r--textproc/libxml++26/pkg-plist12
4 files changed, 50 insertions, 19 deletions
diff --git a/textproc/libxml++26/Makefile b/textproc/libxml++26/Makefile
index c675bcc38674..afcd5c876feb 100644
--- a/textproc/libxml++26/Makefile
+++ b/textproc/libxml++26/Makefile
@@ -3,17 +3,15 @@
# $MCom: ports/textproc/libxml++26/Makefile,v 1.43 2011/04/18 19:58:29 kwm Exp $
PORTNAME= libxml++
-PORTVERSION= 2.40.1
+PORTVERSION= 2.34.2
PORTREVISION?= 0
+PORTEPOCH= 1
CATEGORIES= textproc
MASTER_SITES= GNOME
MAINTAINER= bland@FreeBSD.org
COMMENT= XML API for C++
-LICENSE= LGPL21
-LICENSE_FILE= ${WRKSRC}/COPYING
-
USES+= tar:xz
PLIST_SUB= VERSION="2.6" API_VERSION="2.6"
diff --git a/textproc/libxml++26/distinfo b/textproc/libxml++26/distinfo
index fca4d7a8b9f6..59eef6d2ba55 100644
--- a/textproc/libxml++26/distinfo
+++ b/textproc/libxml++26/distinfo
@@ -1,3 +1,2 @@
-TIMESTAMP = 1490627284
-SHA256 (libxml++-2.40.1.tar.xz) = 4ad4abdd3258874f61c2e2a41d08e9930677976d303653cd1670d3e9f35463e9
-SIZE (libxml++-2.40.1.tar.xz) = 955220
+SHA256 (libxml++-2.34.2.tar.xz) = 77daba20ab76631071d4ed4cc18fa2e981160ca05ae661e8d146f2b0728f9baa
+SIZE (libxml++-2.34.2.tar.xz) = 1070956
diff --git a/textproc/libxml++26/files/patch-c++11 b/textproc/libxml++26/files/patch-c++11
new file mode 100644
index 000000000000..6374f9db386f
--- /dev/null
+++ b/textproc/libxml++26/files/patch-c++11
@@ -0,0 +1,46 @@
+From 7dbfb0aed508451e8237c34472815e44925a545c Mon Sep 17 00:00:00 2001
+From: Mikhail Titov <mlt@gmx.us>
+Date: Thu, 30 Apr 2015 17:51:20 +0200
+Subject: Fix the build with C++11 compilers, such as MS Visual C++ 2013.
+
+Implicit conversions from streams to bool are no longer allowed.
+---
+ libxml++/io/istreamparserinputbuffer.cc | 2 +-
+ libxml++/io/ostreamoutputbuffer.cc | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/libxml++/io/istreamparserinputbuffer.cc b/libxml++/io/istreamparserinputbuffer.cc
+index b1d6e5b..7a7f283 100644
+--- libxml++/io/istreamparserinputbuffer.cc
++++ libxml++/io/istreamparserinputbuffer.cc
+@@ -39,6 +39,6 @@ namespace xmlpp
+
+ bool IStreamParserInputBuffer::do_close()
+ {
+- return input_;
++ return input_.good();
+ }
+ }
+diff --git a/libxml++/io/ostreamoutputbuffer.cc b/libxml++/io/ostreamoutputbuffer.cc
+index 0a3e6db..b23a8b6 100644
+--- libxml++/io/ostreamoutputbuffer.cc
++++ libxml++/io/ostreamoutputbuffer.cc
+@@ -29,13 +29,13 @@ namespace xmlpp
+ // here we rely on the ostream implicit conversion to boolean, to know if the stream can be used and/or if the write succeded.
+ if(output_)
+ output_.write(buffer, len);
+- return output_;
++ return output_.good();
+ }
+
+ bool OStreamOutputBuffer::do_close()
+ {
+ if(output_)
+ output_.flush();
+- return output_;
++ return output_.good();
+ }
+ }
+--
+cgit v0.12
+
diff --git a/textproc/libxml++26/pkg-plist b/textproc/libxml++26/pkg-plist
index fd8bb1ffd111..4199bf447250 100644
--- a/textproc/libxml++26/pkg-plist
+++ b/textproc/libxml++26/pkg-plist
@@ -1,14 +1,11 @@
include/libxml++-%%API_VERSION%%/include/libxml++config.h
include/libxml++-%%API_VERSION%%/libxml++/attribute.h
-include/libxml++-%%API_VERSION%%/libxml++/attributedeclaration.h
-include/libxml++-%%API_VERSION%%/libxml++/attributenode.h
include/libxml++-%%API_VERSION%%/libxml++/document.h
include/libxml++-%%API_VERSION%%/libxml++/dtd.h
include/libxml++-%%API_VERSION%%/libxml++/exceptions/exception.h
include/libxml++-%%API_VERSION%%/libxml++/exceptions/internal_error.h
include/libxml++-%%API_VERSION%%/libxml++/exceptions/parse_error.h
include/libxml++-%%API_VERSION%%/libxml++/exceptions/validity_error.h
-include/libxml++-%%API_VERSION%%/libxml++/exceptions/wrapped_exception.h
include/libxml++-%%API_VERSION%%/libxml++/io/istreamparserinputbuffer.h
include/libxml++-%%API_VERSION%%/libxml++/io/ostreamoutputbuffer.h
include/libxml++-%%API_VERSION%%/libxml++/io/outputbuffer.h
@@ -19,28 +16,19 @@ include/libxml++-%%API_VERSION%%/libxml++/nodes/cdatanode.h
include/libxml++-%%API_VERSION%%/libxml++/nodes/commentnode.h
include/libxml++-%%API_VERSION%%/libxml++/nodes/contentnode.h
include/libxml++-%%API_VERSION%%/libxml++/nodes/element.h
-include/libxml++-%%API_VERSION%%/libxml++/nodes/entitydeclaration.h
include/libxml++-%%API_VERSION%%/libxml++/nodes/entityreference.h
include/libxml++-%%API_VERSION%%/libxml++/nodes/node.h
include/libxml++-%%API_VERSION%%/libxml++/nodes/processinginstructionnode.h
include/libxml++-%%API_VERSION%%/libxml++/nodes/textnode.h
-include/libxml++-%%API_VERSION%%/libxml++/nodes/xincludeend.h
-include/libxml++-%%API_VERSION%%/libxml++/nodes/xincludestart.h
include/libxml++-%%API_VERSION%%/libxml++/noncopyable.h
include/libxml++-%%API_VERSION%%/libxml++/parsers/domparser.h
include/libxml++-%%API_VERSION%%/libxml++/parsers/parser.h
include/libxml++-%%API_VERSION%%/libxml++/parsers/saxparser.h
include/libxml++-%%API_VERSION%%/libxml++/parsers/textreader.h
-include/libxml++-%%API_VERSION%%/libxml++/relaxngschema.h
include/libxml++-%%API_VERSION%%/libxml++/schema.h
-include/libxml++-%%API_VERSION%%/libxml++/schemabase.h
include/libxml++-%%API_VERSION%%/libxml++/validators/dtdvalidator.h
-include/libxml++-%%API_VERSION%%/libxml++/validators/relaxngvalidator.h
include/libxml++-%%API_VERSION%%/libxml++/validators/schemavalidator.h
-include/libxml++-%%API_VERSION%%/libxml++/validators/schemavalidatorbase.h
include/libxml++-%%API_VERSION%%/libxml++/validators/validator.h
-include/libxml++-%%API_VERSION%%/libxml++/validators/xsdvalidator.h
-include/libxml++-%%API_VERSION%%/libxml++/xsdschema.h
lib/libxml++-%%VERSION%%.a
lib/libxml++-%%VERSION%%.so
lib/libxml++-%%VERSION%%.so.2