aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-21 19:07:48 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-21 19:07:48 +0000
commit701fd571f9f6bdf572f165d539efedd629a3fc7a (patch)
treed381b63dee30d6c8834050f3311628f663d5883d
parent988b15524a78f0bad5dbf622de5e5fb67e6ee647 (diff)
downloadports-701fd571f9f6bdf572f165d539efedd629a3fc7a.tar.gz
ports-701fd571f9f6bdf572f165d539efedd629a3fc7a.zip
Notes
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/pugixml/Makefile18
-rw-r--r--textproc/pugixml/distinfo2
-rw-r--r--textproc/pugixml/pkg-descr10
4 files changed, 31 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 0299035b829b..3fe0761b63e2 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1134,6 +1134,7 @@
SUBDIR += print-n-times
SUBDIR += prosper
SUBDIR += publican
+ SUBDIR += pugixml
SUBDIR += pure-csv
SUBDIR += pure-xml
SUBDIR += py-4suite-xml
diff --git a/textproc/pugixml/Makefile b/textproc/pugixml/Makefile
new file mode 100644
index 000000000000..84f4fc29f02e
--- /dev/null
+++ b/textproc/pugixml/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= pugixml
+PORTVERSION= 1.4
+CATEGORIES= textproc
+MASTER_SITES= http://github.com/zeux/pugixml/releases/download/v${PORTVERSION}/
+
+MAINTAINER= ybungalobill@gmail.com
+COMMENT= Light-weight, simple and fast XML parser for C++ with XPath support
+
+LICENSE= MIT
+
+USES= cmake
+CMAKE_SOURCE_PATH= ${WRKSRC}/scripts
+
+PLIST_FILES= include/pugiconfig.hpp include/pugixml.hpp lib/libpugixml.a
+
+.include <bsd.port.mk>
diff --git a/textproc/pugixml/distinfo b/textproc/pugixml/distinfo
new file mode 100644
index 000000000000..14db7d1673ba
--- /dev/null
+++ b/textproc/pugixml/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pugixml-1.4.tar.gz) = 9c8802269cee1a48ab269d4055b910216bdf878cccde286dcae9c25813e6fa87
+SIZE (pugixml-1.4.tar.gz) = 369290
diff --git a/textproc/pugixml/pkg-descr b/textproc/pugixml/pkg-descr
new file mode 100644
index 000000000000..e01de5a7ef2f
--- /dev/null
+++ b/textproc/pugixml/pkg-descr
@@ -0,0 +1,10 @@
+pugixml is a light-weight C++ XML processing library. It features:
+
+* DOM-like interface with rich traversal/modification capabilities
+* Extremely fast non-validating XML parser which constructs the DOM tree from an
+ XML file/buffer
+* XPath 1.0 implementation for complex data-driven tree queries
+* Full Unicode support with Unicode interface variants and automatic encoding
+ conversions
+
+WWW: http://pugixml.com/