aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2017-03-27 18:15:53 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2017-03-27 18:15:53 +0000
commit702942568968f0f6985816ecd13e0ca571b63198 (patch)
treef80549ece214402d41f5e05e71cf2e4b9769f610
parent23a15d5d6a850265da9ef7edfb86d2ac4d7ea6b0 (diff)
downloadports-702942568968f0f6985816ecd13e0ca571b63198.tar.gz
ports-702942568968f0f6985816ecd13e0ca571b63198.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/buildbot-console-view/Makefile37
-rw-r--r--devel/buildbot-console-view/distinfo3
-rw-r--r--devel/buildbot-console-view/pkg-descr6
4 files changed, 47 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 84b7ab23be08..36ed43a9f9a7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -201,6 +201,7 @@
SUBDIR += bugzilla50
SUBDIR += build
SUBDIR += buildbot
+ SUBDIR += buildbot-console-view
SUBDIR += buildbot-pkg
SUBDIR += buildbot-worker
SUBDIR += buildtool
diff --git a/devel/buildbot-console-view/Makefile b/devel/buildbot-console-view/Makefile
new file mode 100644
index 000000000000..61733541d53d
--- /dev/null
+++ b/devel/buildbot-console-view/Makefile
@@ -0,0 +1,37 @@
+# Created by: Michael Gmelin <grembo@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= buildbot-console-view
+PORTVERSION= 0.9.4
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+
+MAINTAINER= grembo@FreeBSD.org
+COMMENT= Continuous Integration Framework (Console View)
+
+LICENSE= GPLv2
+
+MY_DEPENDS= buildbot-pkg>=0.9.4:devel/buildbot-pkg
+BUILD_DEPENDS= ${MY_DEPENDS}
+RUN_DEPENDS= ${MY_DEPENDS}
+TEST_DEPENDS= trial:devel/py-twisted \
+ buildbot-worker>=0.9.4:devel/buildbot-worker \
+ ${PYTHON_PKGNAMEPREFIX}mock>0.8.0:devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}boto3>0:www/py-boto3 \
+ ${PYTHON_PKGNAMEPREFIX}service_identity>=16.0.0:security/py-service_identity \
+ ${PYTHON_PKGNAMEPREFIX}txrequests>0:www/py-txrequests
+
+USES= python:-2.7
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+post-patch:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} -n 10 ${REINPLACE_CMD} -e \
+ 's|/usr/bin/python|${PYTHON_CMD}|g'
+ @${FIND} ${WRKSRC} -name \*.bak -delete
+
+do-test:
+ @cd ${WRKSRC} && trial buildbot
+
+.include <bsd.port.mk>
diff --git a/devel/buildbot-console-view/distinfo b/devel/buildbot-console-view/distinfo
new file mode 100644
index 000000000000..c784000567c2
--- /dev/null
+++ b/devel/buildbot-console-view/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488906561
+SHA256 (buildbot-console-view-0.9.4.tar.gz) = 16d1ab8801439d50d712883ab155530840588d4d77ab600299ead0ef23da5bf0
+SIZE (buildbot-console-view-0.9.4.tar.gz) = 631510
diff --git a/devel/buildbot-console-view/pkg-descr b/devel/buildbot-console-view/pkg-descr
new file mode 100644
index 000000000000..951553acad3b
--- /dev/null
+++ b/devel/buildbot-console-view/pkg-descr
@@ -0,0 +1,6 @@
+This port is the Console View Plugin for BuildBot. For the buildmaster,
+install the devel/buildbot port
+
+For more information, please see: http://buildbot.net/trac
+
+WWW: http://buildbot.net