aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2018-10-23 11:00:20 +0000
committerWen Heping <wen@FreeBSD.org>2018-10-23 11:00:20 +0000
commit706cfc42b26beaeeb0c0860372e5a04f96671021 (patch)
tree209a00b4d4729a3b67e45803430619538422214b
parenta70d5203acc1a3902fc5e34590e1a14b2f6144b5 (diff)
downloadports-706cfc42b26beaeeb0c0860372e5a04f96671021.tar.gz
ports-706cfc42b26beaeeb0c0860372e5a04f96671021.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/gmt5/Makefile53
-rw-r--r--graphics/gmt5/distinfo3
-rw-r--r--graphics/gmt5/files/patch-src_CMakeLists.txt22
-rw-r--r--graphics/gmt5/files/patch-src_common__string.h12
-rw-r--r--graphics/gmt5/pkg-descr6
-rw-r--r--graphics/gmt5/pkg-plist319
7 files changed, 416 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 41adfa07d10b..337929c23d00 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -289,6 +289,7 @@
SUBDIR += gmic
SUBDIR += gmic-qt
SUBDIR += gmt
+ SUBDIR += gmt5
SUBDIR += gmt5-dcw
SUBDIR += gmt5-gshhg
SUBDIR += gnash
diff --git a/graphics/gmt5/Makefile b/graphics/gmt5/Makefile
new file mode 100644
index 000000000000..625994d50abb
--- /dev/null
+++ b/graphics/gmt5/Makefile
@@ -0,0 +1,53 @@
+# $FreeBSD$
+
+PORTNAME= gmt5
+DISTVERSION= 5.4.4
+DISTVERSIONSUFFIX= -src
+CATEGORIES= graphics
+MASTER_SITES= ftp://ftp.soest.hawaii.edu/%SUBDIR%/ \
+ ftp://ftp.geologi.uio.no/pub/%SUBDIR%/ \
+ ftp://ftp.iag.usp.br/%SUBDIR%/ \
+ ftp://ftp.scc.u-tokai.ac.jp/pub/%SUBDIR%/ \
+ http://gd.tuwien.ac.at/graphics/visual/%SUBDIR%/ \
+ http://gmt.mirror.ac.za/%SUBDIR%/ \
+ ftp://ftp.soest.hawaii.edu/gshhg/:gshhg \
+ ftp://ftp.scc.u-tokai.ac.jp/pub/gmt/:gshhg
+MASTER_SITE_SUBDIR= gmt gmt/legacy
+DISTNAME= gmt-${DISTVERSION}${DISTVERSIONSUFFIX}
+
+MAINTAINER= lbartoletti@tuxfamily.org
+COMMENT= Generic Mapping Tools - data processing and display software package
+
+LICENSE= GPLv3 LGPL3
+LICENSE_COMB= multi
+
+LIB_DEPENDS= libnetcdf.so:science/netcdf \
+ libcurl.so:ftp/curl \
+ libpcre.so:devel/pcre \
+ libfftw3f_threads.so:math/fftw3-float \
+ libgdal.so:graphics/gdal
+RUN_DEPENDS= bash:shells/bash
+BUILD_DEPENDS= ${LOCALBASE}/share/dcw-gmt/dcw-gmt.nc:graphics/gmt5-dcw \
+ ${LOCALBASE}/share/gshhg-gmt/binned_GSHHS_c.nc:graphics/gmt5-gshhg
+
+WRKSRC= ${WRKDIR}/gmt-${PORTVERSION}
+
+USES= shebangfix cmake:outsource
+SHEBANG_GLOB= *.sh *.in
+SHEBANG_FILES= share/tools/ncdeflate src/img/img2google src/gmtswitch
+
+USE_LDCONFIG= yes
+
+CMAKE_ARGS+= -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_C_FLAGS=-fstrict-aliasing \
+ -DCMAKE_INSTALL_PREFIX=${PREFIX} \
+ -DDCW_ROOT=${LOCALBASE}/share/gmt5-dcw \
+ -DGSHHG_ROOT=${LOCALBASE}/share/gmt5-gshhg \
+ -DGMT_INSTALL_MODULE_LINKS=off \
+ -DGMT_INSTALL_TRADITIONAL_FOLDERNAMES=off \
+ -DGMT_DATADIR=share/${PORTNAME} \
+ -DGMT_DOCDIR=share/doc/${PORTNAME} \
+ -DGMT_MANDIR=share/doc/${PORTNAME}/man \
+ -DGMT_INSTALL_NAME_SUFFIX=-gmt5
+
+.include <bsd.port.mk>
diff --git a/graphics/gmt5/distinfo b/graphics/gmt5/distinfo
new file mode 100644
index 000000000000..6d3cb6298e74
--- /dev/null
+++ b/graphics/gmt5/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1539483072
+SHA256 (gmt-5.4.4-src.tar.gz) = 1baf3d6b049db7cc6cbd7506524cdca45c41e3bfffb24814245fc18f5a8626c2
+SIZE (gmt-5.4.4-src.tar.gz) = 118099492
diff --git a/graphics/gmt5/files/patch-src_CMakeLists.txt b/graphics/gmt5/files/patch-src_CMakeLists.txt
new file mode 100644
index 000000000000..1041072c7fe8
--- /dev/null
+++ b/graphics/gmt5/files/patch-src_CMakeLists.txt
@@ -0,0 +1,22 @@
+--- src/CMakeLists.txt.orig 2018-03-10 21:01:02 UTC
++++ src/CMakeLists.txt
+@@ -40,6 +40,10 @@ message (STATUS "Searching dependent lib
+ find_package (NETCDF REQUIRED)
+ include_directories (${NETCDF_INCLUDE_DIR})
+
++#libexecinfo is required in *BSD
++find_package(Backtrace REQUIRED)
++list (APPEND GMT_OPTIONAL_LIBRARIES ${Backtrace_LIBRARIES})
++
+ # libcurl is required since 5.4
+ find_package (CURL REQUIRED)
+ include_directories (${CURL_INCLUDE_DIRS})
+@@ -560,7 +564,7 @@ endif (HAVE_M_LIBRARY)
+ # set the build version (VERSION) and the API version (SOVERSION)
+ set_target_properties (gmtlib
+ PROPERTIES
+- OUTPUT_NAME gmt
++ OUTPUT_NAME gmt5
+ PREFIX "${LIB_PREFIX}"
+ IMPORT_PREFIX "${LIB_PREFIX}"
+ VERSION ${GMT_LIB_VERSION}
diff --git a/graphics/gmt5/files/patch-src_common__string.h b/graphics/gmt5/files/patch-src_common__string.h
new file mode 100644
index 000000000000..a48e4055fc05
--- /dev/null
+++ b/graphics/gmt5/files/patch-src_common__string.h
@@ -0,0 +1,12 @@
+--- src/common_string.h.orig 2018-08-21 09:40:24 UTC
++++ src/common_string.h
+@@ -82,7 +82,9 @@ EXTERN_MSC char *stresep (char **stringp
+
+ EXTERN_MSC int gmt_match_string_in_file (const char *filename, const char *string);
+
++#ifndef __FreeBSD__
+ EXTERN_MSC char *basename(char *path);
++#endif
+
+ #ifdef __cplusplus
+ }
diff --git a/graphics/gmt5/pkg-descr b/graphics/gmt5/pkg-descr
new file mode 100644
index 000000000000..b7cc686b4b5a
--- /dev/null
+++ b/graphics/gmt5/pkg-descr
@@ -0,0 +1,6 @@
+GMT is an open source collection of ~130 tools for manipulating
+geographic and Cartesian data sets and producing PostScript
+illustrations ranging from simple x-y plots via contour maps to
+artificially illuminated surfaces and 3D perspective views.
+
+WWW: https://gmt.soest.hawaii.edu/
diff --git a/graphics/gmt5/pkg-plist b/graphics/gmt5/pkg-plist
new file mode 100644
index 000000000000..0cff1929d445
--- /dev/null
+++ b/graphics/gmt5/pkg-plist
@@ -0,0 +1,319 @@
+bin/gmt
+bin/gmt-config-gmt5
+bin/gmt-gmt5
+bin/gmt_shell_functions-gmt5.sh
+bin/gmtswitch-gmt5
+bin/isogmt-gmt5
+etc/bash_completion.d/gmt_completion.bash
+include/gmt-gmt5/common_math.h
+include/gmt-gmt5/common_string.h
+include/gmt-gmt5/compat/qsort.h
+include/gmt-gmt5/config.h
+include/gmt-gmt5/declspec.h
+include/gmt-gmt5/gmt.h
+include/gmt-gmt5/gmt_common.h
+include/gmt-gmt5/gmt_config.h
+include/gmt-gmt5/gmt_constants.h
+include/gmt-gmt5/gmt_contour.h
+include/gmt-gmt5/gmt_core_module.h
+include/gmt-gmt5/gmt_customio.h
+include/gmt-gmt5/gmt_dcw.h
+include/gmt-gmt5/gmt_decorate.h
+include/gmt-gmt5/gmt_defaults.h
+include/gmt-gmt5/gmt_dev.h
+include/gmt-gmt5/gmt_dimensions.h
+include/gmt-gmt5/gmt_error.h
+include/gmt-gmt5/gmt_error_codes.h
+include/gmt-gmt5/gmt_fft.h
+include/gmt-gmt5/gmt_gdalread.h
+include/gmt-gmt5/gmt_grd.h
+include/gmt-gmt5/gmt_grdio.h
+include/gmt-gmt5/gmt_hash.h
+include/gmt-gmt5/gmt_io.h
+include/gmt-gmt5/gmt_macros.h
+include/gmt-gmt5/gmt_mb.h
+include/gmt-gmt5/gmt_memory.h
+include/gmt-gmt5/gmt_nan.h
+include/gmt-gmt5/gmt_notposix.h
+include/gmt-gmt5/gmt_plot.h
+include/gmt-gmt5/gmt_private.h
+include/gmt-gmt5/gmt_project.h
+include/gmt-gmt5/gmt_prototypes.h
+include/gmt-gmt5/gmt_psl.h
+include/gmt-gmt5/gmt_resources.h
+include/gmt-gmt5/gmt_shore.h
+include/gmt-gmt5/gmt_supplements_module.h
+include/gmt-gmt5/gmt_symbol.h
+include/gmt-gmt5/gmt_synopsis.h
+include/gmt-gmt5/gmt_texture.h
+include/gmt-gmt5/gmt_time.h
+include/gmt-gmt5/gmt_types.h
+include/gmt-gmt5/gmt_version.h
+include/gmt-gmt5/gshhg/gmt_gshhg.h
+include/gmt-gmt5/gshhg/gshhg.h
+include/gmt-gmt5/meca/meca.h
+include/gmt-gmt5/meca/utilmeca.h
+include/gmt-gmt5/mgd77/cm4_functions.h
+include/gmt-gmt5/mgd77/mgd77.h
+include/gmt-gmt5/mgd77/mgd77_IGF_coeffs.h
+include/gmt-gmt5/mgd77/mgd77_codes.h
+include/gmt-gmt5/mgd77/mgd77_e77.h
+include/gmt-gmt5/mgd77/mgd77_functions.h
+include/gmt-gmt5/mgd77/mgd77_init.h
+include/gmt-gmt5/mgd77/mgd77_recalc.h
+include/gmt-gmt5/mgd77/mgd77_rls_coeffs.h
+include/gmt-gmt5/mgd77/mgd77defaults.h
+include/gmt-gmt5/mgd77/mgd77magref.h
+include/gmt-gmt5/mgd77/mgd77sniffer.h
+include/gmt-gmt5/mgd77/mgd77snifferdefaults.h
+include/gmt-gmt5/postscriptlight.h
+include/gmt-gmt5/potential/okbfuns.h
+include/gmt-gmt5/psl_config.h
+include/gmt-gmt5/qsort.h
+include/gmt-gmt5/spotter/spotter.h
+include/gmt-gmt5/x2sys/x2sys.h
+lib/gmt-gmt5/plugins/supplements.so
+lib/libgmt5.so
+lib/libgmt5.so.5
+lib/libgmt5.so.5.4.4
+lib/libpostscriptlight.so
+lib/libpostscriptlight.so.5
+lib/libpostscriptlight.so.5.4.4
+%%DATADIR%%/VERSION
+%%DATADIR%%/cpt/abyss.cpt
+%%DATADIR%%/cpt/bathy.cpt
+%%DATADIR%%/cpt/categorical.cpt
+%%DATADIR%%/cpt/cool.cpt
+%%DATADIR%%/cpt/copper.cpt
+%%DATADIR%%/cpt/cubhelix.cpt
+%%DATADIR%%/cpt/cyclic.cpt
+%%DATADIR%%/cpt/dem1.cpt
+%%DATADIR%%/cpt/dem2.cpt
+%%DATADIR%%/cpt/dem3.cpt
+%%DATADIR%%/cpt/dem4.cpt
+%%DATADIR%%/cpt/drywet.cpt
+%%DATADIR%%/cpt/earth.cpt
+%%DATADIR%%/cpt/elevation.cpt
+%%DATADIR%%/cpt/etopo1.cpt
+%%DATADIR%%/cpt/gebco.cpt
+%%DATADIR%%/cpt/geo.cpt
+%%DATADIR%%/cpt/globe.cpt
+%%DATADIR%%/cpt/gray.cpt
+%%DATADIR%%/cpt/haxby.cpt
+%%DATADIR%%/cpt/hot.cpt
+%%DATADIR%%/cpt/ibcso.cpt
+%%DATADIR%%/cpt/inferno.cpt
+%%DATADIR%%/cpt/jet.cpt
+%%DATADIR%%/cpt/magma.cpt
+%%DATADIR%%/cpt/nighttime.cpt
+%%DATADIR%%/cpt/no_green.cpt
+%%DATADIR%%/cpt/ocean.cpt
+%%DATADIR%%/cpt/paired.cpt
+%%DATADIR%%/cpt/panoply.cpt
+%%DATADIR%%/cpt/plasma.cpt
+%%DATADIR%%/cpt/polar.cpt
+%%DATADIR%%/cpt/rainbow.cpt
+%%DATADIR%%/cpt/red2green.cpt
+%%DATADIR%%/cpt/relief.cpt
+%%DATADIR%%/cpt/seafloor.cpt
+%%DATADIR%%/cpt/sealand.cpt
+%%DATADIR%%/cpt/seis.cpt
+%%DATADIR%%/cpt/split.cpt
+%%DATADIR%%/cpt/terra.cpt
+%%DATADIR%%/cpt/topo.cpt
+%%DATADIR%%/cpt/viridis.cpt
+%%DATADIR%%/cpt/world.cpt
+%%DATADIR%%/cpt/wysiwyg.cpt
+%%DATADIR%%/custom/astroid.def
+%%DATADIR%%/custom/circle.def
+%%DATADIR%%/custom/cross.def
+%%DATADIR%%/custom/crosshair.def
+%%DATADIR%%/custom/deltoid.def
+%%DATADIR%%/custom/diamond.def
+%%DATADIR%%/custom/flash.def
+%%DATADIR%%/custom/gmt_custom_symbols.conf
+%%DATADIR%%/custom/hexagon.def
+%%DATADIR%%/custom/hlens.def
+%%DATADIR%%/custom/hlozenge.def
+%%DATADIR%%/custom/hneedle.def
+%%DATADIR%%/custom/hurricane.def
+%%DATADIR%%/custom/invtriangle.def
+%%DATADIR%%/custom/lcrescent.def
+%%DATADIR%%/custom/lflag.def
+%%DATADIR%%/custom/ltriangle.def
+%%DATADIR%%/custom/meca.def
+%%DATADIR%%/custom/octagon.def
+%%DATADIR%%/custom/pacman.def
+%%DATADIR%%/custom/pentagon.def
+%%DATADIR%%/custom/rcrescent.def
+%%DATADIR%%/custom/rflag.def
+%%DATADIR%%/custom/rtriangle.def
+%%DATADIR%%/custom/sectoid.def
+%%DATADIR%%/custom/square.def
+%%DATADIR%%/custom/squaroid.def
+%%DATADIR%%/custom/star.def
+%%DATADIR%%/custom/star3.def
+%%DATADIR%%/custom/star4.def
+%%DATADIR%%/custom/starp.def
+%%DATADIR%%/custom/sun.def
+%%DATADIR%%/custom/triangle.def
+%%DATADIR%%/custom/trirot1.def
+%%DATADIR%%/custom/trirot2.def
+%%DATADIR%%/custom/trirot3.def
+%%DATADIR%%/custom/trirot4.def
+%%DATADIR%%/custom/vlens.def
+%%DATADIR%%/custom/vlozenge.def
+%%DATADIR%%/custom/vneedle.def
+%%DATADIR%%/custom/volcano.def
+%%DATADIR%%/dbase/grdraster.info
+%%DATADIR%%/localization/br.d
+%%DATADIR%%/localization/gmt_cn1.locale
+%%DATADIR%%/localization/gmt_cn2.locale
+%%DATADIR%%/localization/gmt_de.locale
+%%DATADIR%%/localization/gmt_dk.locale
+%%DATADIR%%/localization/gmt_eh.locale
+%%DATADIR%%/localization/gmt_es.locale
+%%DATADIR%%/localization/gmt_fi.locale
+%%DATADIR%%/localization/gmt_fr.locale
+%%DATADIR%%/localization/gmt_gr.locale
+%%DATADIR%%/localization/gmt_hi.locale
+%%DATADIR%%/localization/gmt_hu.locale
+%%DATADIR%%/localization/gmt_ie.locale
+%%DATADIR%%/localization/gmt_il.locale
+%%DATADIR%%/localization/gmt_is.locale
+%%DATADIR%%/localization/gmt_it.locale
+%%DATADIR%%/localization/gmt_jp.locale
+%%DATADIR%%/localization/gmt_kr.locale
+%%DATADIR%%/localization/gmt_nl.locale
+%%DATADIR%%/localization/gmt_no.locale
+%%DATADIR%%/localization/gmt_pl.locale
+%%DATADIR%%/localization/gmt_pt.locale
+%%DATADIR%%/localization/gmt_ru.locale
+%%DATADIR%%/localization/gmt_se.locale
+%%DATADIR%%/localization/gmt_sg.locale
+%%DATADIR%%/localization/gmt_to.locale
+%%DATADIR%%/localization/gmt_tr.locale
+%%DATADIR%%/localization/gmt_uk.locale
+%%DATADIR%%/localization/gmt_us.locale
+%%DATADIR%%/mgd77/Dst_all.wdc
+%%DATADIR%%/mgd77/F107_mon.plt
+%%DATADIR%%/mgd77/mgd77_paths.txt
+%%DATADIR%%/mgd77/umdl.CM4
+%%DATADIR%%/mgg/carter.d
+%%DATADIR%%/mgg/gmtfile_paths
+%%DATADIR%%/postscriptlight/PSL_custom_fonts.txt
+%%DATADIR%%/postscriptlight/PSL_label.ps
+%%DATADIR%%/postscriptlight/PSL_pattern_01.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_02.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_03.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_04.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_05.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_06.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_07.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_08.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_09.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_10.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_11.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_12.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_13.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_14.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_15.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_16.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_17.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_18.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_19.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_20.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_21.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_22.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_23.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_24.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_25.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_26.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_27.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_28.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_29.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_30.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_31.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_32.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_33.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_34.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_35.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_36.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_37.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_38.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_39.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_40.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_41.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_42.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_43.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_44.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_45.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_46.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_47.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_48.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_49.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_50.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_51.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_52.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_53.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_54.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_55.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_56.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_57.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_58.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_59.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_60.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_61.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_62.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_63.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_64.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_65.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_66.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_67.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_68.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_69.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_70.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_71.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_72.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_73.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_74.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_75.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_76.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_77.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_78.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_79.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_80.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_81.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_82.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_83.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_84.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_85.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_86.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_87.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_88.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_89.ras
+%%DATADIR%%/postscriptlight/PSL_pattern_90.ras
+%%DATADIR%%/postscriptlight/PSL_prologue.ps
+%%DATADIR%%/postscriptlight/PSL_text.ps
+%%DATADIR%%/postscriptlight/gmt_custom_media.conf
+%%DATADIR%%/spotter/Global_EarthByte_230-0Ma_GK07_AREPS.rot
+%%DATADIR%%/spotter/Global_EarthByte_Plate_ID_Table.txt
+%%DATADIR%%/spotter/Global_EarthByte_Plate_ID_Table_AREPS.txt
+%%DATADIR%%/spotter/Matthews_etal_GPC_2016_410-0Ma_GK07.rot
+%%DATADIR%%/tools/gmt5syntax
+%%DATADIR%%/tools/gmt_aliases.csh
+%%DATADIR%%/tools/gmt_functions.sh
+%%DATADIR%%/tools/gmt_links.sh
+%%DATADIR%%/tools/gmt_make_custom_code.sh
+%%DATADIR%%/tools/gmt_prepmex.sh
+%%DATADIR%%/tools/gmt_uninstall.sh
+%%DATADIR%%/tools/img2google
+%%DATADIR%%/tools/ncdeflate
+%%DATADIR%%/x2sys/dat.def
+%%DATADIR%%/x2sys/geo.def
+%%DATADIR%%/x2sys/geoz.def
+%%DATADIR%%/x2sys/gmt.def
+%%DATADIR%%/x2sys/mgd77+.def
+%%DATADIR%%/x2sys/mgd77.def
+%%DATADIR%%/x2sys/xy.def
+%%DATADIR%%/x2sys/xyz.def