aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-07 21:08:22 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-09-07 21:08:22 +0000
commit70e175ed96eb4254bd1457cda38601b72a125a0e (patch)
treeec56efa85c0d4eaf0ec38a1cc9f6317b65ac20dc
parent889ec1900a289f6ab6b3903efaae7f3021391329 (diff)
downloadports-70e175ed96eb4254bd1457cda38601b72a125a0e.tar.gz
ports-70e175ed96eb4254bd1457cda38601b72a125a0e.zip
Notes
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/fv/Makefile45
-rw-r--r--graphics/fv/distinfo2
-rw-r--r--graphics/fv/files/patch-common.h15
-rw-r--r--graphics/fv/pkg-descr17
5 files changed, 80 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 8c87f77bfd01..1babe480e9c7 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -116,6 +116,7 @@
SUBDIR += frontline
SUBDIR += ftgl
SUBDIR += fujiplay
+ SUBDIR += fv
SUBDIR += fyre
SUBDIR += g2
SUBDIR += g3dviewer
diff --git a/graphics/fv/Makefile b/graphics/fv/Makefile
new file mode 100644
index 000000000000..9d94102e5ac7
--- /dev/null
+++ b/graphics/fv/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: fv
+# Date created: 07 Sep 2005
+# Whom: Igor Pokrovsky <ip@doom.homeunix.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fv
+PORTVERSION= 1.01
+CATEGORIES= graphics
+MASTER_SITES= http://www.eaflux.com/fv/sources/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= ip@doom.homeunix.org
+COMMENT= A viewer of hdr/pfm images
+
+LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut \
+ png.5:${PORTSDIR}/graphics/png
+
+USE_ZIP= yes
+USE_GCC= 3.3+
+USE_GETOPT_LONG=yes
+USE_GL= yes
+USE_X_PREFIX= yes
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README
+
+do-build:
+ ${CXX} ${CXXFLAGS} -DNDEBUG -DHAVE_DECL_GETOPT -I${X11BASE}/include \
+ -I${LOCALBASE}/include -I${WRKSRC} ${CPPFLAGS} \
+ ${PTHREAD_CFLAGS} ${LDFLAGS} -L${X11BASE}/lib \
+ -L${LOCALBASE}/lib -lpng -lz -lbz2 -lglut -lGLU -lGL -lXi \
+ -lXmu -lX11 -lXext -lSM -lm ${PTHREAD_LIBS} \
+ -o ${WRKSRC}/${PORTNAME} ${WRKSRC}/*.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+
+.ifndef (NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/fv/distinfo b/graphics/fv/distinfo
new file mode 100644
index 000000000000..aaa3393810a3
--- /dev/null
+++ b/graphics/fv/distinfo
@@ -0,0 +1,2 @@
+MD5 (fv-src-1.01.zip) = 0ad6b8fda55f22dc1d0dc21c8fe6ae57
+SIZE (fv-src-1.01.zip) = 41089
diff --git a/graphics/fv/files/patch-common.h b/graphics/fv/files/patch-common.h
new file mode 100644
index 000000000000..8dc6c8e4fe30
--- /dev/null
+++ b/graphics/fv/files/patch-common.h
@@ -0,0 +1,15 @@
+--- common.h.orig
++++ common.h
+@@ -38,7 +38,12 @@
+ #include <fcntl.h>
+ #include <map>
+ #include <pthread.h>
++#if (defined(__unix__) || defined(unix)) && !defined(USG)
++#include <sys/param.h>
++#endif
++#ifndef BSD
+ #include <stdint.h>
++#endif
+ #include <string>
+ #include <sys/stat.h>
+ #include <sys/time.h>
diff --git a/graphics/fv/pkg-descr b/graphics/fv/pkg-descr
new file mode 100644
index 000000000000..0b122e970eec
--- /dev/null
+++ b/graphics/fv/pkg-descr
@@ -0,0 +1,17 @@
+fv is an HDRI viewer. Currently supported formats are the followings:
+* Greg Ward's HDR (also known as Radiance/PIC/RGBE). See
+ http://www.graphics.cornell.edu/~bjw/rgbe.html for details.
+* Paul Debevec's PFM (Portable Float Map). See
+ http://netpbm.sourceforge.net/doc/pfm.html for details.
+
+fv reads data from the standard input or files specified as
+arguments. In the latter case, each file may be compressed one with
+gzip or bzip2. The file may also change after fv is invoked, except
+its header part. fv checks whether the file changes and updates the
+display if necessary. This feature is useful for checking intermediate
+outputs from renderers.
+
+WWW: http://www.eaflux.com/fv/
+
+- Igor Pokrovsky
+ip@doom.homeunix.org