aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-06 09:06:18 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-06 09:06:18 +0000
commit7124f82a056630174526ee5c5855f7bb131c031d (patch)
treed6cb71c133829ea5712dab4f85c4687bd6795512
parent295e4d6cffc94b03cc3e1db9b44760650bcffdb5 (diff)
downloadports-7124f82a056630174526ee5c5855f7bb131c031d.tar.gz
ports-7124f82a056630174526ee5c5855f7bb131c031d.zip
Notes
-rw-r--r--misc/mc/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 86da5ecc92f2..62515a38233f 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -18,6 +18,8 @@ LICENSE= GPLv3
CONFLICTS= mc-light-4*
+BROKEN= does not fetch
+
USES= pkgconfig
USE_GMAKE= yes
USE_GNOME= glib20
@@ -39,7 +41,7 @@ post-patch:
${REINPLACE_CMD} -e 's/SUBDIRS = intl/SUBDIRS =/' ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's/saved_CPPFLAGS="-ltermcap/saved_CPPFLAGS="/' ${WRKSRC}/configure
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_SAMBA) || !(defined(WITHOUT_SAMBA) || defined(MINIMAL))
CONFIGURE_ARGS+=--enable-vfs-smb --with-configdir=${LOCALBASE}/etc\
@@ -60,7 +62,7 @@ PLIST_SUB+= NLS="@comment "
.else
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_GETTEXT= yes
+USES+= gettext
PLIST_SUB+= NLS=""
_MANLANG= es hu it pl ru sr
.endif
@@ -95,4 +97,4 @@ _MAN1= mc.1
_MANPAGES+= ${_MAN1:S%^%${MAN1PREFIX}/man/${lang}/man1/%}
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>