aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 11:59:18 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-12-20 11:59:18 +0000
commit7146cbc5d73c74006aad743cc648199e755b3f49 (patch)
tree0d0851281f2ec920960ee113bc90e8c90fb8b5a2
parentfc631bd198463ccfb8fa6d003bb0f253491bdefd (diff)
downloadports-7146cbc5d73c74006aad743cc648199e755b3f49.tar.gz
ports-7146cbc5d73c74006aad743cc648199e755b3f49.zip
Notes
-rw-r--r--games/q3cellshading/Makefile1
-rw-r--r--games/quake3-data/Makefile3
-rw-r--r--games/quake3-data/Makefile.include49
-rw-r--r--games/quake3-excessive/Makefile4
-rw-r--r--games/quake3-freezetag/Makefile4
-rw-r--r--games/quake3-osp/Makefile4
-rw-r--r--games/quake3-ra3/Makefile4
-rw-r--r--games/quake3-ut/Makefile4
-rw-r--r--games/quake3-wfa/Makefile4
-rw-r--r--games/quake3/Makefile1
10 files changed, 48 insertions, 30 deletions
diff --git a/games/q3cellshading/Makefile b/games/q3cellshading/Makefile
index 8fa5ce2be241..39e51c0d3b67 100644
--- a/games/q3cellshading/Makefile
+++ b/games/q3cellshading/Makefile
@@ -23,6 +23,7 @@ COMMENT= Quake III Arena -- first person shooter (native build)
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_ZIP= yes
+USE_CRLF= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_PERL5_BUILD=yes
diff --git a/games/quake3-data/Makefile b/games/quake3-data/Makefile
index 906e61d1a266..e176c25ae6d1 100644
--- a/games/quake3-data/Makefile
+++ b/games/quake3-data/Makefile
@@ -10,6 +10,7 @@ DISTVERSION= 1.32b-3
CATEGORIES= games
MASTER_SITES= ftp://ftp.idsoftware.com/idstuff/quake3/linux/ \
ftp://ftp.fasta.fh-dortmund.de/mirror/idstuff/quake3/linux/
+PKGNAMEPREFIX= ${Q3PKGNAMEPREFIX}
DISTNAME= linuxq3apoint-${DISTVERSION}.x86
EXTRACT_SUFX= .run
@@ -21,6 +22,8 @@ NO_WRKSUBDIR= yes
OPTIONS= TEAMARENA "Install Quake III Team Arena data files" on
+DATADIR= ${Q3DIR}
+
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
diff --git a/games/quake3-data/Makefile.include b/games/quake3-data/Makefile.include
index cede8bcd61de..e2a071493c47 100644
--- a/games/quake3-data/Makefile.include
+++ b/games/quake3-data/Makefile.include
@@ -1,44 +1,33 @@
-# Makefile for defining variables used by other Quake III Arena related ports.
+# Makefile for defining variables used by other Doom related ports.
-# Package name prefix.
+# Set variables.
-Q3PKGNAMEPREFIX=quake3-
+Q3PKGNAMEPREFIX?=quake3-
+Q3DIR?= ${LOCALBASE}/share/quake3
-.if ${PORTNAME} != "quake3"
-PKGNAMEPREFIX?= ${Q3PKGNAMEPREFIX}
-.endif
+# Add them to the environment.
+
+MAKE_ENV+= Q3DIR="${Q3DIR}"
+PLIST_SUB+= Q3DIR="${Q3DIR:S/${LOCALBASE}\///}"
+SUB_LIST+= Q3DIR="${Q3DIR}"
-# Dependency to "games/quake3-data".
+# Add the dependency.
.if ${PORTNAME} != "data"
RUN_DEPENDS+= ${Q3DIR}/baseq3/pak1.pk3:${PORTSDIR}/games/quake3-data
.endif
-# Installation directories.
-
-Q3DIR= ${LOCALBASE}/share/quake3
-
-.if ${PORTNAME} == "data" || ${PORTNAME} == "quake3"
-DATADIR?= ${Q3DIR}
-.else
-DATADIR?= ${Q3DIR}/${PORTNAME}
-.endif
+# DOS to Unix text conversion.
-DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-
-PLIST_SUB+= Q3DIR="${Q3DIR:S/${PREFIX}\///}"
-
-# Convert "dos" text files to "unix".
-
-.if defined(USE_ZIP)
+.if defined(USE_CRLF)
+. if defined(USE_ZIP)
EXTRACT_BEFORE_ARGS= -aqo
-.else
+. else
USE_REINPLACE= yes
-REINPLACE_ARGS= -i ""
-
pre-patch:
-# remove trailing ^M
- @${FIND} -E ${WRKSRC} -type f \
- -iregex ".*\.(bat|cfg|gam|htm|html|inf|ini|lst|sc|scr|txt|url)" \
- -exec ${REINPLACE_CMD} -e "s|`${ECHO_CMD} -e '\r'`$$||" {} \;
+ @${FIND} ${WRKDIR} -type f -print0 | \
+ ${XARGS} -0 ${FILE} | ${GREP} 'CRLF' | \
+ ${SED} -e "s/:.*//" | ${SED} -e 's/ /\\ /g' | \
+ ${XARGS} ${REINPLACE_CMD} -i "" -e "s/`${PRINTF} '\r'`$$//"
+. endif
.endif
diff --git a/games/quake3-excessive/Makefile b/games/quake3-excessive/Makefile
index b1c526fcc761..b09f1e07c03e 100644
--- a/games/quake3-excessive/Makefile
+++ b/games/quake3-excessive/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 003
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pat
+PKGNAMEPREFIX= ${Q3PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}_q3_server_${PORTVERSION}
MAINTAINER= pat@FreeBSD.org
@@ -18,8 +19,11 @@ COMMENT= Quake III Arena Mod: Excessive
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_ZIP= yes
+USE_CRLF= yes
NO_BUILD= yes
+DATADIR= ${Q3DIR}/${PORTNAME}
+
post-extract:
@(cd ${WRKSRC}; ${UNZIP_CMD} description.pk3)
diff --git a/games/quake3-freezetag/Makefile b/games/quake3-freezetag/Makefile
index 9356118330fb..e94719953d40 100644
--- a/games/quake3-freezetag/Makefile
+++ b/games/quake3-freezetag/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 1.51b
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= pat
+PKGNAMEPREFIX= ${Q3PKGNAMEPREFIX}
DISTNAME= q3freeze${PORTVERSION:S/.//}
MAINTAINER= pat@FreeBSD.org
@@ -18,8 +19,11 @@ COMMENT= Quake III Arena Mod: Freeze Tag
WRKSRC= ${WRKDIR}/freeze
USE_ZIP= yes
+USE_CRLF= yes
NO_BUILD= yes
+DATADIR= ${Q3DIR}/${PORTNAME}
+
.include "${.CURDIR}/../quake3-data/Makefile.include"
.include <bsd.port.pre.mk>
diff --git a/games/quake3-osp/Makefile b/games/quake3-osp/Makefile
index 9531a9831d7c..de4d87bf2f42 100644
--- a/games/quake3-osp/Makefile
+++ b/games/quake3-osp/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 1.03a
CATEGORIES= games
MASTER_SITES= ${MASTER_SITE_GENTOO}
MASTER_SITE_SUBDIR= distfiles
+PKGNAMEPREFIX= ${Q3PKGNAMEPREFIX}
DISTNAME= osp-Quake3-${PORTVERSION}_full
MAINTAINER= pat@FreeBSD.org
@@ -18,8 +19,11 @@ COMMENT= Quake III Arena Mod: OSP Tourney DM/CA/CTF
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_ZIP= yes
+USE_CRLF= yes
NO_BUILD= yes
+DATADIR= ${Q3DIR}/${PORTNAME}
+
do-install:
@${MKDIR} ${DATADIR}
.for f in *.cfg *.pk3 description.txt filters.txt
diff --git a/games/quake3-ra3/Makefile b/games/quake3-ra3/Makefile
index 275d3b5c4043..b1ec0a2fe0fa 100644
--- a/games/quake3-ra3/Makefile
+++ b/games/quake3-ra3/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 1.76
CATEGORIES= games
MASTER_SITES= ftp.clanbase.com/pub/ \
ftp.mirrors.degnet.de/pub/misc/PlanetQuake3.net/modifications/rocketarena3/
+PKGNAMEPREFIX= ${Q3PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}${PORTVERSION:S/.//}
MAINTAINER= pat@FreeBSD.org
@@ -20,8 +21,11 @@ NO_PACKAGE= "Package will be 102MB, set FORCE_PACKAGE if you really want to buil
WRKSRC= ${WRKDIR}/arena
USE_ZIP= yes
+USE_CRLF= yes
NO_BUILD= yes
+DATADIR= ${Q3DIR}/${PORTNAME}
+
do-install:
@${MKDIR} ${DATADIR}
.for f in *.cfg *.pk3
diff --git a/games/quake3-ut/Makefile b/games/quake3-ut/Makefile
index 36155dd63550..d81feb345b44 100644
--- a/games/quake3-ut/Makefile
+++ b/games/quake3-ut/Makefile
@@ -9,16 +9,20 @@ PORTNAME= ut
PORTVERSION= 3.7
CATEGORIES= games
MASTER_SITES= ftp://ftp.snt.utwente.nl/pub/games/urbanterror/
+PKGNAMEPREFIX= ${Q3PKGNAMEPREFIX}
DISTNAME= urbanTerror${PORTVERSION:S/.//}_full
MAINTAINER= pat@FreeBSD.org
COMMENT= Quake III Arena Mod: Urban Terror
USE_ZIP= yes
+USE_CRLF= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
NO_PACKAGE= "Distfile is \>256MB\; define FORCE_PACKAGE if you really want this."
+DATADIR= ${Q3DIR}/${PORTNAME}
+
do-install:
@${MKDIR} ${DATADIR}
.for f in *.pk3 description.txt
diff --git a/games/quake3-wfa/Makefile b/games/quake3-wfa/Makefile
index 03e1c446464c..5c79b75d79a9 100644
--- a/games/quake3-wfa/Makefile
+++ b/games/quake3-wfa/Makefile
@@ -9,6 +9,7 @@ PORTNAME= wfa
PORTVERSION= 3.5b
CATEGORIES= games
MASTER_SITES= http://www.ijs.si/~lesi/distfiles/
+PKGNAMEPREFIX= ${Q3PKGNAMEPREFIX}
DISTFILES= WFA35Engine.zip WFA35MapPack1.zip WFA35MapPack2.zip \
WFA_v35b.zip 35b_mappack1.zip
DIST_SUBDIR= ${PORTNAME}
@@ -19,9 +20,12 @@ COMMENT= Quake III Arena Mod: Weapons Factory Arena
NO_PACKAGE= "Package will be 138MB, set FORCE_PACKAGE if you really want to build it"
USE_ZIP= yes
+USE_CRLF= yes
NO_BUILD= yes
NO_WRKSUBDIR= yes
+DATADIR= ${Q3DIR}/${PORTNAME}
+
post-extract:
@${RM} ${WRKSRC}/help/BobWFACfgV236.exe
diff --git a/games/quake3/Makefile b/games/quake3/Makefile
index 8fa5ce2be241..39e51c0d3b67 100644
--- a/games/quake3/Makefile
+++ b/games/quake3/Makefile
@@ -23,6 +23,7 @@ COMMENT= Quake III Arena -- first person shooter (native build)
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
USE_ZIP= yes
+USE_CRLF= yes
USE_GMAKE= yes
USE_REINPLACE= yes
USE_PERL5_BUILD=yes