aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-01-06 21:33:21 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-01-06 21:33:21 +0000
commit71e5bb2abe92b87556f6c55acc3c50962d0b4524 (patch)
treea23c6b149b807b9b3910875d1c381a87b2d24249
parenta65b37a7ebee99e398465b168bf2e9cf89085093 (diff)
downloadports-71e5bb2abe92b87556f6c55acc3c50962d0b4524.tar.gz
ports-71e5bb2abe92b87556f6c55acc3c50962d0b4524.zip
Convert jlaffayes's ports to new options framework
Approved by: jlaffaye
Notes
Notes: svn path=/head/; revision=310017
-rw-r--r--audio/mpdscribble/Makefile17
-rw-r--r--databases/soci/Makefile18
-rw-r--r--irc/libircclient/Makefile20
-rw-r--r--textproc/discount/Makefile26
4 files changed, 36 insertions, 45 deletions
diff --git a/audio/mpdscribble/Makefile b/audio/mpdscribble/Makefile
index a9aaf5dcb255..b01086045e1b 100644
--- a/audio/mpdscribble/Makefile
+++ b/audio/mpdscribble/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: mpdscribble
-# Date created: July 13 2006
-# Whom: Stepan Zastupov [RedChrom] <redchrom@gmail.com>
-#
+# Created by: Stepan Zastupov [RedChrom] <redchrom@gmail.com>
# $FreeBSD$
-#
PORTNAME= mpdscribble
PORTVERSION= 0.22
@@ -24,11 +20,12 @@ USE_RC_SUBR= mpdscribble
MAN1= mpdscribble.1
-OPTIONS= SOUP "Use libsoup instead of libcurl" off
+OPTIONS_DEFINE= SOUP DOCS
+SOUP_DESC= Use libsoup instead of libcurl
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_SOUP)
+.if ${PORT_OPTIONS:MSOUP}
LIB_DEPENDS+= soup-2.4.1:${PORTSDIR}/devel/libsoup
CONFIGURE_ARGS+= --with-http-client=soup
.else
@@ -43,11 +40,11 @@ do-install:
.if !exists(${PREFIX}/etc/mpdscribble.conf)
@(cd ${PREFIX}/etc && ${CP} mpdscribble.conf.sample mpdscribble.conf)
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS NEWS README
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/soci/Makefile b/databases/soci/Makefile
index 1d1ae7f75aa0..5514eb2fd060 100644
--- a/databases/soci/Makefile
+++ b/databases/soci/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: soci
-# Date created: 2010-09-13
-# Whom: Julien Laffaye <kimelto@gmail.com>
-#
+# Created by: Julien Laffaye <kimelto@gmail.com>
# $FreeBSD$
-#
PORTNAME= soci
PORTVERSION= 3.0.0
@@ -28,12 +24,12 @@ ALL_TARGET= build_libs
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-OPTIONS= MYSQL "Build MySQL driver" on \
- PGSQL "Build PostgreSQL driver" on
+OPTIONS_DEFINE= MYSQL PGSQL
+OPTIONS_DEFAULT= MYSQL PGSQL
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.ifdef (WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
USE_MYSQL= yes
PLIST_SUB+= MYSQL=""
CONFIGURE_ARGS+=--mysql-include=${LOCALBASE}/include/mysql \
@@ -42,7 +38,7 @@ CONFIGURE_ARGS+=--mysql-include=${LOCALBASE}/include/mysql \
PLIST_SUB+= MYSQL="@comment "
.endif
-.ifdef (WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
PLIST_SUB+= PGSQL=""
CONFIGURE_ARGS+=--postgresql-include=${LOCALBASE}/include \
@@ -58,4 +54,4 @@ post-patch:
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/irc/libircclient/Makefile b/irc/libircclient/Makefile
index e0e4be5e7f63..b422b0d379ca 100644
--- a/irc/libircclient/Makefile
+++ b/irc/libircclient/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libircclient
-# Date created: 2008-11-20
-# Whom: Julien Laffaye <kimelto@gmail.com>
-#
+# Created by: Julien Laffaye <kimelto@gmail.com>
# $FreeBSD$
-#
PORTNAME= libircclient
PORTVERSION= 1.6
@@ -13,18 +9,20 @@ MASTER_SITES= SF
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= An IRC library to create IRC clients
-OPTIONS= SSL "Build with SSL Support" on \
- IPV6 "Build with IPv6 Support" on
+OPTIONS_DEFINE= OPENSSL IPV6 DOCS EXAMPLES
+OPTIONS_DEFAULT= OPENSSL
BUILD_WRKSRC= ${WRKSRC}/src
GNU_CONFIGURE= yes
-.if !defined(WITHOUT_SSL)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MOPENSSL}
CONFIGURE_ARGS+= --enable-openssl
USE_OPENSSL= yes
.endif
-.if !defined(WITHOUT_IPV6)
+.if ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --enable-ipv6
.endif
@@ -37,11 +35,11 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/src/libircclient.a ${PREFIX}/lib
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${ECHO_MSG} "installing additional documentation to ${DOCSDIR}"
@(cd ${WRKSRC}/doc/html/ && ${COPYTREE_SHARE} \* ${DOCSDIR})
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${ECHO_MSG} "installing additional examples to ${EXAMPLESDIR}"
@(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
diff --git a/textproc/discount/Makefile b/textproc/discount/Makefile
index c9c18ba80066..e62f6ed92209 100644
--- a/textproc/discount/Makefile
+++ b/textproc/discount/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: discount
-# Date created: 2009-04-22
-# Whom: Julien Laffaye <kimelto@gmail.com>
-#
+# Created by: Julien Laffaye <kimelto@gmail.com>
# $FreeBSD$
-#
PORTNAME= discount
PORTVERSION= 2.1.1.3
@@ -47,21 +43,25 @@ PLIST_FILES= bin/markdown \
lib/libmarkdown.a \
include/mkdio.h
-OPTIONS= EXTRA "Enable all extra features" on \
- TAB8 "Use a tabstop of 8 (default is 4)" on \
- SAMPLES "Install sample programs" off
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= EXTRA TAB8 SAMPLES
+OPTIONS_DEFAULT= EXTRA TAB8
-.ifdef (WITH_EXTRA)
+EXTRA_DESC= Enable all extra features
+TAB8_DESC= Use a tabstop of 8 (default is 4)
+SAMPLES_DESC= Install sample programs
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MEXTRA}
CONFIGURE_ARGS+=--enable-dl-tag \
--enable-all-features
.endif
-.ifdef (WITH_TAB8)
+.if ${PORT_OPTIONS:MTAB8}
CONFIGURE_ARGS+=--with-tabstops=8
.endif
-.ifdef (WITH_SAMPLES)
+.if ${PORT_OPTIONS:MSAMPLES}
INSTALL_TARGET+=install.samples
PLIST_FILES+= bin/makepage \
bin/mkd2html \
@@ -72,4 +72,4 @@ MAN1+= makepage.1 \
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>