aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2013-11-01 09:57:50 +0000
committerRenato Botelho <garga@FreeBSD.org>2013-11-01 09:57:50 +0000
commit725bdaafc9e53ceec561005a3917a69a5f72baa0 (patch)
tree0d24d2a10080624ae4a3da6c2808221490647fa2
parente6a4796d7366ed80f8bd9a502de3c32b5e405415 (diff)
downloadports-725bdaafc9e53ceec561005a3917a69a5f72baa0.tar.gz
ports-725bdaafc9e53ceec561005a3917a69a5f72baa0.zip
Fix wrong use of OPTIONS_SUB
Reported by: danfe
Notes
Notes: svn path=/head/; revision=332346
-rw-r--r--archivers/sharutils/Makefile2
-rw-r--r--devel/libslang2/Makefile2
-rw-r--r--editors/jed/Makefile2
-rw-r--r--net/xmlrpc-c-devel/Makefile2
-rw-r--r--www/dansguardian-devel/Makefile2
-rw-r--r--www/dansguardian/Makefile2
-rw-r--r--www/sarg/Makefile2
7 files changed, 7 insertions, 7 deletions
diff --git a/archivers/sharutils/Makefile b/archivers/sharutils/Makefile
index 0b81d763e883..02e19fb1620b 100644
--- a/archivers/sharutils/Makefile
+++ b/archivers/sharutils/Makefile
@@ -20,8 +20,8 @@ CONFIGURE_ARGS= --program-prefix=g --disable-uucode
INSTALL_TARGET= install install-man
INFO= sharutils
USES= charsetfix perl5
+OPTIONS_SUB= yes
-OPTIONS_SUB= NLS
NLS_USES= gettext
NLS_CONFIGURE_ON= --with-libintl-prefix="${LOCALBASE}"
NLS_CONFIGURE_OFF= --disable-nls
diff --git a/devel/libslang2/Makefile b/devel/libslang2/Makefile
index 488bc31f4c22..86909d1b2976 100644
--- a/devel/libslang2/Makefile
+++ b/devel/libslang2/Makefile
@@ -32,7 +32,7 @@ DATADIR= ${PREFIX}/share/slsh
OPTIONS_DEFINE= PCRE PNG ICONV ONIG DOCS
OPTIONS_DEFAULT=PCRE PNG ICONV DOCS
-OPTIONS_SUB= PCRE PNG ICONV ONIG
+OPTIONS_SUB= yes
ONIG_DESC= Oniguruma support
diff --git a/editors/jed/Makefile b/editors/jed/Makefile
index e931f13a5267..0a34322de5bb 100644
--- a/editors/jed/Makefile
+++ b/editors/jed/Makefile
@@ -21,11 +21,11 @@ CONFLICTS= jed-devel-[0-9]*
OPTIONS_DEFINE= X11 PERMS HOSTLOOKUP DOCS
OPTIONS_DEFAULT=X11 HOSTLOOKUP DOCS
-OPTIONS_SUB= X11
PERMS_DESC= Respect permissions by Root
HOSTLOOKUP_DESC=Look-up for hostname
+OPTIONS_SUB= yes
USE_BZIP2= yes
DIST_SUBDIR= jed
GNU_CONFIGURE= yes
diff --git a/net/xmlrpc-c-devel/Makefile b/net/xmlrpc-c-devel/Makefile
index 926c8da8a341..0bbb3be757fa 100644
--- a/net/xmlrpc-c-devel/Makefile
+++ b/net/xmlrpc-c-devel/Makefile
@@ -14,7 +14,6 @@ LICENSE= BSD
OPTIONS_DEFINE= DEBUG CURL LIBWWW CPLUSPLUS
OPTIONS_DEFAULT=CURL LIBWWW CPLUSPLUS
-OPTIONS_SUB= CPLUSPLUS
LIBWWW_DESC= Compile with libwww support
CPLUSPLUS_DESC= Build xmlrpc-c c++ libs and tools
@@ -22,6 +21,7 @@ CPLUSPLUS_DESC= Build xmlrpc-c c++ libs and tools
CONFLICTS= xmlrpc-epi-0.* xmlrpc-c-[0-9]*
USES= gmake
+OPTIONS_SUB= yes
USE_XZ= yes
GNU_CONFIGURE= yes
MAKEFILE= GNUmakefile
diff --git a/www/dansguardian-devel/Makefile b/www/dansguardian-devel/Makefile
index 59adfcc4e8e3..ce3e5e11c7c0 100644
--- a/www/dansguardian-devel/Makefile
+++ b/www/dansguardian-devel/Makefile
@@ -35,7 +35,7 @@ SHEBANG_FILES= ${WRKSRC}/data/dansguardian.pl
OPTIONS_DEFINE= APACHE TRICKLE CLISCAN CLAMD ICAP KAV NTLM EMAIL DEBUG SSL DOCS
OPTIONS_DEFAULT=APACHE TRICKLE DOCS
-OPTIONS_SUB= TRICKLE CLISCAN CLAMD ICAP KAV NTLM EMAIL
+OPTIONS_SUB= yes
APACHE_DESC= Enable Apache support for access denied page
TRICKLE_DESC= Enable the trickle download manager
diff --git a/www/dansguardian/Makefile b/www/dansguardian/Makefile
index 86e09e8fd786..ad0cff017b88 100644
--- a/www/dansguardian/Makefile
+++ b/www/dansguardian/Makefile
@@ -33,7 +33,7 @@ SHEBANG_FILES= ${WRKSRC}/data/dansguardian.pl
OPTIONS_DEFINE= APACHE TRICKLE CLISCAN CLAMD ICAP KAV NTLM EMAIL DEBUG DOCS
OPTIONS_DEFAULT=APACHE TRICKLE DOCS
-OPTIONS_SUB= TRICKLE CLISCAN CLAMD ICAP KAV NTLM EMAIL
+OPTIONS_SUB= yes
APACHE_DESC= Enable Apache support for access denied page
TRICKLE_DESC= Enable the trickle download manager
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index d09af5e118c5..55da35f1e20b 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -15,12 +15,12 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
OPTIONS_DEFINE= GD PHP NLS PCRE LDAP ICONV
OPTIONS_DEFAULT=GD PHP NLS PCRE LDAP ICONV
-OPTIONS_SUB= PHP NLS
PHP_DESC= Install PHP for reporting generating
USES= gmake
USE_AUTOTOOLS= autoconf aclocal
+OPTIONS_SUB= yes
GNU_CONFIGURE= yes
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS= CPPFLAGS=-I${LOCALBASE}/include \