aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-09-01 11:28:17 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-09-01 11:28:17 +0000
commit729d39335209927a6dc04dc4829f4ef8b2969d74 (patch)
tree8c7e39839a18205f1d39d9cef97eb6973f568b10
parent439a1ff205ac482db17279dd6e1ac8261e54de9c (diff)
downloadports-729d39335209927a6dc04dc4829f4ef8b2969d74.tar.gz
ports-729d39335209927a6dc04dc4829f4ef8b2969d74.zip
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/fileprune/Makefile20
-rw-r--r--sysutils/fileprune/distinfo1
-rw-r--r--sysutils/fileprune/pkg-descr24
-rw-r--r--sysutils/fileprune/pkg-plist1
-rw-r--r--sysutils/prune/Makefile20
-rw-r--r--sysutils/prune/distinfo1
-rw-r--r--sysutils/prune/pkg-descr24
-rw-r--r--sysutils/prune/pkg-plist1
9 files changed, 93 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 117ceced6c3e..5f584d81f24e 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -221,6 +221,7 @@
SUBDIR += portupgrade
SUBDIR += prips
SUBDIR += procmap
+ SUBDIR += prune
SUBDIR += pslist
SUBDIR += psmisc
SUBDIR += pstack
diff --git a/sysutils/fileprune/Makefile b/sysutils/fileprune/Makefile
new file mode 100644
index 000000000000..ca559f599c7c
--- /dev/null
+++ b/sysutils/fileprune/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: prune
+# Date created: 29 August 2003
+# Whom: dds
+#
+# $FreeBSD$
+#
+
+PORTNAME= prune
+PORTVERSION= 1.7
+CATEGORIES= sysutils
+MASTER_SITES= http://www.spinellis.gr/sw/unix/prune/ \
+ http://www.dmst.aueb.gr/dds/sw/unix/prune/
+
+MAINTAINER= dds@FreeBSD.org
+COMMENT= Prune a file set according to a given age distribution
+
+MAN1= prune.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/fileprune/distinfo b/sysutils/fileprune/distinfo
new file mode 100644
index 000000000000..d3739fd6a0f4
--- /dev/null
+++ b/sysutils/fileprune/distinfo
@@ -0,0 +1 @@
+MD5 (prune-1.7.tar.gz) = 1d61f4bee4e4d41e7f667d7854ceb52b
diff --git a/sysutils/fileprune/pkg-descr b/sysutils/fileprune/pkg-descr
new file mode 100644
index 000000000000..1ef9c1ea9145
--- /dev/null
+++ b/sysutils/fileprune/pkg-descr
@@ -0,0 +1,24 @@
+Prune will delete files from the specified set targeting a given
+distribution of the files within time as well as size, number, and
+age constraints. Its main purpose is to keep a set of daily-created
+backup files in manageable size, while still providing reasonable
+access to older versions. Specifying a size, file number, or age
+constraint will simply remove files starting from the oldest, until
+the constraint is met. The distribution specification (exponential,
+Gaussian (normal), or Fibonacci) provides finer control of the files
+to delete, allowing the retention of recent copies and the increasingly
+aggressive pruning of the older files. The retention schedule
+specifies the age intervals for which files will be retained. As
+an example, an exponential retention schedule for 10 files with a
+base of 2 will be
+
+1 2 4 8 16 32 64 128 256 512 1024
+
+The above schedule specifies that for the interval of 65 to 128
+days there should be (at least) one retained file (unless constraints
+and options override this setting).
+
+
+WWW: http://www.spinellis.gr/sw/unix/prune
+
+- Diomidis Spinellis dds@aueb.gr
diff --git a/sysutils/fileprune/pkg-plist b/sysutils/fileprune/pkg-plist
new file mode 100644
index 000000000000..7f8f8104e61c
--- /dev/null
+++ b/sysutils/fileprune/pkg-plist
@@ -0,0 +1 @@
+bin/prune
diff --git a/sysutils/prune/Makefile b/sysutils/prune/Makefile
new file mode 100644
index 000000000000..ca559f599c7c
--- /dev/null
+++ b/sysutils/prune/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: prune
+# Date created: 29 August 2003
+# Whom: dds
+#
+# $FreeBSD$
+#
+
+PORTNAME= prune
+PORTVERSION= 1.7
+CATEGORIES= sysutils
+MASTER_SITES= http://www.spinellis.gr/sw/unix/prune/ \
+ http://www.dmst.aueb.gr/dds/sw/unix/prune/
+
+MAINTAINER= dds@FreeBSD.org
+COMMENT= Prune a file set according to a given age distribution
+
+MAN1= prune.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/sysutils/prune/distinfo b/sysutils/prune/distinfo
new file mode 100644
index 000000000000..d3739fd6a0f4
--- /dev/null
+++ b/sysutils/prune/distinfo
@@ -0,0 +1 @@
+MD5 (prune-1.7.tar.gz) = 1d61f4bee4e4d41e7f667d7854ceb52b
diff --git a/sysutils/prune/pkg-descr b/sysutils/prune/pkg-descr
new file mode 100644
index 000000000000..1ef9c1ea9145
--- /dev/null
+++ b/sysutils/prune/pkg-descr
@@ -0,0 +1,24 @@
+Prune will delete files from the specified set targeting a given
+distribution of the files within time as well as size, number, and
+age constraints. Its main purpose is to keep a set of daily-created
+backup files in manageable size, while still providing reasonable
+access to older versions. Specifying a size, file number, or age
+constraint will simply remove files starting from the oldest, until
+the constraint is met. The distribution specification (exponential,
+Gaussian (normal), or Fibonacci) provides finer control of the files
+to delete, allowing the retention of recent copies and the increasingly
+aggressive pruning of the older files. The retention schedule
+specifies the age intervals for which files will be retained. As
+an example, an exponential retention schedule for 10 files with a
+base of 2 will be
+
+1 2 4 8 16 32 64 128 256 512 1024
+
+The above schedule specifies that for the interval of 65 to 128
+days there should be (at least) one retained file (unless constraints
+and options override this setting).
+
+
+WWW: http://www.spinellis.gr/sw/unix/prune
+
+- Diomidis Spinellis dds@aueb.gr
diff --git a/sysutils/prune/pkg-plist b/sysutils/prune/pkg-plist
new file mode 100644
index 000000000000..7f8f8104e61c
--- /dev/null
+++ b/sysutils/prune/pkg-plist
@@ -0,0 +1 @@
+bin/prune