aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Engels <lme@FreeBSD.org>2017-07-27 18:21:21 +0000
committerLars Engels <lme@FreeBSD.org>2017-07-27 18:21:21 +0000
commit72f85d3643dca530be0c31b7ad3414d3faccd814 (patch)
treee8d820553dffe6c16cbe2e983667c5524d39803f
parent3a9179729a20884c9e47f0c43c3cddba40f0e51a (diff)
downloadports-72f85d3643dca530be0c31b7ad3414d3faccd814.tar.gz
ports-72f85d3643dca530be0c31b7ad3414d3faccd814.zip
Notes
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/icingaweb2-module-grafana/Makefile30
-rw-r--r--net-mgmt/icingaweb2-module-grafana/distinfo3
-rw-r--r--net-mgmt/icingaweb2-module-grafana/pkg-descr3
-rw-r--r--net-mgmt/icingaweb2-module-grafana/pkg-plist39
5 files changed, 76 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index bd214c002b52..b965c702b9d7 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -89,6 +89,7 @@
SUBDIR += icingaweb2-module-cube
SUBDIR += icingaweb2-module-director
SUBDIR += icingaweb2-module-generictts
+ SUBDIR += icingaweb2-module-grafana
SUBDIR += icingaweb2-module-map
SUBDIR += icli
SUBDIR += icmpmonitor
diff --git a/net-mgmt/icingaweb2-module-grafana/Makefile b/net-mgmt/icingaweb2-module-grafana/Makefile
new file mode 100644
index 000000000000..f965427036a1
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-grafana/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= icingaweb2-module-grafana
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.8
+CATEGORIES= net-mgmt www
+
+MAINTAINER= lme@FreeBSD.org
+COMMENT= Add Grafana graphs into Icinga Web 2 to display performance metrics
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= icingaweb2>=2.4.1:net-mgmt/icingaweb2
+
+USE_GITHUB= yes
+GH_ACCOUNT= mikesch-mp
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+WWWDIR?= ${PREFIX}/www/icingaweb2/modules/${PORTNAME:C/^.*-//}
+
+do-install:
+ @${RM} -r ${WRKSRC}/.README.md.swp ${WRKSRC}/.github
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC} && \
+ ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/icingaweb2-module-grafana/distinfo b/net-mgmt/icingaweb2-module-grafana/distinfo
new file mode 100644
index 000000000000..20ffb37a180d
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-grafana/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1501178110
+SHA256 (mikesch-mp-icingaweb2-module-grafana-v1.1.8_GH0.tar.gz) = 0e6a328fbb37c63b6f6bba0016c949336300d6b4dd7b97e62610bd6dd6dcfb5e
+SIZE (mikesch-mp-icingaweb2-module-grafana-v1.1.8_GH0.tar.gz) = 459896
diff --git a/net-mgmt/icingaweb2-module-grafana/pkg-descr b/net-mgmt/icingaweb2-module-grafana/pkg-descr
new file mode 100644
index 000000000000..a495071504fe
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-grafana/pkg-descr
@@ -0,0 +1,3 @@
+Add Grafana graphs into Icinga Web 2 to display performance metrics.
+
+WWW: https://github.com/Mikesch-mp/icingaweb2-module-grafana
diff --git a/net-mgmt/icingaweb2-module-grafana/pkg-plist b/net-mgmt/icingaweb2-module-grafana/pkg-plist
new file mode 100644
index 000000000000..7db34fbfb6b9
--- /dev/null
+++ b/net-mgmt/icingaweb2-module-grafana/pkg-plist
@@ -0,0 +1,39 @@
+%%WWWDIR%%/CONTRIBUTING.md
+%%WWWDIR%%/LICENSE
+%%WWWDIR%%/README.md
+%%WWWDIR%%/RELEASE.md
+%%WWWDIR%%/application/controllers/ConfigController.php
+%%WWWDIR%%/application/controllers/GraphController.php
+%%WWWDIR%%/application/forms/Config/GeneralConfigForm.php
+%%WWWDIR%%/application/forms/Graph/GraphForm.php
+%%WWWDIR%%/application/views/scripts/config/index.phtml
+%%WWWDIR%%/application/views/scripts/graph/index.phtml
+%%WWWDIR%%/application/views/scripts/graph/new.phtml
+%%WWWDIR%%/application/views/scripts/graph/remove.phtml
+%%WWWDIR%%/application/views/scripts/graph/update.phtml
+%%WWWDIR%%/application/views/scripts/index/graph.phtml
+%%WWWDIR%%/application/views/scripts/show/index.phtml
+%%WWWDIR%%/configuration.php
+%%WWWDIR%%/dashboards/graphite/base-metrics.json
+%%WWWDIR%%/dashboards/graphite/icinga2-default.json
+%%WWWDIR%%/dashboards/influxdb/base-metrics.json
+%%WWWDIR%%/dashboards/influxdb/icinga2-default.json
+%%WWWDIR%%/doc/01-about.md
+%%WWWDIR%%/doc/02-installation.md
+%%WWWDIR%%/doc/03-module-configuration.md
+%%WWWDIR%%/doc/04-graph-configuration.md
+%%WWWDIR%%/doc/images/grafana-datasource-graphite.png
+%%WWWDIR%%/doc/images/grafana-datasource-influxdb.png
+%%WWWDIR%%/doc/images/grafana-import-base-metrics-dashboard.png
+%%WWWDIR%%/doc/images/grafana-import-icinga2-default-dashboard.png
+%%WWWDIR%%/doc/images/icingaweb2_grafana_screenshot_01.png
+%%WWWDIR%%/doc/images/icingaweb2_grafana_screenshot_02.png
+%%WWWDIR%%/doc/images/icingaweb2_grafana_screenshot_03.png
+%%WWWDIR%%/doc/images/icingaweb2_grafana_screenshot_04.png
+%%WWWDIR%%/doc/images/module_grafana_configuration01.png
+%%WWWDIR%%/library/Grafana/ProvidedHook/Grapher.php
+%%WWWDIR%%/library/Grafana/ProvidedHook/Monitoring/HostActions.php
+%%WWWDIR%%/library/Grafana/Util.php
+%%WWWDIR%%/module.info
+%%WWWDIR%%/public/css/module.less
+%%WWWDIR%%/run.php