aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-05-07 09:30:51 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-05-07 09:30:51 +0000
commit74c8814c7a400e789a22d3690e89c40113b44cfc (patch)
tree7deeaa934fa0a8323de57b5ec5d288826b2bb746
parent59e2a91800c709232576be49e9c23287608e0306 (diff)
downloadports-74c8814c7a400e789a22d3690e89c40113b44cfc.tar.gz
ports-74c8814c7a400e789a22d3690e89c40113b44cfc.zip
Notes
-rw-r--r--devel/cvsdadm/Makefile14
-rw-r--r--devel/p4genpatch/Makefile18
-rw-r--r--devel/strace/Makefile19
3 files changed, 21 insertions, 30 deletions
diff --git a/devel/cvsdadm/Makefile b/devel/cvsdadm/Makefile
index 9059cc8b0f4e..d1b5386535a3 100644
--- a/devel/cvsdadm/Makefile
+++ b/devel/cvsdadm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: cvsdadm
-# Date Created: Sat Jan 21 22:05:06 EST 2006
-# Whom: Serge Gagnon <serge.gagnon.1@ulaval.ca>
-#
+# Created by: Serge Gagnon <serge.gagnon.1@ulaval.ca>
# $FreeBSD$
-#
PORTNAME= cvsdadm
PORTVERSION= 0.3.2
@@ -18,20 +14,22 @@ COMMENT= Tool for CVSd pserver user administration
WRKSRC= ${WRKDIR}/${PORTNAME}
+USES= shebangfix
NO_BUILD= yes
USE_PERL5_RUN= yes
POD2TEXT?= pod2text
PORTDOCS= cvsdadm.README
+SHEBANG_FILES= cvsdadm
+
PLIST_FILES= bin/cvsdadm
MAN1= cvsdadm.1
-post-patch:
- @${REINPLACE_CMD} -e "s,#!/usr/bin/perl,#! ${PERL}," ${WRKSRC}/cvsdadm
+.include <bsd.port.options.mk>
do-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@${POD2TEXT} ${WRKSRC}/cvsdadm > ${WRKSRC}/${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
diff --git a/devel/p4genpatch/Makefile b/devel/p4genpatch/Makefile
index 82c7dc23aa99..16e2e7d15cbf 100644
--- a/devel/p4genpatch/Makefile
+++ b/devel/p4genpatch/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: p4genpatch
-# Date created: 29 January 2005
-# Whom: bms@FreeBSD.org
-#
+# Created by: bms@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= p4genpatch
PORTVERSION= 1
@@ -19,17 +15,17 @@ RUN_DEPENDS= p4:${PORTSDIR}/devel/p4
NO_BUILD= yes
NO_WRKSUBDIR= yes
+USES= shebangfix
USE_PERL5= yes
SCRIPTS= bin/p4genpatch bin/p4d2p
PLIST_FILES= ${SCRIPTS}
-post-patch:
- ${MKDIR} ${WRKSRC}
- ${CP} -r ${FILESDIR}/bin ${WRKSRC}
-.for script in ${SCRIPTS}
- ${REINPLACE_CMD} -e 's,^#!/usr/bin/perl,#!${PERL},g' ${WRKSRC}/${script}
-.endfor
+SHEBANG_FILES= ${SCRIPTS}
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} -r ${FILESDIR}/bin ${WRKSRC}
do-install:
.for script in ${SCRIPTS}
diff --git a/devel/strace/Makefile b/devel/strace/Makefile
index d18437136dc4..d9b55faeb8f0 100644
--- a/devel/strace/Makefile
+++ b/devel/strace/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: strace
-# Date created: Tue May 15 22:29:27 MSD 2001
-# Whom: Alex Semenyaka <alex@rinet.ru>
-#
+# Created by: Alex Semenyaka <alex@rinet.ru>
# $FreeBSD$
-#
PORTNAME= strace
PORTVERSION= 4.5.18
@@ -14,30 +10,31 @@ MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= A portable process tracer
+USES= shebangfix
USE_BZIP2= yes
USE_PERL5= yes # for strace-graph
GNU_CONFIGURE= yes
ONLY_FOR_ARCHS= i386
-PLIST_FILES= bin/strace bin/strace-graph
+SHEBANG_FILES= strace-graph
MAN1= strace.1
+PLIST_FILES= bin/strace bin/strace-graph
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= AUTHORS COPYRIGHT CREDITS ChangeLog NEWS PORTING \
README README-freebsd README-svr4 TODO
.endif
-post-patch:
- ${REINPLACE_CMD} 's,/usr/bin/perl,${PERL},' ${WRKSRC}/strace-graph
-
do-install:
@${MKDIR} ${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/strace ${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/strace-graph ${PREFIX}/bin
@${MKDIR} ${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/strace.1 ${MANPREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif