aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 16:41:08 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-05-26 16:41:08 +0000
commit75062f23561fdcbafd18e02dfc6caf4af5e65b87 (patch)
treeec1d67819beb7f5596fea7eb05cd21f79a8a1353
parent5a740d797081195f40e2e479cf8d4736b65eb8a2 (diff)
downloadports-75062f23561fdcbafd18e02dfc6caf4af5e65b87.tar.gz
ports-75062f23561fdcbafd18e02dfc6caf4af5e65b87.zip
Notes
-rw-r--r--www/mod_security/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/www/mod_security/Makefile b/www/mod_security/Makefile
index bd0277ef8180..6e482fdfa98a 100644
--- a/www/mod_security/Makefile
+++ b/www/mod_security/Makefile
@@ -2,7 +2,7 @@
PORTNAME= mod_security
PORTVERSION= 2.7.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www security
MASTER_SITES= http://www.modsecurity.org/tarball/${PORTVERSION}/
PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
@@ -19,6 +19,7 @@ LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre \
USE_APACHE= 22+
USE_GNOME= libxml2
GNU_CONFIGURE= yes
+USES= perl5
AP_GENPLIST= yes
AP_INC= ${LOCALBASE}/include/libxml2
@@ -41,7 +42,7 @@ OPTIONS_DEFINE= LUA MLOGC
LUA_CONFIGURE_ON= --with-lua=${LOCALBASE}
LUA_CONFIGURE_OFF+= --without-lua
-LUA_USE= LUA=5.1+
+LUA_USES= lua
MLOGC_DESC= Build ModSecurity Log Collector
MLOGC_CONFIGURE_ON= --with-curl=${LOCALBASE} --disable-errors
@@ -57,6 +58,9 @@ REINPLACE_ARGS= -i ""
AP_EXTRAS+= -DWITH_LIBXML2
CONFIGURE_ARGS+= --with-apxs=${APXS} --with-pcre=${LOCALBASE}
+post-patch:
+ @${REINPLACE_CMD} -e "s/lua5.1/lua-${LUA_VER}/g" ${WRKSRC}/configure
+
pre-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/${APACHEMODDIR}