aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-09-25 10:54:49 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-09-25 10:54:49 +0000
commit7539732e2fc81227019c57812373a3d63490a63e (patch)
tree011f27cace66253061d2b76ea36a201b5983aa99
parent36659e59ee7922c25aba06e215cfb3a2f40cd2ea (diff)
downloadports-7539732e2fc81227019c57812373a3d63490a63e.tar.gz
ports-7539732e2fc81227019c57812373a3d63490a63e.zip
Notes
-rw-r--r--www/http_load/Makefile10
-rw-r--r--www/http_load/distinfo6
-rw-r--r--www/http_load/files/Makefile.bsd4
-rw-r--r--www/http_load/files/patch-aa61
4 files changed, 8 insertions, 73 deletions
diff --git a/www/http_load/Makefile b/www/http_load/Makefile
index 79a568ea81c2..67bb413429dc 100644
--- a/www/http_load/Makefile
+++ b/www/http_load/Makefile
@@ -6,26 +6,22 @@
#
PORTNAME= http_load
-PORTVERSION= 20020104
-PORTREVISION= 2
+PORTVERSION= 20060312
CATEGORIES= www
MASTER_SITES= http://www.acme.com/software/http_load/
-DISTNAME= ${PORTNAME}-04jan2002
+DISTNAME= ${PORTNAME}-12mar2006
MAINTAINER= ports@FreeBSD.org
COMMENT= Multiprocessing http performance test client
-WRKSRC= ${WRKDIR}/http_load-04jan2002
MAKEFILE= ${FILESDIR}/Makefile.bsd
MAN1= http_load.1
-MANCOMPRESSED= maybe
+MANCOMPRESSED= yes
PLIST_FILES= bin/http_load
.ifndef NO_OPENSSL
USE_OPENSSL= yes
-.else
-PKGNAMESUFFIX= -nossl
.endif
.include <bsd.port.mk>
diff --git a/www/http_load/distinfo b/www/http_load/distinfo
index 995260694c12..9c3acfcad356 100644
--- a/www/http_load/distinfo
+++ b/www/http_load/distinfo
@@ -1,3 +1,3 @@
-MD5 (http_load-04jan2002.tar.gz) = 546f78d8ecbe13537cd7e1c65eb21281
-SHA256 (http_load-04jan2002.tar.gz) = 28fb6574cfca3a3c6a8a5f1a299a16aa6f6eacd204d7408232d2a289a29899a1
-SIZE (http_load-04jan2002.tar.gz) = 16710
+MD5 (http_load-12mar2006.tar.gz) = d1a6c2261f8828a3f319e86ff0517219
+SHA256 (http_load-12mar2006.tar.gz) = 88c862eb3de76d9f5b3af45c96dd7b903fafa7e52e975246707889a8f9ec46f0
+SIZE (http_load-12mar2006.tar.gz) = 17033
diff --git a/www/http_load/files/Makefile.bsd b/www/http_load/files/Makefile.bsd
index a26caac69497..625e0af62586 100644
--- a/www/http_load/files/Makefile.bsd
+++ b/www/http_load/files/Makefile.bsd
@@ -6,7 +6,7 @@ CFLAGS += -DUSE_SSL -I${OPENSSLBASE}/include ${OPENSSL_CFLAGS}
LDADD += -L${OPENSSLBASE}/lib -lssl -lcrypto
.endif
-BINDIR = ${LOCALBASE}/bin
-MANDIR = ${LOCALBASE}/man/man
+BINDIR = ${PREFIX}/bin
+MANDIR = ${PREFIX}/man/man
.include <bsd.prog.mk>
diff --git a/www/http_load/files/patch-aa b/www/http_load/files/patch-aa
deleted file mode 100644
index 5342a50b59ab..000000000000
--- a/www/http_load/files/patch-aa
+++ /dev/null
@@ -1,61 +0,0 @@
---- http_load.c.bak Fri Jul 15 23:49:26 2005
-+++ http_load.c Fri Jul 15 23:49:33 2005
-@@ -655,11 +655,11 @@
- (void) memset( &hints, 0, sizeof(hints) );
- hints.ai_family = PF_UNSPEC;
- hints.ai_socktype = SOCK_STREAM;
-- (void) snprintf( portstr, sizeof(portstr), "%d", (int) urls[url_num].port );
-- if ( (gaierr = getaddrinfo( urls[url_num].hostname, portstr, &hints, &ai )) != 0 )
-+ (void) snprintf( portstr, sizeof(portstr), "%d", (int) port );
-+ if ( (gaierr = getaddrinfo( hostname, portstr, &hints, &ai )) != 0 )
- {
- (void) fprintf(
-- stderr, "%s: getaddrinfo %s - %s\n", argv0, urls[url_num].hostname,
-+ stderr, "%s: getaddrinfo %s - %s\n", argv0, hostname,
- gai_strerror( gaierr ) );
- exit( 1 );
- }
-@@ -724,15 +724,15 @@
-
- (void) fprintf(
- stderr, "%s: no valid address found for host %s\n", argv0,
-- urls[url_num].hostname );
-+ hostname );
- exit( 1 );
-
- #else /* USE_IPV6 */
-
-- he = gethostbyname( urls[url_num].hostname );
-+ he = gethostbyname( hostname );
- if ( he == (struct hostent*) 0 )
- {
-- (void) fprintf( stderr, "%s: unknown host - %s\n", argv0, urls[url_num].hostname );
-+ (void) fprintf( stderr, "%s: unknown host - %s\n", argv0, hostname );
- exit( 1 );
- }
- urls[url_num].sock_family = urls[url_num].sa.sin_family = he->h_addrtype;
-@@ -825,6 +825,7 @@
- ClientData client_data;
- int flags;
- int sip_num;
-+ int rcv_bytes, error;
-
- /* Start filling in the connection slot. */
- connections[cnum].url_num = url_num;
-@@ -863,6 +864,16 @@
- perror( urls[url_num].url_str );
- (void) close( connections[cnum].conn_fd );
- return;
-+ }
-+
-+ /* Shrink the recieve window to better imitate a slow connection. */
-+ if ( do_throttle )
-+ {
-+ rcv_bytes = 2048;
-+ error = setsockopt(connections[cnum].conn_fd, SOL_SOCKET, SO_RCVBUF,
-+ (void *)&rcv_bytes, sizeof(rcv_bytes));
-+ if (error)
-+ perror("Setsockopt problem:");
- }
-
- if ( num_sips > 0 )