aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2006-07-13 18:18:16 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2006-07-13 18:18:16 +0000
commit75badcdeae6c1f99c70fb2513ab24bfec90236e6 (patch)
treef94e469df3adc7c500fc0a98c7463b1f748233e0
parent51b0c0b072feee4de45fcfc2566ffaaacd6d9cba (diff)
downloadports-75badcdeae6c1f99c70fb2513ab24bfec90236e6.tar.gz
ports-75badcdeae6c1f99c70fb2513ab24bfec90236e6.zip
Notes
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-rpm-build-perl/Makefile23
-rw-r--r--devel/p5-rpm-build-perl/distinfo3
-rw-r--r--devel/p5-rpm-build-perl/pkg-descr5
-rw-r--r--devel/p5-rpm-build-perl/pkg-plist11
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 463a6cc6456f..f388862cc695 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1394,6 +1394,7 @@
SUBDIR += p5-mixin
SUBDIR += p5-orz
SUBDIR += p5-prefork
+ SUBDIR += p5-rpm-build-perl
SUBDIR += p5-version
SUBDIR += p65
SUBDIR += pas2dox
diff --git a/devel/p5-rpm-build-perl/Makefile b/devel/p5-rpm-build-perl/Makefile
new file mode 100644
index 000000000000..c90c44fa7bd5
--- /dev/null
+++ b/devel/p5-rpm-build-perl/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: p5-rpm-build-perl
+# Date created: 2006-07-12
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rpm-build-perl
+PORTVERSION= 0.5.2
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/A/AT/ATOURBIN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= This module is required to build Perl RPM packages
+
+PERL_CONFIGURE= yes
+
+MAN1= perl.prov.1 perl.req.1
+MAN3= B::PerlReq.3 PerlReq::Utils.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-rpm-build-perl/distinfo b/devel/p5-rpm-build-perl/distinfo
new file mode 100644
index 000000000000..337f7e2d8b4f
--- /dev/null
+++ b/devel/p5-rpm-build-perl/distinfo
@@ -0,0 +1,3 @@
+MD5 (rpm-build-perl-0.5.2.tar.gz) = 1a6796aece2f76c4f188d6ea56d3202f
+SHA256 (rpm-build-perl-0.5.2.tar.gz) = d360cd862f5984a0c47ef60d9b899ea7abe26331e51dbfc61f129d859875e71c
+SIZE (rpm-build-perl-0.5.2.tar.gz) = 18295
diff --git a/devel/p5-rpm-build-perl/pkg-descr b/devel/p5-rpm-build-perl/pkg-descr
new file mode 100644
index 000000000000..a98652ce7e80
--- /dev/null
+++ b/devel/p5-rpm-build-perl/pkg-descr
@@ -0,0 +1,5 @@
+rpm-build-perl is required to build Perl RPM packages;
+it contains scripts for automatic dependency tracking,
+RPM macros for Perl.
+
+WWW: http://search.cpan.org/dist/rpm-build-perl/
diff --git a/devel/p5-rpm-build-perl/pkg-plist b/devel/p5-rpm-build-perl/pkg-plist
new file mode 100644
index 000000000000..bd6b7f26b463
--- /dev/null
+++ b/devel/p5-rpm-build-perl/pkg-plist
@@ -0,0 +1,11 @@
+bin/perl.prov
+bin/perl.req
+%%SITE_PERL%%/fake.pm
+%%SITE_PERL%%/B/PerlReq.pm
+%%SITE_PERL%%/PerlReq/Utils.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/rpm-build-perl/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/B
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/PerlReq
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/rpm-build-perl
+@dirrm %%SITE_PERL%%/B
+@dirrm %%SITE_PERL%%/PerlReq