aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-13 19:12:13 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2002-11-13 19:12:13 +0000
commit7618128fa0eb1fd3c6174acca24f2fe2e0951106 (patch)
tree1c9cd2a64bd109adf00c4899a5b7ed7b02712c21
parentac43e8a05bfc4278c5f66b714314561edaaa9f9d (diff)
downloadports-7618128fa0eb1fd3c6174acca24f2fe2e0951106.tar.gz
ports-7618128fa0eb1fd3c6174acca24f2fe2e0951106.zip
Notes
-rw-r--r--cad/Makefile1
-rw-r--r--cad/cascade/Makefile34
-rw-r--r--cad/cascade/distinfo1
-rw-r--r--cad/cascade/pkg-comment1
-rw-r--r--cad/cascade/pkg-descr14
-rw-r--r--cad/cascade/pkg-plist10
6 files changed, 61 insertions, 0 deletions
diff --git a/cad/Makefile b/cad/Makefile
index 936253378a69..83c0f169873f 100644
--- a/cad/Makefile
+++ b/cad/Makefile
@@ -1,6 +1,7 @@
# $FreeBSD$
#
+ SUBDIR += cascade
SUBDIR += chipmunk
SUBDIR += cider
SUBDIR += electric
diff --git a/cad/cascade/Makefile b/cad/cascade/Makefile
new file mode 100644
index 000000000000..7e688f761044
--- /dev/null
+++ b/cad/cascade/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: cascade
+# Date created: 9 November 2002
+# Whom: Marc Fonvieille <blackend@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cascade
+PORTVERSION= 1.4
+CATEGORIES= cad
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S/%SUBDIR%/rfcascade/}
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= blackend@FreeBSD.org
+
+GNU_CONFIGURE= YES
+
+MAN1= cascade.1
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/cascade ${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/cascade.1 ${MANPREFIX}/man/man1
+ @${MKDIR} ${PREFIX}/share/examples/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/examples/* \
+ ${PREFIX}/share/examples/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/cascade-mode.el \
+ ${PREFIX}/share/emacs/site-lisp
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+ @${INSTALL_DATA} ${WRKSRC}/doc/* \
+ ${PREFIX}/share/doc/${PORTNAME}
+.endif
+
+.include <bsd.port.mk>
diff --git a/cad/cascade/distinfo b/cad/cascade/distinfo
new file mode 100644
index 000000000000..10d2f8088b71
--- /dev/null
+++ b/cad/cascade/distinfo
@@ -0,0 +1 @@
+MD5 (cascade-1.4.tar.gz) = e6be4843125536af6e2992c675c838ba
diff --git a/cad/cascade/pkg-comment b/cad/cascade/pkg-comment
new file mode 100644
index 000000000000..aed730d8f1d7
--- /dev/null
+++ b/cad/cascade/pkg-comment
@@ -0,0 +1 @@
+A simple tool to analyze noise and distortion of a RF system
diff --git a/cad/cascade/pkg-descr b/cad/cascade/pkg-descr
new file mode 100644
index 000000000000..8191dbbcf579
--- /dev/null
+++ b/cad/cascade/pkg-descr
@@ -0,0 +1,14 @@
+Cascade is a program for analyzing the noise and distortion performance
+of a cascade of elements in an electronic system. A typical application
+of cascade is the analysis of a receiver. A text description of the
+receiver block diagram consisting of things like amplifiers, mixers,
+and filters is entered into cascade. Each element is characterized
+by its gain and optionally noise figure, and third order intercept
+point. The program then analyzes the system and produces a report
+detailing the performance at each stage.
+
+A summary is produced which shows the relative contributions to the
+total system performance of each block. This allows easy identification
+of what limits system performance.
+
+WWW: http://rfcascade.sourceforge.net/
diff --git a/cad/cascade/pkg-plist b/cad/cascade/pkg-plist
new file mode 100644
index 000000000000..11a29259c2aa
--- /dev/null
+++ b/cad/cascade/pkg-plist
@@ -0,0 +1,10 @@
+bin/cascade
+%%PORTDOCS%%share/doc/cascade/ex1.gif
+%%PORTDOCS%%share/doc/cascade/index.html
+share/emacs/site-lisp/cascade-mode.el
+share/examples/cascade/README.examples
+share/examples/cascade/ex1.cas
+share/examples/cascade/ex1.gif
+share/examples/cascade/ex1.out
+@dirrm share/examples/cascade
+%%PORTDOCS%%@dirrm share/doc/cascade