aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2017-01-07 19:23:00 +0000
committerThierry Thomas <thierry@FreeBSD.org>2017-01-07 19:23:00 +0000
commit762deaa84770083e4961228f69acee8cc8b54293 (patch)
tree3d3f8ef963c028cfdea61b598a85fa80f43546ee
parent23ee74cd9d303544db775afac58c4b980fd7506f (diff)
Notes
-rw-r--r--MOVED1
-rw-r--r--math/Makefile2
-rw-r--r--math/libproj4/Makefile43
-rw-r--r--math/libproj4/distinfo4
-rw-r--r--math/libproj4/files/patch-Makefile59
-rw-r--r--math/libproj4/files/patch-proj_ftmerc.c13
-rw-r--r--math/libproj4/pkg-plist6
-rw-r--r--math/proj.4/Makefile32
-rw-r--r--math/proj.4/distinfo3
-rw-r--r--math/proj.4/files/patch-src_pj__mutex.c11
-rw-r--r--math/proj.4/pkg-descr (renamed from math/libproj4/pkg-descr)3
-rw-r--r--math/proj.4/pkg-plist31
12 files changed, 81 insertions, 127 deletions
diff --git a/MOVED b/MOVED
index aa60021a180c..c96b9c7c58fe 100644
--- a/MOVED
+++ b/MOVED
@@ -8969,3 +8969,4 @@ databases/rubygem-rubyrep||2017-01-07|Has expired: Depends on deprecated databas
databases/rubygem-activerecord-mysql-adapter||2017-01-07|Has expired: Depends on deprecated databases/rubygem-activerecord
databases/rubygem-dm-active_model||2017-01-07|Has expired: Depends on deprecated databases/rubygem-activemodel
databases/rubygem-activemodel||2017-01-07|Has expired: Upstream support ended
+math/libproj4:math/proj.4|2017-01-07|Project was renamed
diff --git a/math/Makefile b/math/Makefile
index 029d1b01b793..60204d829e3c 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -254,7 +254,6 @@
SUBDIR += libmissing
SUBDIR += libocas
SUBDIR += liborigin
- SUBDIR += libproj4
SUBDIR += libqalculate
SUBDIR += libranlip
SUBDIR += librsb
@@ -574,6 +573,7 @@
SUBDIR += plplot-ada
SUBDIR += primegen
SUBDIR += prng
+ SUBDIR += proj.4
SUBDIR += proofgeneral
SUBDIR += pspp
SUBDIR += pure-mpfr
diff --git a/math/libproj4/Makefile b/math/libproj4/Makefile
deleted file mode 100644
index 6746230f0b08..000000000000
--- a/math/libproj4/Makefile
+++ /dev/null
@@ -1,43 +0,0 @@
-# Created by: thierry@pompo.net
-# $FreeBSD$
-
-PORTNAME= libproj4
-DISTVERSION= 3_20081120
-CATEGORIES= math geography
-MASTER_SITES= http://home.comcast.net/~gevenden56/proj/
-DISTFILES= ${PORTNAME}.${DISTVERSION}${EXTRACT_SUFX}
-DIST_SUBDIR= ${PORTNAME}
-
-MAINTAINER= thierry@FreeBSD.org
-COMMENT= C language procedures related to cartographic processes
-
-LIB_DEPENDS= libgsl.so:math/gsl
-
-USES= gmake tar:bzip2
-CFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-ALL_TARGET= libproj4 lproj
-MAKE_JOBS_UNSAFE=yes
-USE_LDCONFIG= yes
-
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MDOCS}
-DISTFILES+= manual.pdf
-EXTRACT_ONLY= ${PORTNAME}.${DISTVERSION}${EXTRACT_SUFX}
-.endif
-
-.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000034
-LIB_DEPENDS+= libmissing.so:math/libmissing
-LDFLAGS+= -lmissing
-.endif
-
-post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${_DISTDIR}/manual.pdf ${STAGEDIR}${DOCSDIR}
-.endif
-
-.include <bsd.port.post.mk>
diff --git a/math/libproj4/distinfo b/math/libproj4/distinfo
deleted file mode 100644
index d32998beba29..000000000000
--- a/math/libproj4/distinfo
+++ /dev/null
@@ -1,4 +0,0 @@
-SHA256 (libproj4/libproj4.3_20081120.tar.bz2) = 5948cbc825ddc481f4dbcb6a33389fa7838a9a499148c9e4cc560644d3e9d2b1
-SIZE (libproj4/libproj4.3_20081120.tar.bz2) = 73360
-SHA256 (libproj4/manual.pdf) = 35ba85a86ed87effd3303c41066ff565dc3c0a53f941e6aa1d7d9c8cfe6cfbd6
-SIZE (libproj4/manual.pdf) = 2292932
diff --git a/math/libproj4/files/patch-Makefile b/math/libproj4/files/patch-Makefile
deleted file mode 100644
index bcc08ade2578..000000000000
--- a/math/libproj4/files/patch-Makefile
+++ /dev/null
@@ -1,59 +0,0 @@
---- Makefile.orig 2008-11-20 18:40:28.000000000 +0100
-+++ Makefile 2014-10-11 18:03:23.000000000 +0200
-@@ -31,7 +31,7 @@
-
- #prefix = /usr/local
- #prefix = /usr
--prefix = $(HOME)
-+prefix = $(PREFIX)
-
- # edit to reflect directory where system defaults and inits are located
- LIB = $(prefix)/lib
-@@ -45,7 +45,7 @@
- THREADS=1
-
- # select local compiler to use
--CC = gcc
-+#CC = gcc
-
- # normally set on runline when debugging or testing file
- T =
-@@ -134,18 +134,20 @@
- thrf = -DPROJ_HAVE_THREADS=1
- endif
-
--CFLAGS = -g -O -I./ $(gslf) $(thrf)
-+CFLAGS+= -fPIC -I./ $(gslf) $(thrf)
- #CFLAGS = -g -I./ $(gslf) $(thrf)
-
--LDFLAGS = -L./ -lproj4 $(gsll) $(thrl) -lm
-+LDFLAGS+= -L./ -lproj4 $(gsll) $(thrl) -lm
-
- lproj: lproj.o $T $L
-- $(CC) -o lproj -I./ lproj.o $T -L./ -lproj4 $(gsll) $(thrl) -lm
-+ $(CC) -o lproj -I./ lproj.o $T -L./ -lproj4 $(LDFLAGS)
-
- lproj.o: lib_proj.h
-
- libproj4: $(RLIB)
- if [ -f /usr/bin/ranlib -o -f /bin/ranlib ] ; then ranlib $L ; fi
-+ $(CC) -shared $(LDFLAGS) -o libproj4.so.0 *.o
-+ ln -sf libproj4.so.0 libproj4.so
-
- $(RLIB): lib_proj.h
-
-@@ -154,9 +156,11 @@
- all: libproj4
-
- install:
-- install -D libproj4.a $(LIB)/libproj4.a
-- install -D lproj $(BIN)/lproj
-- install -D lib_proj.h $(INC)/lib_proj.h
-+ install libproj4.a $(DESTDIR)$(LIB)/libproj4.a
-+ install libproj4.so $(DESTDIR)$(LIB)/libproj4.so
-+ install libproj4.so.0 $(DESTDIR)$(LIB)/libproj4.so.0
-+ install -s lproj $(DESTDIR)$(BIN)/lproj
-+ install lib_proj.h $(DESTDIR)$(INC)/lib_proj.h
-
- clean:
- /bin/rm -f core *.o
diff --git a/math/libproj4/files/patch-proj_ftmerc.c b/math/libproj4/files/patch-proj_ftmerc.c
deleted file mode 100644
index 10ecb31e7930..000000000000
--- a/math/libproj4/files/patch-proj_ftmerc.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- ./proj_ftmerc.c.orig 2008-11-20 18:40:28.000000000 +0100
-+++ ./proj_ftmerc.c 2014-10-16 21:31:30.000000000 +0200
-@@ -31,6 +31,10 @@
- #define PROJ_LIB__
- #include <lib_proj.h>
- #include <complex.h>
-+#include <sys/param.h>
-+#if defined(__FreeBSD__) && (__FreeBSD_version < 1000034)
-+# include <missing_complex.h>
-+#endif
- PROJ_HEAD(ftmerc, "French Transverse Mercator") "\n\tCyl, Ell";
-
- /* forward series constants */
diff --git a/math/libproj4/pkg-plist b/math/libproj4/pkg-plist
deleted file mode 100644
index b750f401a3d8..000000000000
--- a/math/libproj4/pkg-plist
+++ /dev/null
@@ -1,6 +0,0 @@
-bin/lproj
-include/lib_proj.h
-lib/libproj4.a
-lib/libproj4.so
-lib/libproj4.so.0
-%%PORTDOCS%%%%DOCSDIR%%/manual.pdf
diff --git a/math/proj.4/Makefile b/math/proj.4/Makefile
new file mode 100644
index 000000000000..645a3ec159d6
--- /dev/null
+++ b/math/proj.4/Makefile
@@ -0,0 +1,32 @@
+# Created by: thierry@pompo.net
+# $FreeBSD$
+
+PORTNAME= proj
+PORTVERSION= 4.9.3
+CATEGORIES= math geography
+MASTER_SITES= http://download.osgeo.org/proj/
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= C language procedures related to cartographic processes
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libgsl.so:math/gsl
+
+USES= cmake compiler
+USE_LDCONFIG= yes
+
+FMAN1= cs2cs.1 geod.1 proj.1
+FMAN3= geodesic.3 pj_init.3
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|gcc|${COMPILER_TYPE}|' \
+ ${WRKSRC}/cmake/Proj4SystemInfo.cmake
+
+post-install:
+.for m in 1 3
+ (cd ${STAGEDIR}${MANPREFIX}/share/man/man${m} && ${GZIP_CMD} ${FMAN${m}})
+.endfor
+
+.include <bsd.port.mk>
diff --git a/math/proj.4/distinfo b/math/proj.4/distinfo
new file mode 100644
index 000000000000..5429a708b05f
--- /dev/null
+++ b/math/proj.4/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483805279
+SHA256 (proj-4.9.3.tar.gz) = 6984542fea333488de5c82eea58d699e4aff4b359200a9971537cd7e047185f7
+SIZE (proj-4.9.3.tar.gz) = 921448
diff --git a/math/proj.4/files/patch-src_pj__mutex.c b/math/proj.4/files/patch-src_pj__mutex.c
new file mode 100644
index 000000000000..55346aef46f7
--- /dev/null
+++ b/math/proj.4/files/patch-src_pj__mutex.c
@@ -0,0 +1,11 @@
+--- src/pj_mutex.c.orig 2016-08-29 18:47:58 UTC
++++ src/pj_mutex.c
+@@ -124,7 +124,7 @@ void pj_acquire_lock()
+ pthread_mutex_lock( &pj_precreated_lock);
+
+ pthread_mutexattr_init(&mutex_attr);
+-#ifdef HAVE_PTHREAD_MUTEX_RECURSIVE
++#if defined(HAVE_PTHREAD_MUTEX_RECURSIVE) || defined(__FreeBSD__)
+ pthread_mutexattr_settype(&mutex_attr, PTHREAD_MUTEX_RECURSIVE);
+ #else
+ pthread_mutexattr_settype(&mutex_attr, PTHREAD_MUTEX_RECURSIVE_NP);
diff --git a/math/libproj4/pkg-descr b/math/proj.4/pkg-descr
index 63282539503f..82cbde817cef 100644
--- a/math/libproj4/pkg-descr
+++ b/math/proj.4/pkg-descr
@@ -3,4 +3,5 @@ to cartographic processes. Procedures for each of the processes will be strictly
categorized and although they may share common subfunctions they will not
intersect in scope.
-WWW: http://home.comcast.net/~gevenden56/proj/
+WWW: http://proj4.org/
+WWW: https://github.com/OSGeo/proj.4
diff --git a/math/proj.4/pkg-plist b/math/proj.4/pkg-plist
new file mode 100644
index 000000000000..27141e377763
--- /dev/null
+++ b/math/proj.4/pkg-plist
@@ -0,0 +1,31 @@
+bin/cs2cs
+bin/geod
+bin/nad2bin
+bin/proj
+include/geodesic.h
+include/proj_api.h
+include/projects.h
+lib/libproj.so
+lib/libproj.so.12
+lib/libproj.so.12.0.0
+share/cmake/PROJ4/proj4-config-version.cmake
+share/cmake/PROJ4/proj4-config.cmake
+share/cmake/PROJ4/proj4-targets-%%CMAKE_BUILD_TYPE%%.cmake
+share/cmake/PROJ4/proj4-targets.cmake
+share/man/man1/cs2cs.1.gz
+share/man/man1/geod.1.gz
+share/man/man1/proj.1.gz
+share/man/man3/geodesic.3.gz
+share/man/man3/pj_init.3.gz
+%%DATADIR%%/CH
+%%DATADIR%%/GL27
+%%DATADIR%%/IGNF
+%%DATADIR%%/epsg
+%%DATADIR%%/esri
+%%DATADIR%%/esri.extra
+%%DATADIR%%/nad.lst
+%%DATADIR%%/nad27
+%%DATADIR%%/nad83
+%%DATADIR%%/other.extra
+%%DATADIR%%/proj_def.dat
+%%DATADIR%%/world