aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-12-31 05:44:52 +0000
committerWill Andrews <will@FreeBSD.org>2000-12-31 05:44:52 +0000
commit7756dfe8f4cc574fba49af0d6bb7ee008a2148d2 (patch)
tree58283f33d0f54e23048d2529082b87dfea48a13b
parent36f8276f2aa5c0c308adb8d0c62feefd6ac28f9f (diff)
downloadports-7756dfe8f4cc574fba49af0d6bb7ee008a2148d2.tar.gz
ports-7756dfe8f4cc574fba49af0d6bb7ee008a2148d2.zip
Notes
-rw-r--r--databases/Makefile1
-rw-r--r--databases/p5-Text-Query-SQL/Makefile32
-rw-r--r--databases/p5-Text-Query-SQL/distinfo1
-rw-r--r--databases/p5-Text-Query-SQL/pkg-comment1
-rw-r--r--databases/p5-Text-Query-SQL/pkg-descr10
-rw-r--r--databases/p5-Text-Query-SQL/pkg-plist13
6 files changed, 58 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 5d10de646589..e64b8f27bbe4 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -46,6 +46,7 @@
SUBDIR += p5-Mysql
SUBDIR += p5-Pg
SUBDIR += p5-SQL-Statement
+ SUBDIR += p5-Text-Query-SQL
SUBDIR += p5-hp200lx-db
SUBDIR += pgaccess
SUBDIR += postgresql7
diff --git a/databases/p5-Text-Query-SQL/Makefile b/databases/p5-Text-Query-SQL/Makefile
new file mode 100644
index 000000000000..1f062df3a9a4
--- /dev/null
+++ b/databases/p5-Text-Query-SQL/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: databases/p5-Text-Query-SQL
+# Date created: 31 December 2000
+# Whom: Anton Berezin <tobez@tobez.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Query-SQL
+PORTVERSION= 0.09
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@tobez.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/Text/Query.pm:${PORTSDIR}/textproc/p5-Text-Query
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MAN3= Text::Query::BuildSQLMifluz.3 Text::Query::BuildSQLMySQL.3 \
+ Text::Query::BuildSQLFulcrum.3 Text::Query::BuildSQL.3 \
+ Text::Query::BuildSQLPg.3 Text::Query::SolveSQL.3 \
+ Bundle::Text::Query::BuildSQL.3
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+
+pre-patch:
+ @${PERL} -pi -e '/DBI/ and $$_=""' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/databases/p5-Text-Query-SQL/distinfo b/databases/p5-Text-Query-SQL/distinfo
new file mode 100644
index 000000000000..62ef3e3fc5ed
--- /dev/null
+++ b/databases/p5-Text-Query-SQL/distinfo
@@ -0,0 +1 @@
+MD5 (Text-Query-SQL-0.09.tar.gz) = 37b1302cdf66eeba203c8170d331edea
diff --git a/databases/p5-Text-Query-SQL/pkg-comment b/databases/p5-Text-Query-SQL/pkg-comment
new file mode 100644
index 000000000000..fbe5b66f92bc
--- /dev/null
+++ b/databases/p5-Text-Query-SQL/pkg-comment
@@ -0,0 +1 @@
+Text-Query-SQL provides query builders for SQL databases
diff --git a/databases/p5-Text-Query-SQL/pkg-descr b/databases/p5-Text-Query-SQL/pkg-descr
new file mode 100644
index 000000000000..4429dec2e06a
--- /dev/null
+++ b/databases/p5-Text-Query-SQL/pkg-descr
@@ -0,0 +1,10 @@
+Text-Query-SQL provides query builders for SQL databases. Searching 'foo
+and bar' will retrieve rows containing the words foo and bar. It does it
+by generating the appropriate SQL request.
+
+Text-Query-SQL is derived from the Text-Query module.
+
+WWW: http://www.senga.org/Text-Query-SQL/
+
+-Anton
+<tobez@tobez.org>
diff --git a/databases/p5-Text-Query-SQL/pkg-plist b/databases/p5-Text-Query-SQL/pkg-plist
new file mode 100644
index 000000000000..52336fa11d42
--- /dev/null
+++ b/databases/p5-Text-Query-SQL/pkg-plist
@@ -0,0 +1,13 @@
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Query/SQL/.packlist
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/BuildSQLMifluz.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/BuildSQLMySQL.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/BuildSQLFulcrum.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/BuildSQL.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/BuildSQLPg.pm
+lib/perl5/site_perl/%%PERL_VER%%/Text/Query/SolveSQL.pm
+lib/perl5/site_perl/%%PERL_VER%%/Bundle/Text/Query/BuildSQL.pm
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Text/Query/SQL
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Bundle/Text/Query 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Bundle/Text 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Bundle 2>/dev/null || true
+@unexec rmdir %D/lib/perl5/site_perl/%%PERL_VER%%/Text/Query 2>/dev/null || true