aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Dupre <ale@FreeBSD.org>2012-05-20 06:42:55 +0000
committerAlex Dupre <ale@FreeBSD.org>2012-05-20 06:42:55 +0000
commit77cb321f555961d887151f7a0e56b4289007a832 (patch)
tree8cf380a192f1f3bb956bfa03e547165460421400
parent12ce6c87dd0ede9d22d073e48b5a0e107474401e (diff)
downloadports-77cb321f555961d887151f7a0e56b4289007a832.tar.gz
ports-77cb321f555961d887151f7a0e56b4289007a832.zip
Notes
-rw-r--r--archivers/pecl-bz2/Makefile2
-rw-r--r--archivers/pecl-lzf/Makefile2
-rw-r--r--archivers/pecl-phk/Makefile3
-rw-r--r--audio/pecl-id3/Makefile2
-rw-r--r--databases/pecl-chdb/Makefile2
-rw-r--r--databases/pecl-drizzle/Makefile3
-rw-r--r--databases/pecl-mdbtools/Makefile3
-rw-r--r--databases/pecl-tokyo_tyrant/Makefile4
-rw-r--r--databases/php-adodb-ext/Makefile3
-rw-r--r--databases/php-sqlite3/Makefile2
-rw-r--r--databases/php5-rrdtool/Makefile3
-rw-r--r--devel/pecl-automap/Makefile3
-rw-r--r--devel/pecl-bbcode/Makefile3
-rw-r--r--devel/pecl-bcompiler/Makefile2
-rw-r--r--devel/pecl-dio/Makefile3
-rw-r--r--devel/pecl-inclued/Makefile3
-rw-r--r--devel/pecl-mcve/Makefile3
-rw-r--r--devel/pecl-shape/Makefile2
-rw-r--r--devel/pecl-spl_types/Makefile3
-rw-r--r--devel/pecl-statgrab/Makefile11
-rw-r--r--devel/pecl-uuid/Makefile5
-rw-r--r--devel/php-java-bridge/Makefile2
-rw-r--r--devel/php5-blitz-devel/Makefile3
-rw-r--r--devel/php5-blitz/Makefile3
-rw-r--r--devel/php5-ice/Makefile4
-rw-r--r--devel/php5-msgpack/Makefile2
-rw-r--r--devel/php5-pinba/Makefile4
-rw-r--r--devel/php5-thrift/Makefile2
-rw-r--r--graphics/pecl-gmagick/Makefile2
-rw-r--r--graphics/pecl-imlib2/Makefile2
-rw-r--r--graphics/php-facedetect/Makefile2
-rw-r--r--graphics/php5-ffmpeg/Makefile4
-rw-r--r--japanese/php5-mecab/Makefile3
-rw-r--r--mail/pecl-pop3/Makefile2
-rw-r--r--math/pecl-bitset/Makefile2
-rw-r--r--math/pecl-stats/Makefile2
-rw-r--r--net-im/pecl-stomp/Makefile2
-rw-r--r--net/pecl-cvsclient/Makefile2
-rw-r--r--print/pecl-ps/Makefile3
-rw-r--r--security/pecl-crack/Makefile2
-rw-r--r--security/pecl-tcpwrap/Makefile2
-rw-r--r--sysutils/pecl-fileinfo/Makefile2
-rw-r--r--sysutils/pecl-proctitle/Makefile2
-rw-r--r--textproc/pecl-enchant/Makefile2
-rw-r--r--textproc/pecl-html_parse/Makefile2
-rw-r--r--textproc/pecl-syck/Makefile2
-rw-r--r--textproc/pecl-xdiff/Makefile2
-rw-r--r--textproc/pecl-xslcache/Makefile5
-rw-r--r--www/pecl-amfext/Makefile2
-rw-r--r--www/php-templates/Makefile2
50 files changed, 102 insertions, 36 deletions
diff --git a/archivers/pecl-bz2/Makefile b/archivers/pecl-bz2/Makefile
index 41046af47d7e..04619aa9d295 100644
--- a/archivers/pecl-bz2/Makefile
+++ b/archivers/pecl-bz2/Makefile
@@ -18,6 +18,8 @@ COMMENT= A Bzip2 management extension
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-bz2
diff --git a/archivers/pecl-lzf/Makefile b/archivers/pecl-lzf/Makefile
index 7f16ad967dc0..702d3f8318a3 100644
--- a/archivers/pecl-lzf/Makefile
+++ b/archivers/pecl-lzf/Makefile
@@ -18,6 +18,8 @@ COMMENT= Handles LZF de/compression
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-lzf
WRKSRC= ${WRKDIR}/${DISTNAME:U}
diff --git a/archivers/pecl-phk/Makefile b/archivers/pecl-phk/Makefile
index 1ae9e4148f81..828eeacbd710 100644
--- a/archivers/pecl-phk/Makefile
+++ b/archivers/pecl-phk/Makefile
@@ -21,7 +21,8 @@ LICENSE= PHP301
USE_PHP= yes
USE_PHP_BUILD= yes
USE_PHPEXT= yes
-IGNORE_WITH_PHP=4
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-phk
diff --git a/audio/pecl-id3/Makefile b/audio/pecl-id3/Makefile
index a1da0433cedf..ddf3b50d5d37 100644
--- a/audio/pecl-id3/Makefile
+++ b/audio/pecl-id3/Makefile
@@ -18,6 +18,8 @@ COMMENT= Extension to read and write ID3 tags in MP3 files
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-id3
diff --git a/databases/pecl-chdb/Makefile b/databases/pecl-chdb/Makefile
index 014505592ff4..8576dff14153 100644
--- a/databases/pecl-chdb/Makefile
+++ b/databases/pecl-chdb/Makefile
@@ -24,6 +24,8 @@ USE_PHP_BUILD= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
PHP_MODNAME= chdb
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CFLAGS+= -L${LOCALBASE}/lib
diff --git a/databases/pecl-drizzle/Makefile b/databases/pecl-drizzle/Makefile
index a9111dc544eb..6b38287f42d1 100644
--- a/databases/pecl-drizzle/Makefile
+++ b/databases/pecl-drizzle/Makefile
@@ -22,7 +22,8 @@ LICENSE= PHP301
USE_PHP= yes
USE_PHPEXT= yes
-IGNORE_WITH_PHP=4
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.if !defined(NOPORTDOCS)
PORTDOCS= README EXPERIMENTAL ChangeLog CREDITS
diff --git a/databases/pecl-mdbtools/Makefile b/databases/pecl-mdbtools/Makefile
index 259e0ffbad23..15dbe4ac5a57 100644
--- a/databases/pecl-mdbtools/Makefile
+++ b/databases/pecl-mdbtools/Makefile
@@ -22,9 +22,10 @@ LICENSE= LGPL21
USE_PHP= yes
USE_PHPEXT= yes
USE_PHP_BUILD= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
BUILD_DEPENDS= ${LOCALBASE}/lib/libmdb.a:${PORTSDIR}/databases/mdbtools
RUN_DEPENDS= ${LOCALBASE}/lib/libmdb.a:${PORTSDIR}/databases/mdbtools
-IGNORE_WITH_PHP=4
CONFIGURE_ARGS= --with-mdbtools=${LOCALBASE}
diff --git a/databases/pecl-tokyo_tyrant/Makefile b/databases/pecl-tokyo_tyrant/Makefile
index be08e0cb1c84..ecdbec4c076f 100644
--- a/databases/pecl-tokyo_tyrant/Makefile
+++ b/databases/pecl-tokyo_tyrant/Makefile
@@ -17,11 +17,11 @@ COMMENT= Wrapper to the Tokyo Tyrant client library
LIB_DEPENDS= tokyotyrant.3:${PORTSDIR}/databases/tokyotyrant
-IGNORE_WITH_PHP=4
-
USE_PHP= session
USE_PHP_BUILD= spl
USE_PHPIZE= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/databases/php-adodb-ext/Makefile b/databases/php-adodb-ext/Makefile
index 4741b0f70b78..bb54e1f9b27c 100644
--- a/databases/php-adodb-ext/Makefile
+++ b/databases/php-adodb-ext/Makefile
@@ -20,9 +20,10 @@ WRKSRC= ${WRKDIR}/adodb-${PORTVERSION:S/.//}
USE_PHP= yes
USE_PHPIZE= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
USE_ZIP= yes
-DEFAULT_PHP_VER= 5
CONFIGURE_ARGS= --with-php-config=${PREFIX}/bin/php-config \
--prefix=${PREFIX}/lib/php/${PHP_EXT_DIR}
SUB_FILES= pkg-message
diff --git a/databases/php-sqlite3/Makefile b/databases/php-sqlite3/Makefile
index fc4cf56e3758..ba836adfac0e 100644
--- a/databases/php-sqlite3/Makefile
+++ b/databases/php-sqlite3/Makefile
@@ -22,5 +22,7 @@ USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
USE_PHP_BUILD= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/databases/php5-rrdtool/Makefile b/databases/php5-rrdtool/Makefile
index 83271459bc7d..ffef72a1c9dc 100644
--- a/databases/php5-rrdtool/Makefile
+++ b/databases/php5-rrdtool/Makefile
@@ -23,7 +23,8 @@ LIB_DEPENDS= rrd:${PORTSDIR}/databases/rrdtool
WRKSRC= ${WRKDIR}/rrdtool
USE_PHP= yes
-DEFAULT_PHP_VER=5
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/devel/pecl-automap/Makefile b/devel/pecl-automap/Makefile
index 22b4b1c14e0e..7bf078a5cf80 100644
--- a/devel/pecl-automap/Makefile
+++ b/devel/pecl-automap/Makefile
@@ -22,7 +22,8 @@ USE_PHP= spl
USE_PHP_BUILD= yes
USE_PHPEXT= yes
PHP_MODNAME= automap
-IGNORE_WITH_PHP=4
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-automap
diff --git a/devel/pecl-bbcode/Makefile b/devel/pecl-bbcode/Makefile
index ba28e0d20ecb..90d98de1b577 100644
--- a/devel/pecl-bbcode/Makefile
+++ b/devel/pecl-bbcode/Makefile
@@ -22,7 +22,8 @@ LICENSE_COMB= multi
USE_PHP= yes
USE_PHP_BUILD= yes
USE_PHPEXT= yes
-IGNORE_WITH_PHP=4
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-bbcode
diff --git a/devel/pecl-bcompiler/Makefile b/devel/pecl-bcompiler/Makefile
index ba4a592f72e6..7238070580c4 100644
--- a/devel/pecl-bcompiler/Makefile
+++ b/devel/pecl-bcompiler/Makefile
@@ -18,6 +18,8 @@ COMMENT= A bytecode compiler extension
USE_PHP= bz2
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-bcompiler
diff --git a/devel/pecl-dio/Makefile b/devel/pecl-dio/Makefile
index 79ec7401aa20..d28c2bba0de0 100644
--- a/devel/pecl-dio/Makefile
+++ b/devel/pecl-dio/Makefile
@@ -20,6 +20,7 @@ LICENSE= PHP30
USE_PHP= yes
USE_PHPEXT= yes
-IGNORE_WITH_PHP=4
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/devel/pecl-inclued/Makefile b/devel/pecl-inclued/Makefile
index c1c28d61841a..ca0439015a6f 100644
--- a/devel/pecl-inclued/Makefile
+++ b/devel/pecl-inclued/Makefile
@@ -19,7 +19,8 @@ LICENSE= PHP301
USE_PHP= yes
USE_PHPEXT= yes
-IGNORE_WITH_PHP=4
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-inclued
diff --git a/devel/pecl-mcve/Makefile b/devel/pecl-mcve/Makefile
index 6bcbff702208..55ec801664e4 100644
--- a/devel/pecl-mcve/Makefile
+++ b/devel/pecl-mcve/Makefile
@@ -22,8 +22,9 @@ LICENSE= PHP30
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS+=--with-mcve="${LOCALBASE}"
-IGNORE_WITH_PHP=4
post-patch:
${REINPLACE_CMD} -e '/SEARCH_PATH/ s,=",="${LOCALBASE} ${PREFIX} ,' \
diff --git a/devel/pecl-shape/Makefile b/devel/pecl-shape/Makefile
index ef0d26d3b949..ccf1f802a569 100644
--- a/devel/pecl-shape/Makefile
+++ b/devel/pecl-shape/Makefile
@@ -23,6 +23,8 @@ USE_PHP= yes
USE_PHP_BUILD= yes
USE_PHPEXT= yes
PHP_MODNAME= shp
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS+=--with-shp=${LOCALBASE}
diff --git a/devel/pecl-spl_types/Makefile b/devel/pecl-spl_types/Makefile
index c703c47b4aa4..f42d70ffd6f3 100644
--- a/devel/pecl-spl_types/Makefile
+++ b/devel/pecl-spl_types/Makefile
@@ -24,7 +24,8 @@ USE_PHP= spl
USE_PHP_BUILD= yes
USE_PHPEXT= yes
PHP_MODNAME= spl_types
-IGNORE_WITH_PHP=4
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-spl-types
CFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/pecl-statgrab/Makefile b/devel/pecl-statgrab/Makefile
index 5afda4a250df..d0095c5c12ed 100644
--- a/devel/pecl-statgrab/Makefile
+++ b/devel/pecl-statgrab/Makefile
@@ -21,17 +21,12 @@ LIB_DEPENDS= statgrab.8:${PORTSDIR}/devel/libstatgrab
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -ldevstat ${EXTRA_LIBS}
CONFIGURE_ARGS= --with-statgrab=${LOCALBASE}
-.include <bsd.port.pre.mk>
-
-.if ${PHP_VER} < 5
-post-patch:
- @${PATCH} -d ${WRKSRC} -p0 < ${FILESDIR}/php_statgrab.h.patch
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/pecl-uuid/Makefile b/devel/pecl-uuid/Makefile
index 7e2a0bc9da29..2c8a72a3689b 100644
--- a/devel/pecl-uuid/Makefile
+++ b/devel/pecl-uuid/Makefile
@@ -22,6 +22,7 @@ CONFIGURE_ARGS= --with-uuid=${LOCALBASE} CFLAGS=-I${LOCALBASE}/include LDFLAGS=-
PHP_MODNAME= ${PORTNAME}
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
-.include <bsd.port.pre.mk>
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/php-java-bridge/Makefile b/devel/php-java-bridge/Makefile
index 16c84fb0319f..24d811193e85 100644
--- a/devel/php-java-bridge/Makefile
+++ b/devel/php-java-bridge/Makefile
@@ -25,6 +25,8 @@ USE_PHP= session
USE_PHPIZE= yes
USE_PHPEXT= yes
PHP_MODNAME= java
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/devel/php5-blitz-devel/Makefile b/devel/php5-blitz-devel/Makefile
index 5f9506036b24..40b4a48ee3f6 100644
--- a/devel/php5-blitz-devel/Makefile
+++ b/devel/php5-blitz-devel/Makefile
@@ -20,6 +20,7 @@ USE_PHP= yes
USE_PHP_BUILD= yes
USE_PHPEXT= yes
PHP_MODNAME= blitz
-IGNORE_WITH_PHP=4
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/devel/php5-blitz/Makefile b/devel/php5-blitz/Makefile
index 99994d8845a0..3ec550f84be7 100644
--- a/devel/php5-blitz/Makefile
+++ b/devel/php5-blitz/Makefile
@@ -16,6 +16,7 @@ COMMENT= PHP templating engine
USE_PHP= yes
USE_PHP_BUILD= yes
USE_PHPEXT= yes
-IGNORE_WITH_PHP=4
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/devel/php5-ice/Makefile b/devel/php5-ice/Makefile
index 0413bcd2a039..856f3415bf5c 100644
--- a/devel/php5-ice/Makefile
+++ b/devel/php5-ice/Makefile
@@ -19,10 +19,10 @@ LIB_DEPENDS= Ice.${LIB_VRS}:${PORTSDIR}/devel/ice
USE_GMAKE= yes
MAKE_ARGS+= PHP_EXT_DIR=${PHP_EXT_DIR}
-DEFAULT_PHP_VER=5
-IGNORE_WITH_PHP=4
USE_PHP= yes
USE_PHP_BUILD= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
BUILD_WRKSRC= ${WRKSRC}/php
INSTALL_WRKSRC= ${WRKSRC}/php
diff --git a/devel/php5-msgpack/Makefile b/devel/php5-msgpack/Makefile
index adcbabb05f72..352fc532b2d6 100644
--- a/devel/php5-msgpack/Makefile
+++ b/devel/php5-msgpack/Makefile
@@ -21,6 +21,8 @@ USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
PHP_MODNAME= msgpack
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
BUILD_DEPENDS+= ${LOCALBASE}/lib/php/${PHP_EXT_DIR}/session.so:${PORTSDIR}/www/php5-session
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/php5-pinba/Makefile b/devel/php5-pinba/Makefile
index bf7cde129715..826dc8692dc8 100644
--- a/devel/php5-pinba/Makefile
+++ b/devel/php5-pinba/Makefile
@@ -24,8 +24,8 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
USE_PHP= yes
USE_PHPEXT= yes
-DEFAULT_PHP_VER=5
-IGNORE_WITH_PHP=4
PHP_MODNAME= pinba
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/devel/php5-thrift/Makefile b/devel/php5-thrift/Makefile
index 0bdb598e0662..8de3d8ea3a41 100644
--- a/devel/php5-thrift/Makefile
+++ b/devel/php5-thrift/Makefile
@@ -20,6 +20,8 @@ USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
PHP_MODNAME= thrift_protocol
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
WRKSRC= ${WRKDIR}/php/src/ext/thrift_protocol
diff --git a/graphics/pecl-gmagick/Makefile b/graphics/pecl-gmagick/Makefile
index d254a44d5217..55809490c07a 100644
--- a/graphics/pecl-gmagick/Makefile
+++ b/graphics/pecl-gmagick/Makefile
@@ -20,6 +20,8 @@ LIB_DEPENDS= GraphicsMagick.1:${PORTSDIR}/graphics/GraphicsMagick
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --with-gmagick=${LOCALBASE}
diff --git a/graphics/pecl-imlib2/Makefile b/graphics/pecl-imlib2/Makefile
index 46983ca4cce9..1c65b9c48bf4 100644
--- a/graphics/pecl-imlib2/Makefile
+++ b/graphics/pecl-imlib2/Makefile
@@ -19,6 +19,8 @@ COMMENT= A PECL extension if imlib2
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
USE_EFL= imlib2
# libImlib2 may or may not depend on X, however,
diff --git a/graphics/php-facedetect/Makefile b/graphics/php-facedetect/Makefile
index cad383d5a06c..2957b27799c2 100644
--- a/graphics/php-facedetect/Makefile
+++ b/graphics/php-facedetect/Makefile
@@ -28,6 +28,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS+= --with-facedetect
diff --git a/graphics/php5-ffmpeg/Makefile b/graphics/php5-ffmpeg/Makefile
index 14792c54b7d9..87aba70298da 100644
--- a/graphics/php5-ffmpeg/Makefile
+++ b/graphics/php5-ffmpeg/Makefile
@@ -21,12 +21,12 @@ LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
avutil.1:${PORTSDIR}/multimedia/ffmpeg
CFLAGS+= -I${LOCALBASE}/include
-DEFAULT_PHP_VER=5
-IGNORE_WITH_PHP=4
USE_BZIP2= yes
USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS+= --with-ffmpeg=${LOCALBASE}/include
diff --git a/japanese/php5-mecab/Makefile b/japanese/php5-mecab/Makefile
index a3bea4893140..5a6e21885fb9 100644
--- a/japanese/php5-mecab/Makefile
+++ b/japanese/php5-mecab/Makefile
@@ -19,8 +19,9 @@ COMMENT= A PHP5 extension for MeCab Morphological Analyzer
LIB_DEPENDS= mecab:${PORTSDIR}/japanese/mecab
USE_PHP= yes
-DEFAULT_PHP_VER=5
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --with-mecab=${LOCALBASE}/bin/mecab-config
CONFIGURE_ENV= LIBS="${LIBS} ${PTHREAD_LIBS}"
CFLAGS+= ${PTHREAD_CFLAGS}
diff --git a/mail/pecl-pop3/Makefile b/mail/pecl-pop3/Makefile
index f9a00f00e619..94b949252f95 100644
--- a/mail/pecl-pop3/Makefile
+++ b/mail/pecl-pop3/Makefile
@@ -21,5 +21,7 @@ USE_PHPIZE= yes
USE_PHP_BUILD= yes
USE_PHPEXT= yes
PHP_MODNAME= pop3
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/math/pecl-bitset/Makefile b/math/pecl-bitset/Makefile
index 0022d58d1f16..52ce275a401f 100644
--- a/math/pecl-bitset/Makefile
+++ b/math/pecl-bitset/Makefile
@@ -18,5 +18,7 @@ COMMENT= A PECL extension for manipulating bitsets
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/math/pecl-stats/Makefile b/math/pecl-stats/Makefile
index cf4fe7f3cf94..05df37054998 100644
--- a/math/pecl-stats/Makefile
+++ b/math/pecl-stats/Makefile
@@ -18,5 +18,7 @@ COMMENT= A PECL extension which with routines for statistical computation
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/net-im/pecl-stomp/Makefile b/net-im/pecl-stomp/Makefile
index 7ec4e2ec84e4..5cbd669515e4 100644
--- a/net-im/pecl-stomp/Makefile
+++ b/net-im/pecl-stomp/Makefile
@@ -18,5 +18,7 @@ COMMENT= PECL extension of stomp client
USE_PHP= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/net/pecl-cvsclient/Makefile b/net/pecl-cvsclient/Makefile
index a7a9056fb329..619e97c36088 100644
--- a/net/pecl-cvsclient/Makefile
+++ b/net/pecl-cvsclient/Makefile
@@ -18,5 +18,7 @@ COMMENT= A PHP extension for CVS pserver client
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/print/pecl-ps/Makefile b/print/pecl-ps/Makefile
index 0624d9d1db7e..504ebd03201f 100644
--- a/print/pecl-ps/Makefile
+++ b/print/pecl-ps/Makefile
@@ -22,8 +22,9 @@ LIB_DEPENDS= ps.4:${PORTSDIR}/print/pslib
USE_PHP= yes
USE_PHPEXT= yes
-DEFAULT_PHP_VER= 5
PHP_MODNAME= ${PORTNAME}
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
post-patch:
@${REINPLACE_CMD} -e 's|-ldl|-lintl|g' ${WRKSRC}/config.m4
diff --git a/security/pecl-crack/Makefile b/security/pecl-crack/Makefile
index 919de9dd920b..5cc89d6d77f1 100644
--- a/security/pecl-crack/Makefile
+++ b/security/pecl-crack/Makefile
@@ -24,6 +24,8 @@ USE_PHPIZE= yes
USE_PHP_BUILD= yes
USE_PHPEXT= yes
PHP_MODNAME= crack
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
WRKSRC= ${WRKDIR}/crack-0.4
diff --git a/security/pecl-tcpwrap/Makefile b/security/pecl-tcpwrap/Makefile
index dbe0e7b9934e..e90d596df6da 100644
--- a/security/pecl-tcpwrap/Makefile
+++ b/security/pecl-tcpwrap/Makefile
@@ -18,6 +18,8 @@ COMMENT= A PECL extension which provides tcpwrappers binding
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
post-patch:
@${REINPLACE_CMD} -e 's, -ldl,,' ${WRKSRC}/config.m4
diff --git a/sysutils/pecl-fileinfo/Makefile b/sysutils/pecl-fileinfo/Makefile
index 17003b4e657e..9a7c46771c4e 100644
--- a/sysutils/pecl-fileinfo/Makefile
+++ b/sysutils/pecl-fileinfo/Makefile
@@ -19,6 +19,8 @@ COMMENT= A PECL extension to retrieve info about files
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --with-fileinfo=/usr
diff --git a/sysutils/pecl-proctitle/Makefile b/sysutils/pecl-proctitle/Makefile
index 538ac2db26fa..e98c543ae2ba 100644
--- a/sysutils/pecl-proctitle/Makefile
+++ b/sysutils/pecl-proctitle/Makefile
@@ -18,5 +18,7 @@ COMMENT= A PECL extension that allows changing the current process' name
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/textproc/pecl-enchant/Makefile b/textproc/pecl-enchant/Makefile
index 79f8c4bf9a12..528d42c198bf 100644
--- a/textproc/pecl-enchant/Makefile
+++ b/textproc/pecl-enchant/Makefile
@@ -23,5 +23,7 @@ CONFIGURE_ARGS+=--with-enchant=${LOCALBASE}
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= ${PORTNAME}
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/textproc/pecl-html_parse/Makefile b/textproc/pecl-html_parse/Makefile
index cdbb12b5a088..c1e842291d7e 100644
--- a/textproc/pecl-html_parse/Makefile
+++ b/textproc/pecl-html_parse/Makefile
@@ -22,6 +22,8 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libekhtml.a:${PORTSDIR}/textproc/ekhtml
USE_PHP= yes
USE_PHP_BUILD= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-html_parse
diff --git a/textproc/pecl-syck/Makefile b/textproc/pecl-syck/Makefile
index 1e9ac4983605..85b7f0daaf67 100644
--- a/textproc/pecl-syck/Makefile
+++ b/textproc/pecl-syck/Makefile
@@ -21,6 +21,8 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libsyck.a:${PORTSDIR}/textproc/syck
USE_PHP= spl hash
USE_PHP_BUILD= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-syck
diff --git a/textproc/pecl-xdiff/Makefile b/textproc/pecl-xdiff/Makefile
index 4418ce6f330a..ab06c9b4cb86 100644
--- a/textproc/pecl-xdiff/Makefile
+++ b/textproc/pecl-xdiff/Makefile
@@ -20,6 +20,8 @@ LIB_DEPENDS= xdiff.0:${PORTSDIR}/textproc/libxdiff
USE_PHP= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/textproc/pecl-xslcache/Makefile b/textproc/pecl-xslcache/Makefile
index 415109d9c05d..2f90df1b295d 100644
--- a/textproc/pecl-xslcache/Makefile
+++ b/textproc/pecl-xslcache/Makefile
@@ -16,11 +16,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= miwi@FreeBSD.org
COMMENT= Caches the parsed XSL stylesheet between sessions
-DEFAULT_PHP_VER=5
-IGNORE_WITH_PHP=4
-
USE_PHP= dom xml xsl
USE_PHP_BUILD= yes
USE_PHPEXT= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
.include <bsd.port.mk>
diff --git a/www/pecl-amfext/Makefile b/www/pecl-amfext/Makefile
index c8726c1fb277..7aa97e33e6c6 100644
--- a/www/pecl-amfext/Makefile
+++ b/www/pecl-amfext/Makefile
@@ -19,6 +19,8 @@ COMMENT= Implements encoding and decoding of AMF and AMF3 messages
USE_PHP= yes
USE_PHPEXT= yes
PHP_MODNAME= amf
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-amf
CPPFLAGS+= -I${LOCALBASE}/include/php/ext/standard
diff --git a/www/php-templates/Makefile b/www/php-templates/Makefile
index 9d8ee84e2dd9..ec3e5ed98261 100644
--- a/www/php-templates/Makefile
+++ b/www/php-templates/Makefile
@@ -24,6 +24,8 @@ USE_DOS2UNIX= yes
USE_PHP= yes
USE_PHPIZE= yes
+DEFAULT_PHP_VER=53
+IGNORE_WITH_PHP=5
CONFIGURE_ARGS= --enable-templates=shared