aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-29 20:43:41 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-29 20:43:41 +0000
commit7887c65e94ca35ebeff0a0bca6079232392ca34f (patch)
tree570559e2511e91a785624e46614032390f2cc0e5
parent7432c27a9207fca792c997dab8875f9d13e9a268 (diff)
downloadports-7887c65e94ca35ebeff0a0bca6079232392ca34f.tar.gz
ports-7887c65e94ca35ebeff0a0bca6079232392ca34f.zip
Notes
-rw-r--r--databases/Makefile1
-rw-r--r--databases/pear-MDB2_Driver_ibase/Makefile29
-rw-r--r--databases/pear-MDB2_Driver_ibase/distinfo3
-rw-r--r--databases/pear-MDB2_Driver_ibase/pkg-descr3
4 files changed, 36 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index 4020a8fb4fd8..7037d4416d12 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -320,6 +320,7 @@
SUBDIR += pear-DBA
SUBDIR += pear-MDB
SUBDIR += pear-MDB2
+ SUBDIR += pear-MDB2_Driver_ibase
SUBDIR += pear-MDB2_Driver_mysql
SUBDIR += pear-MDB2_Driver_mysqli
SUBDIR += pear-MDB2_Driver_pgsql
diff --git a/databases/pear-MDB2_Driver_ibase/Makefile b/databases/pear-MDB2_Driver_ibase/Makefile
new file mode 100644
index 000000000000..b3ec40270db2
--- /dev/null
+++ b/databases/pear-MDB2_Driver_ibase/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: pear-MDB2_Driver_ibase
+# Date created: 29 April 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= MDB2_Driver_ibase
+PORTVERSION= 1.4.0
+CATEGORIES= databases www pear
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= PEAR ibase MDB2 driver
+
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+FILES= MDB2/Driver/ibase.php \
+ MDB2/Driver/Datatype/ibase.php \
+ MDB2/Driver/Function/ibase.php \
+ MDB2/Driver/Manager/ibase.php \
+ MDB2/Driver/Native/ibase.php \
+ MDB2/Driver/Reverse/ibase.php
+
+TESTS= MDB2_nonstandard_ibase.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/databases/pear-MDB2_Driver_ibase/distinfo b/databases/pear-MDB2_Driver_ibase/distinfo
new file mode 100644
index 000000000000..f71e3f2927be
--- /dev/null
+++ b/databases/pear-MDB2_Driver_ibase/distinfo
@@ -0,0 +1,3 @@
+MD5 (PEAR/MDB2_Driver_ibase-1.4.0.tgz) = 783e041778ffec16c70a764fa746a401
+SHA256 (PEAR/MDB2_Driver_ibase-1.4.0.tgz) = 43396a7334390ba557f31bb4fde43189a81430f177b3a3880f82651308dc2fcc
+SIZE (PEAR/MDB2_Driver_ibase-1.4.0.tgz) = 35710
diff --git a/databases/pear-MDB2_Driver_ibase/pkg-descr b/databases/pear-MDB2_Driver_ibase/pkg-descr
new file mode 100644
index 000000000000..c1355540be7c
--- /dev/null
+++ b/databases/pear-MDB2_Driver_ibase/pkg-descr
@@ -0,0 +1,3 @@
+This is the Interbase/Firebird MDB2 driver.
+
+WWW: http://pear.php.net/package/MDB2_Driver_ibase/