aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-05-01 19:33:03 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-05-01 19:33:03 +0000
commit79b34561621e8bf07c6dd65fe4f35a26414e9644 (patch)
tree50da4d811f667c96bb4ed679eeb148c4d043961e
parentd025dab1382726395c063ef26db2a3a4fa21a6b3 (diff)
Notes
-rw-r--r--www/Makefile1
-rw-r--r--www/cherokee-devel/Makefile28
-rw-r--r--www/cherokee-devel/distinfo6
-rw-r--r--www/cherokee-devel/files/patch-cherokee-socket.c23
-rw-r--r--www/cherokee-devel/pkg-plist104
5 files changed, 50 insertions, 112 deletions
diff --git a/www/Makefile b/www/Makefile
index 628c0b9389c0..70bdd8d3dd61 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -75,6 +75,7 @@
SUBDIR += checkbot
SUBDIR += cheetah
SUBDIR += cherokee
+ SUBDIR += cherokee-devel
SUBDIR += chimera
SUBDIR += chpasswd
SUBDIR += chtml
diff --git a/www/cherokee-devel/Makefile b/www/cherokee-devel/Makefile
index c996aa6119c0..15482784ca7c 100644
--- a/www/cherokee-devel/Makefile
+++ b/www/cherokee-devel/Makefile
@@ -6,23 +6,25 @@
#
PORTNAME= cherokee
-PORTVERSION= 0.5.6
-PORTREVISION= 4
+DISTVERSION= 0.6.0b700
CATEGORIES= www
MASTER_SITES= http://www.cherokee-project.com/download/${PORTVERSION:R}/${PORTVERSION}/ \
CENKES http://www.alaskaparadise.com/freebsd/
+PKGNAMESUFFIX= -devel
MAINTAINER= beech@alaskaparadise.com
COMMENT= Extremely fast and flexible web server
LIB_DEPENDS= pcre.0:${PORTSDIR}/devel/pcre
-CONFLICTS= cherokee-devel-[0-9]*
+CONFLICTS= cherokee-[0-9]*
USE_GNOME= gnomehack gnometarget pkgconfig
USE_LDCONFIG= yes
USE_RC_SUBR= cherokee.sh
USE_GCC= 3.4+
USE_BISON= yes
+USE_MYSQL= yes
+USE_OPENLDAP= yes
GNU_CONFIGURE= yes
CPPFLAGS= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
@@ -31,7 +33,7 @@ CONFIGURE_ARGS= --mandir=${MANPREFIX}/man \
--with-wwwroot=${PREFIX}/www/cherokee \
--enable-readdir_r \
--disable-static
-DEFCONFS= advanced.conf cherokee.conf icons.conf mime.compression.types mime.types
+DEFCONFS= cherokee.conf mime.compression.types mime.types
CONFSUBDIRS= ssl mods-available mods-enabled sites-available sites-enabled
MAN1= cget.1 cherokee-config.1 cherokee.1 cherokee_logrotate.1
@@ -57,8 +59,10 @@ CONFIGURE_ARGS+=--disable-ipv6
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} \
${REINPLACE_CMD} -e 's|@mkdir_p@|${MKDIR} --|g'
+ @${MV} ${WRKSRC}/mods-icons.conf.sample ${WRKSRC}/mods-icons.sample
@${REINPLACE_CMD} -e '/cherokee_replace.*%sysconfdir%/d;/^SUBDIRS/s|doc ||;\
- /^install-data-am/s|install-data-local|install-data-local-config|'\
+ /^install-data-am/s|install-data-local|install-data-local-config|;\
+ /^SUBDIRS/s|windows||'\
${WRKSRC}/Makefile.in
@for i in ${BUILD_WRKSRC}/*.sample.pre;do ${SED} -e \
's:%sysconfdir%:${PREFIX}/etc:g; \
@@ -74,24 +78,16 @@ post-install:
@${INSTALL} -d ${CONFSUBDIRS:S|^|${PREFIX}/etc/cherokee/|}
@for i in ${DEFCONFS};do\
${INSTALL_DATA} ${WRKSRC}/$$i.sample ${PREFIX}/etc/cherokee/$$i.default;done
+ @${INSTALL_DATA} ${WRKSRC}/performance.conf.sample ${PREFIX}/etc/cherokee/cherokee.conf.perf_sample
@for i in ${WRKSRC}/mods-*.sample;do\
${INSTALL_DATA} $$i ${PREFIX}/etc/cherokee/mods-available/$${i#*mods-};done
- @for i in ${WRKSRC}/sites-*.sample;do\
- ${INSTALL_DATA} $$i ${PREFIX}/etc/cherokee/sites-available/$${i#*sites-};done
@:>${PREFIX}/etc/cherokee/mods-enabled/.empty
+ @:>${PREFIX}/etc/cherokee/sites-available/.empty
+ @:>${PREFIX}/etc/cherokee/sites-enabled/.empty
@:>${PREFIX}/etc/cherokee/ssl/.empty
@for i in `${FIND} ${PREFIX}/etc/cherokee/ -name \*.default`;do\
if [ ! -f $${i%.default} ];then ${CP} $$i $${i%.default};fi;done
@for i in `${FIND} ${PREFIX}/etc/cherokee/ -name \*.sample`;do\
if [ ! -f $${i%.sample} ];then ${CP} $$i $${i%.sample};fi;done
- @if [ -z "`${LS} ${PREFIX}/etc/cherokee/sites-enabled/`" ];then\
- ${LN} -sf ../sites-available/default ${PREFIX}/etc/cherokee/sites-enabled/;fi
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}/images/
- @${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}/
- @${INSTALL_DATA} ${WRKSRC}/doc/*.png ${DOCSDIR}/
- @${INSTALL_DATA} ${WRKSRC}/doc/images/*.png ${DOCSDIR}/images/
- @${INSTALL_DATA} ${WRKSRC}/doc/develop/Intro.txt ${DOCSDIR}/
-.endif
.include <bsd.port.post.mk>
diff --git a/www/cherokee-devel/distinfo b/www/cherokee-devel/distinfo
index ecafe009b942..23462026fdd1 100644
--- a/www/cherokee-devel/distinfo
+++ b/www/cherokee-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (cherokee-0.5.6.tar.gz) = 0c5ae67c296f7e080900b23e533efd0b
-SHA256 (cherokee-0.5.6.tar.gz) = d19ac8a85c252ccfe04c06ce0ec9b03d036b27d07c6db4601ce7d6b33c4e9cc8
-SIZE (cherokee-0.5.6.tar.gz) = 1392282
+MD5 (cherokee-0.6.0b700.tar.gz) = bba3567da2802bef8a76694d8e29ef47
+SHA256 (cherokee-0.6.0b700.tar.gz) = 3fbad3ce1f3e444d4067555bdd0065267c75f71b7e45df2a1e057459edd9f008
+SIZE (cherokee-0.6.0b700.tar.gz) = 1025738
diff --git a/www/cherokee-devel/files/patch-cherokee-socket.c b/www/cherokee-devel/files/patch-cherokee-socket.c
deleted file mode 100644
index c3d2ffb49222..000000000000
--- a/www/cherokee-devel/files/patch-cherokee-socket.c
+++ /dev/null
@@ -1,23 +0,0 @@
---- cherokee/socket.c.orig Thu Dec 7 09:46:29 2006
-+++ cherokee/socket.c Thu Dec 14 10:35:48 2006
-@@ -1153,13 +1153,17 @@
- cherokee_socket_init_client_tls (cherokee_socket_t *socket)
- {
- #ifdef HAVE_TLS
-- int re;
--
- # ifdef HAVE_GNUTLS
-+
- const int kx_priority[] = {GNUTLS_KX_ANON_DH, 0};
- gnutls_anon_client_credentials anoncred;
--
-+
-+#endif
-+
-+ int re;
- socket->is_tls = TLS;
-+
-+# ifdef HAVE_GNUTLS
-
- /* Acredentials
- */
diff --git a/www/cherokee-devel/pkg-plist b/www/cherokee-devel/pkg-plist
index 112903b5220d..fa0abb8ea053 100644
--- a/www/cherokee-devel/pkg-plist
+++ b/www/cherokee-devel/pkg-plist
@@ -4,22 +4,18 @@ bin/cherokee-panic
bin/cherokee_logrotate
@unexec for i in `find %D/etc/cherokee -name \*.default`;do if cmp -s $i ${i%%.default};then rm -f ${i%%.default};fi;done
@unexec for i in `find %D/etc/cherokee -name \*.sample`;do if cmp -s $i ${i%%.sample};then rm -f ${i%%.sample};fi;done
-@unexec cd %D/etc/cherokee/sites-enabled/&&if [ -L default -a -z "`ls|grep -vx default`" ];then rm -f default;fi
-etc/cherokee/advanced.conf.default
etc/cherokee/cherokee.conf.default
-etc/cherokee/icons.conf.default
+etc/cherokee/cherokee.conf.perf_sample
etc/cherokee/mime.compression.types.default
etc/cherokee/mime.types.default
-etc/cherokee/mods-available/admin.sample
+etc/cherokee/mods-available/icons.sample
etc/cherokee/mods-available/ssl.sample
etc/cherokee/mods-enabled/.empty
-etc/cherokee/sites-available/default.sample
-etc/cherokee/sites-available/example.sample
+etc/cherokee/sites-available/.empty
+etc/cherokee/sites-enabled/.empty
etc/cherokee/ssl/.empty
@exec for i in `find %D/etc/cherokee -name \*.default`;do if [ ! -f ${i%%.default} ];then cp $i ${i%%.default};fi;done
@exec for i in `find %D/etc/cherokee -name \*.sample`;do if [ ! -f ${i%%.sample} ];then cp $i ${i%%.sample};fi;done
-@exec if [ ! -d %D/etc/cherokee/sites-enabled ];then mkdir %D/etc/cherokee/sites-enabled;fi
-@exec cd %D/etc/cherokee/sites-enabled/&&if [ -z "`ls`" ];then ln -sf ../sites-available/default;fi
include/cherokee/admin_client.h
include/cherokee/buffer.h
include/cherokee/cherokee-config.h
@@ -34,20 +30,20 @@ include/cherokee/handler.h
include/cherokee/header.h
include/cherokee/http.h
include/cherokee/list.h
-include/cherokee/list_merge_sort.h
include/cherokee/logger.h
include/cherokee/macros.h
include/cherokee/mime.h
include/cherokee/mime_entry.h
include/cherokee/module.h
-include/cherokee/module_loader.h
include/cherokee/nonce.h
+include/cherokee/plugin.h
+include/cherokee/plugin_loader.h
include/cherokee/resolv_cache.h
include/cherokee/server.h
include/cherokee/table.h
-include/cherokee/typed_table.h
include/cherokee/url.h
include/cherokee/util.h
+include/cherokee/version.h
lib/cherokee/libplugin_admin.la
lib/cherokee/libplugin_admin.so
lib/cherokee/libplugin_cgi.la
@@ -70,18 +66,30 @@ lib/cherokee/libplugin_gzip.la
lib/cherokee/libplugin_gzip.so
lib/cherokee/libplugin_htdigest.la
lib/cherokee/libplugin_htdigest.so
+lib/cherokee/libplugin_htpasswd.la
+lib/cherokee/libplugin_htpasswd.so
+lib/cherokee/libplugin_ldap.la
+lib/cherokee/libplugin_ldap.so
+lib/cherokee/libplugin_mirror.so
+lib/cherokee/libplugin_mirror.la
+lib/cherokee/libplugin_mysql.so
+lib/cherokee/libplugin_mysql.la
lib/cherokee/libplugin_ncsa.la
lib/cherokee/libplugin_ncsa.so
lib/cherokee/libplugin_nn.la
lib/cherokee/libplugin_nn.so
+lib/cherokee/libplugin_pam.la
+lib/cherokee/libplugin_pam.so
lib/cherokee/libplugin_phpcgi.la
lib/cherokee/libplugin_phpcgi.so
lib/cherokee/libplugin_plain.la
lib/cherokee/libplugin_plain.so
-lib/cherokee/libplugin_read_config.la
-lib/cherokee/libplugin_read_config.so
+lib/cherokee/libplugin_proxy.la
+lib/cherokee/libplugin_proxy.so
lib/cherokee/libplugin_redir.la
lib/cherokee/libplugin_redir.so
+lib/cherokee/libplugin_round_robin.la
+lib/cherokee/libplugin_round_robin.so
lib/cherokee/libplugin_scgi.la
lib/cherokee/libplugin_scgi.so
lib/cherokee/libplugin_server_info.la
@@ -101,6 +109,7 @@ lib/libcherokee-server.la
lib/libcherokee-server.so
lib/libcherokee-server.so.0
libdata/pkgconfig/cherokee.pc
+sbin/cherokee-admin
sbin/cherokee
share/aclocal/cherokee.m4
%%DATADIR%%/deps/combined.deps
@@ -127,72 +136,27 @@ share/aclocal/cherokee.m4
%%DATADIR%%/icons/text.png
%%DATADIR%%/icons/unknown.png
%%DATADIR%%/mime_types.txt
-%%PORTDOCS%%%%DOCSDIR%%/Authentication.html
-%%PORTDOCS%%%%DOCSDIR%%/Authors.html
-%%PORTDOCS%%%%DOCSDIR%%/Behavior_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/CGI_executing.html
-%%PORTDOCS%%%%DOCSDIR%%/Cget.html
-%%PORTDOCS%%%%DOCSDIR%%/Combined_logger.html
-%%PORTDOCS%%%%DOCSDIR%%/Combined_logs.html
-%%PORTDOCS%%%%DOCSDIR%%/Common_behavior.html
-%%PORTDOCS%%%%DOCSDIR%%/Comparison_servers.html
-%%PORTDOCS%%%%DOCSDIR%%/Compiling_and_Installing.html
-%%PORTDOCS%%%%DOCSDIR%%/Configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/Copying_and_license.html
-%%PORTDOCS%%%%DOCSDIR%%/Current_events.html
-%%PORTDOCS%%%%DOCSDIR%%/Directory_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/Directory_listing.html
-%%PORTDOCS%%%%DOCSDIR%%/Encoders.html
-%%PORTDOCS%%%%DOCSDIR%%/Extension_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/FastCGI.html
-%%PORTDOCS%%%%DOCSDIR%%/File_sending.html
-%%PORTDOCS%%%%DOCSDIR%%/Frequently_asked_questions.html
-%%PORTDOCS%%%%DOCSDIR%%/Gzip_encoder.html
-%%PORTDOCS%%%%DOCSDIR%%/How_to_generate_SSL_keys.html
-%%PORTDOCS%%%%DOCSDIR%%/How_to_manage_Virtual_Host.html
-%%PORTDOCS%%%%DOCSDIR%%/Htdigest_validator.html
-%%PORTDOCS%%%%DOCSDIR%%/Htpasswd_validator.html
-%%PORTDOCS%%%%DOCSDIR%%/Icons_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/Intro.txt
-%%PORTDOCS%%%%DOCSDIR%%/Jaws_and_Cherokee_with_FastCGI.html
-%%PORTDOCS%%%%DOCSDIR%%/Logging_system.html
-%%PORTDOCS%%%%DOCSDIR%%/Mime_types_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/NCSA_logger.html
-%%PORTDOCS%%%%DOCSDIR%%/NCSA_logs.html
-%%PORTDOCS%%%%DOCSDIR%%/PAM_validator.html
-%%PORTDOCS%%%%DOCSDIR%%/PHP_execution.html
-%%PORTDOCS%%%%DOCSDIR%%/Plain_validator.html
-%%PORTDOCS%%%%DOCSDIR%%/Redirections.html
-%%PORTDOCS%%%%DOCSDIR%%/Request_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/Ruby_on_Rails_with_SCGI.html
-%%PORTDOCS%%%%DOCSDIR%%/SCGI.html
-%%PORTDOCS%%%%DOCSDIR%%/Server_configuration.html
-%%PORTDOCS%%%%DOCSDIR%%/U-Cherokee.html
-%%PORTDOCS%%%%DOCSDIR%%/Validators.html
-%%PORTDOCS%%%%DOCSDIR%%/W3C_logger.html
-%%PORTDOCS%%%%DOCSDIR%%/W3C_logs.html
-%%PORTDOCS%%%%DOCSDIR%%/WebApplications.html
-%%PORTDOCS%%%%DOCSDIR%%/cherokee.png
-%%PORTDOCS%%%%DOCSDIR%%/index.html
-%%PORTDOCS%%%%DOCSDIR%%/images/Cherokee-icono.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Exquisite-khelpcenter.png
-%%PORTDOCS%%%%DOCSDIR%%/images/Server-conf-small.png
+%%DATADIR%%/themes/default/cherokee-logo.png
+%%DATADIR%%/themes/default/entry.html
+%%DATADIR%%/themes/default/footer.html
+%%DATADIR%%/themes/default/header.html
+%%DATADIR%%/themes/default/theme.css
www/cherokee/images/cherokee-logo.png
www/cherokee/images/default-bg.png
www/cherokee/images/powered_by_cherokee.png
www/cherokee/index.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%/deps
+@dirrm %%DATADIR%%/themes/default
+@dirrm %%DATADIR%%/themes
@dirrm %%DATADIR%%
-@dirrm lib/cherokee
@dirrm include/cherokee
-@dirrmtry etc/cherokee/ssl
-@dirrmtry etc/cherokee/sites-enabled
-@dirrmtry etc/cherokee/sites-available
-@dirrmtry etc/cherokee/mods-enabled
+@dirrm lib/cherokee
@dirrmtry etc/cherokee/mods-available
+@dirrmtry etc/cherokee/mods-enabled
+@dirrmtry etc/cherokee/sites-available
+@dirrmtry etc/cherokee/sites-enabled
+@dirrmtry etc/cherokee/ssl
@dirrmtry etc/cherokee
@dirrmtry www/cherokee/images
@dirrmtry www/cherokee