aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSanthosh Raju <fox@FreeBSD.org>2021-03-08 04:10:53 +0000
committerSanthosh Raju <fox@FreeBSD.org>2021-03-08 04:10:53 +0000
commit7a8e6f04393be5ff33e8f39b29a6b0d0431f25bf (patch)
tree237cb349f75928fd424ef8e221e26ab08cf4a3e8
parenteb796c6b9aaf1a65f663524dd2ffaaeeb5cc8866 (diff)
downloadports-7a8e6f04393be5ff33e8f39b29a6b0d0431f25bf.tar.gz
ports-7a8e6f04393be5ff33e8f39b29a6b0d0431f25bf.zip
Notes
-rw-r--r--security/wolfssl/Makefile3
-rw-r--r--security/wolfssl/distinfo8
-rw-r--r--security/wolfssl/files/patch-src-ssl.c31
-rw-r--r--security/wolfssl/pkg-plist2
4 files changed, 5 insertions, 39 deletions
diff --git a/security/wolfssl/Makefile b/security/wolfssl/Makefile
index e41e7ce7a8e0..de3302fa8013 100644
--- a/security/wolfssl/Makefile
+++ b/security/wolfssl/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= wolfssl
-PORTVERSION= 4.6.0
-PORTREVISION= 1
+PORTVERSION= 4.7.0
CATEGORIES= security devel
MASTER_SITES= https://www.wolfssl.com/ \
LOCAL/fox
diff --git a/security/wolfssl/distinfo b/security/wolfssl/distinfo
index 6647efe9a0e5..50d426e4a727 100644
--- a/security/wolfssl/distinfo
+++ b/security/wolfssl/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1609170566
-SHA256 (wolfssl-4.6.0.zip) = f44ad0fc260acde4e42e60167b218034b4c8bf73718410f2f3b431a6c41edea8
-SIZE (wolfssl-4.6.0.zip) = 9071773
-SHA256 (e9b1ceae7e1daac6206d399e30c04bd51e3f8c7f.patch) = d012891c56b9d82d1dde9d956affc49c596d4ebf2d71f4ee0cc3ff1c50aa6fbd
-SIZE (e9b1ceae7e1daac6206d399e30c04bd51e3f8c7f.patch) = 1043
+TIMESTAMP = 1615175830
+SHA256 (wolfssl-4.7.0.zip) = 59edfb6b70c17c82f2ef6126198549adf6cbccee8f013cfca88323590f8cbd43
+SIZE (wolfssl-4.7.0.zip) = 9121149
diff --git a/security/wolfssl/files/patch-src-ssl.c b/security/wolfssl/files/patch-src-ssl.c
deleted file mode 100644
index 15dbf7856c62..000000000000
--- a/security/wolfssl/files/patch-src-ssl.c
+++ /dev/null
@@ -1,31 +0,0 @@
-From 0aead8cb868003a5dff2e81d6a7ffd7579652610 Mon Sep 17 00:00:00 2001
-From: Fabian Keil <fk@fabiankeil.de>
-Date: Sun, 17 Jan 2021 11:21:59 +0100
-Subject: [PATCH] wolfSSL_CertManagerFree(): free refMutex
-
-Fixes memory leaks like:
- ==323== 96 bytes in 1 blocks are definitely lost in loss record 3 of 4
- ==323== at 0x4C291E1: calloc (in /usr/local/lib/valgrind/vgpreload_memcheck-amd64-freebsd.so)
- ==323== by 0x585495F: pthread_mutex_init (in /lib/libthr.so.3)
- ==323== by 0x4E7B5E8: wc_InitMutex (wc_port.c:1071)
- ==323== by 0x4F09540: wolfSSL_CertManagerNew_ex (ssl.c:3596)
- ==323== by 0x4EC6A81: InitSSL_Ctx (internal.c:1752)
- ==323== by 0x4F0441E: wolfSSL_CTX_new_ex (ssl.c:394)
- ==323== by 0x4F04658: wolfSSL_CTX_new (ssl.c:436)
- ==323== by 0x400AA2: main (wolfssl-ctx-leak.c:9)
-
-This is a partial cherry-pick of upstream commit
-9598c037168b73ce2f by Tesfa Mael.
---- src/ssl.c.orig 2020-12-23 02:15:20 UTC
-+++ src/ssl.c
-@@ -3663,7 +3663,9 @@ void wolfSSL_CertManagerFree(WOLFSSL_CERT_MANAGER* cm)
- FreeTrustedPeerTable(cm->tpTable, TP_TABLE_SIZE, cm->heap);
- wc_FreeMutex(&cm->tpLock);
- #endif
--
-+ if (wc_FreeMutex(&cm->refMutex) != 0) {
-+ WOLFSSL_MSG("Couldn't free refMutex mutex");
-+ }
- XFREE(cm, cm->heap, DYNAMIC_TYPE_CERT_MANAGER);
- }
- }
diff --git a/security/wolfssl/pkg-plist b/security/wolfssl/pkg-plist
index 8e53f89b5fbd..1df72de8ea03 100644
--- a/security/wolfssl/pkg-plist
+++ b/security/wolfssl/pkg-plist
@@ -224,7 +224,7 @@ include/wolfssl/wolfio.h
lib/libwolfssl.a
lib/libwolfssl.so
lib/libwolfssl.so.24
-lib/libwolfssl.so.24.3.0
+lib/libwolfssl.so.24.4.0
libdata/pkgconfig/wolfssl.pc
%%PORTDOCS%%%%DOCSDIR%%/README.txt
%%PORTDOCS%%%%DOCSDIR%%/example/client.c