aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2019-10-11 19:32:15 +0000
committerKurt Jaeger <pi@FreeBSD.org>2019-10-11 19:32:15 +0000
commit7b045e70a1d0601db525c23e54a00af42ed09854 (patch)
tree9c7d240ed7348cbfc97680893f36ba87adc834b7
parent1d77d19a10248bbc3f34e44e611b2f7e78c04594 (diff)
downloadports-7b045e70a1d0601db525c23e54a00af42ed09854.tar.gz
ports-7b045e70a1d0601db525c23e54a00af42ed09854.zip
MFH: r514295
databases/mongodb36: upgrade 3.6.13 -> 3.6.14 with security fixes PR: 240126 Submitted by: Ronald Klop <ronald-lists@klop.ws> Approved by: dev@dudu.ro (maintainer) Relnotes: https://docs.mongodb.com/manual/release-notes/3.6/#aug-26-2019 Security: CVE-2019-2386, CVE-2019-2389, CVE-2019-2390 Approved by: ports-secteam (miwi, implicit)
Notes
Notes: svn path=/branches/2019Q4/; revision=514296
-rw-r--r--databases/mongodb36/Makefile11
-rw-r--r--databases/mongodb36/distinfo6
-rw-r--r--databases/mongodb36/files/patch-boost-1.6725
-rw-r--r--databases/mongodb36/files/patch-src_mongo_util_time__support.cpp11
4 files changed, 8 insertions, 45 deletions
diff --git a/databases/mongodb36/Makefile b/databases/mongodb36/Makefile
index d2058a6a6930..7d10ad69d728 100644
--- a/databases/mongodb36/Makefile
+++ b/databases/mongodb36/Makefile
@@ -2,8 +2,7 @@
PORTNAME= mongodb
DISTVERSIONPREFIX= r
-DISTVERSION= 3.6.13
-PORTREVISION= 2
+DISTVERSION= 3.6.14
CATEGORIES= databases net
MASTER_SITES= https://fastdl.mongodb.org/src/ \
http://fastdl.mongodb.org/src/ \
@@ -18,7 +17,7 @@ COMMENT= Distributed document-oriented "NoSQL" database
LICENSE= AGPLv3 APACHE20
LICENSE_COMB= multi
-ONLY_FOR_ARCHS= amd64 aarch64
+ONLY_FOR_ARCHS= aarch64 amd64
ONLY_FOR_ARCHS_REASON= "Only supported on amd64 and aarch64 (i386 deprecated in v3)"
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cheetah>=2.4.4:devel/py-cheetah@${PY_FLAVOR} \
@@ -28,12 +27,12 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libpcre.so:devel/pcre \
libsnappy.so:archivers/snappy
-CONFLICTS_BUILD= mongo-cxx-driver
-CONFLICTS_INSTALL= mongodb34 mongodb40
-
USES= compiler:c++14-lang cpe python:2.7,build scons shebangfix
USE_RC_SUBR= mongod
+CONFLICTS_BUILD= mongo-cxx-driver
+CONFLICTS_INSTALL= mongodb34 mongodb40
+
SHEBANG_FILES= src/mongo/installer/compass/install_compass.in
python_OLD_CMD= @python_interpreter@
MAKE_ARGS= --prefix=${STAGEDIR}${PREFIX} \
diff --git a/databases/mongodb36/distinfo b/databases/mongodb36/distinfo
index df146f4be260..2bd23875145b 100644
--- a/databases/mongodb36/distinfo
+++ b/databases/mongodb36/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1562087330
-SHA256 (mongodb-src-r3.6.13.tar.gz) = e4f1ea19dd22446d0348dde39fd229f8cae759d75a06509be43a2f5517997bd5
-SIZE (mongodb-src-r3.6.13.tar.gz) = 40853787
+TIMESTAMP = 1566830350
+SHA256 (mongodb-src-r3.6.14.tar.gz) = 728436ae694693810a9bfb8ec25f3a66c7bb029c69a5dad70199924e3f3e581e
+SIZE (mongodb-src-r3.6.14.tar.gz) = 40895581
diff --git a/databases/mongodb36/files/patch-boost-1.67 b/databases/mongodb36/files/patch-boost-1.67
deleted file mode 100644
index fa8118f5c08c..000000000000
--- a/databases/mongodb36/files/patch-boost-1.67
+++ /dev/null
@@ -1,25 +0,0 @@
-In file included from src/third_party/yaml-cpp-0.5.3/src/nodebuilder.cpp:5:
-In file included from src/third_party/yaml-cpp-0.5.3/include/yaml-cpp/node/detail/node.h:14:
-In file included from src/third_party/yaml-cpp-0.5.3/include/yaml-cpp/node/detail/node_ref.h:13:
-In file included from src/third_party/yaml-cpp-0.5.3/include/yaml-cpp/node/detail/node_data.h:20:
-In file included from src/third_party/yaml-cpp-0.5.3/include/yaml-cpp/node/iterator.h:13:
-src/third_party/yaml-cpp-0.5.3/include/yaml-cpp/node/detail/iterator.h:48:54: error: no member named 'next' in namespace 'boost'
- void increment() { this->base_reference() = boost::next(this->base()); }
- ~~~~~~~^
-
---- src/third_party/yaml-cpp-0.5.3/include/yaml-cpp/node/detail/iterator.h.orig 2018-02-16 21:50:58 UTC
-+++ src/third_party/yaml-cpp-0.5.3/include/yaml-cpp/node/detail/iterator.h
-@@ -11,7 +11,13 @@
- #include "yaml-cpp/node/ptr.h"
- #include "yaml-cpp/node/detail/node_iterator.h"
- #include <boost/iterator/iterator_adaptor.hpp>
-+
-+#include <boost/version.hpp>
-+#if BOOST_VERSION < 106700
- #include <boost/utility.hpp>
-+#else
-+#include <boost/next_prior.hpp>
-+#endif
-
- namespace YAML {
- namespace detail {
diff --git a/databases/mongodb36/files/patch-src_mongo_util_time__support.cpp b/databases/mongodb36/files/patch-src_mongo_util_time__support.cpp
deleted file mode 100644
index 503d5074a6e0..000000000000
--- a/databases/mongodb36/files/patch-src_mongo_util_time__support.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/mongo/util/time_support.cpp.orig 2018-04-19 11:21:07 UTC
-+++ src/mongo/util/time_support.cpp
-@@ -933,7 +933,7 @@ private:
- // Find minimum timer resolution of OS
- Nanoseconds getMinimumTimerResolution() {
- Nanoseconds minTimerResolution;
--#if defined(__linux__)
-+#if defined(__linux__) || defined(__FreeBSD__)
- struct timespec tp;
- clock_getres(CLOCK_REALTIME, &tp);
- minTimerResolution = Nanoseconds{tp.tv_nsec};