aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2016-07-02 03:10:14 +0000
committerKurt Jaeger <pi@FreeBSD.org>2016-07-02 03:10:14 +0000
commit7b41a334640c600ae99ffc485c9383317f6eb706 (patch)
tree0777782d8ffff56f69504ba62499408a5bf943c3
parent1cf09a7b111b930bad30c87d1e6226363f723295 (diff)
downloadports-7b41a334640c600ae99ffc485c9383317f6eb706.tar.gz
ports-7b41a334640c600ae99ffc485c9383317f6eb706.zip
Notes
-rw-r--r--www/links/Makefile13
-rw-r--r--www/links/distinfo4
-rw-r--r--www/links/files/patch-configure80
-rw-r--r--www/links/files/patch-default.c8
-rw-r--r--www/links/files/patch-types.c6
5 files changed, 91 insertions, 20 deletions
diff --git a/www/links/Makefile b/www/links/Makefile
index 275c7d134730..4054430fa611 100644
--- a/www/links/Makefile
+++ b/www/links/Makefile
@@ -2,17 +2,17 @@
# $FreeBSD$
PORTNAME= links
-DISTVERSION= 2.9
+DISTVERSION= 2.13
PORTEPOCH= 1
CATEGORIES= www ipv6
-MASTER_SITES= http://links.twibright.com/download/ LOCAL/bf
+MASTER_SITES= http://links.twibright.com/download/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= portmaster@BSDforge.com
COMMENT= Lynx-like text WWW browser
LICENSE= GPLv2
-CONFLICTS= links-0* links-hacked-[0-9]* links1-*
+CONFLICTS= links-0* links-hacked-[0-9]* links1-[0-9]*
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-ssl --without-pmshell --without-atheos \
@@ -20,8 +20,7 @@ CONFIGURE_ARGS+= --with-ssl --without-pmshell --without-atheos \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_OPENSSL= yes
-USES= cpe tar:bzip2
+USES= cpe ssl tar:bzip2
CPE_VENDOR= twibright
@@ -92,7 +91,7 @@ post-patch:
.if ${PORT_OPTIONS:MX11}
post-install:
- @${INSTALL_DATA} ${WRKSRC}/graphics/links.xpm ${STAGEDIR}${PREFIX}/share/pixmaps/links.xpm
+ ${INSTALL_DATA} ${WRKSRC}/graphics/links.xpm ${STAGEDIR}${PREFIX}/share/pixmaps/links.xpm
.endif
.include <bsd.port.mk>
diff --git a/www/links/distinfo b/www/links/distinfo
index 6910164aab04..98b2bf2169af 100644
--- a/www/links/distinfo
+++ b/www/links/distinfo
@@ -1,2 +1,2 @@
-SHA256 (links-2.9.tar.bz2) = 4360ead54d5f41da16b2f4c0033317ca775f40c1e658a29e9e7f8ce4bc23878f
-SIZE (links-2.9.tar.bz2) = 4111393
+SHA256 (links-2.13.tar.bz2) = c252095334a3b199fa791c6f9a9affe2839a7fbd536685ab07851cb7efaa4405
+SIZE (links-2.13.tar.bz2) = 6516087
diff --git a/www/links/files/patch-configure b/www/links/files/patch-configure
index 40c996e977b6..c037fcbe3858 100644
--- a/www/links/files/patch-configure
+++ b/www/links/files/patch-configure
@@ -1,11 +1,83 @@
---- configure.orig 2011-04-19 11:36:37.000000000 -0400
-+++ configure 2011-10-18 13:48:27.000000000 -0400
-@@ -1762,6 +1762,8 @@
+--- configure.orig 2016-06-26 22:49:47 UTC
++++ configure
+@@ -1913,6 +1913,8 @@ else
cat > conftest.$ac_ext <<EOF
- #line 1764 "configure"
+ #line 1913 "configure"
#include "confdefs.h"
+#include <sys/types.h>
+#include <netinet/in.h>
#include <$ac_hdr>
EOF
ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
+@@ -6031,7 +6033,7 @@ if eval "test \"`echo '$''{'ac_cv_lib_$a
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-ldl $LIBS"
++LIBS=" $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 6035 "configure"
+ #include "confdefs.h"
+@@ -6065,7 +6067,7 @@ if eval "test \"`echo '$ac_cv_lib_'$ac_l
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-ldl $LIBS"
++ LIBS=" $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+@@ -7586,7 +7588,7 @@ if eval "test \"`echo '$''{'ac_cv_lib_$a
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 7582 "configure"
+ #include "confdefs.h"
+@@ -7620,7 +7622,7 @@ if eval "test \"`echo '$ac_cv_lib_'$ac_l
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+@@ -7633,7 +7635,7 @@ if eval "test \"`echo '$''{'ac_cv_lib_$a
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-ldl $LIBS"
++LIBS=" $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 7629 "configure"
+ #include "confdefs.h"
+@@ -7667,7 +7669,7 @@ if eval "test \"`echo '$ac_cv_lib_'$ac_l
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-ldl $LIBS"
++ LIBS=" $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
+@@ -9837,7 +9839,7 @@ if eval "test \"`echo '$''{'ac_cv_lib_$a
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-lpthread $LIBS"
++LIBS="-pthread $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 9833 "configure"
+ #include "confdefs.h"
+@@ -9871,7 +9873,7 @@ if eval "test \"`echo '$ac_cv_lib_'$ac_l
+ #define $ac_tr_lib 1
+ EOF
+
+- LIBS="-lpthread $LIBS"
++ LIBS="-pthread $LIBS"
+
+ else
+ echo "$ac_t""no" 1>&6
diff --git a/www/links/files/patch-default.c b/www/links/files/patch-default.c
index 9d2d8aa26d88..cf88b86d8fba 100644
--- a/www/links/files/patch-default.c
+++ b/www/links/files/patch-default.c
@@ -1,7 +1,7 @@
---- default.c.orig 2008-03-06 22:43:25.117856165 -0500
-+++ default.c 2008-03-06 22:44:12.412560939 -0500
-@@ -400,7 +400,7 @@
- get_system_name();
+--- default.c.orig 2016-06-17 20:33:57 UTC
++++ default.c
+@@ -829,7 +829,7 @@ void init_home(void)
+ get_compiler_name();
links_home = get_home(&first_use);
if (!links_home) {
- fprintf(stderr, "Unable to find or create links config directory. Please check, that you have $HOME variable set correctly and that you have write permission to your home directory.\n\007");
diff --git a/www/links/files/patch-types.c b/www/links/files/patch-types.c
index ee9d1508ec3c..96810352f3ee 100644
--- a/www/links/files/patch-types.c
+++ b/www/links/files/patch-types.c
@@ -1,6 +1,6 @@
---- types.c.orig 2012-06-06 15:49:37.000000000 -0400
-+++ types.c 2012-06-27 02:28:56.000000000 -0400
-@@ -841,7 +841,8 @@
+--- types.c.orig 2016-06-17 20:33:57 UTC
++++ types.c
+@@ -849,7 +849,8 @@ unsigned char *get_content_type_by_exten
ext = NULL;
}
if (ext) while (ext[extl] && ext[extl] != '.' && !dir_sep(ext[extl]) && !end_of_dir(url, ext[extl])) extl++;