aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2011-03-24 08:20:12 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2011-03-24 08:20:12 +0000
commit7b652105680f9acd39b49e9393b57b0db9bd10ff (patch)
tree97950825ea97caa45b973edefdcbfc5cf75051cb
parent19dc938ee0d43d2df4822295dd712167d55cf45a (diff)
Notes
-rw-r--r--archivers/par2cmdline-tbb/Makefile2
-rw-r--r--devel/tbb/Makefile13
-rw-r--r--devel/tbb/distinfo5
-rw-r--r--devel/tbb/pkg-plist5
-rw-r--r--graphics/opencv/Makefile1
5 files changed, 16 insertions, 10 deletions
diff --git a/archivers/par2cmdline-tbb/Makefile b/archivers/par2cmdline-tbb/Makefile
index 277a34581c76..068678a13d60 100644
--- a/archivers/par2cmdline-tbb/Makefile
+++ b/archivers/par2cmdline-tbb/Makefile
@@ -7,7 +7,7 @@
PORTNAME= par2cmdline-tbb
PORTVERSION= 20100203
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= archivers
MASTER_SITES= http://chuchusoft.com/par2_tbb/
DISTNAME= par2cmdline-0.4-tbb-${PORTVERSION}
diff --git a/devel/tbb/Makefile b/devel/tbb/Makefile
index 58a9c4ac58e0..adcff131c74c 100644
--- a/devel/tbb/Makefile
+++ b/devel/tbb/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= tbb
-PORTVERSION= 3.0
-PORTREVISION= 1
+PORTVERSION= 3.0.5
CATEGORIES= devel
-MASTER_SITES= http://www.threadingbuildingblocks.org/uploads/78/154/3.0/
-DISTNAME= tbb30_018oss_src
+MASTER_SITES= http://threadingbuildingblocks.org/uploads/77/164/3.0%20Update%205/ \
+ LOCAL/martymac
+DISTNAME= tbb30_20101215oss_src
EXTRACT_SUFX= .tgz
MAINTAINER= martymac@FreeBSD.org
@@ -25,13 +25,14 @@ USE_GMAKE= yes
ALL_TARGET= default
MAKE_ENV= CPLUS=${CXX}
-WRKSRC= ${WRKDIR}/tbb30_018oss
+WRKSRC= ${WRKDIR}/tbb30_20101215oss
post-extract:
@${CP} ${FILESDIR}/version_info_FreeBSD.sh ${WRKSRC}/build/
post-patch:
- @${REINPLACE_CMD} 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/build/FreeBSD.gcc.inc
+ @${REINPLACE_CMD} 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/build/FreeBSD.gcc.inc
do-install:
cd ${WRKSRC}; \
diff --git a/devel/tbb/distinfo b/devel/tbb/distinfo
index 565183eabb4a..8c480d60e861 100644
--- a/devel/tbb/distinfo
+++ b/devel/tbb/distinfo
@@ -1,3 +1,2 @@
-MD5 (tbb30_018oss_src.tgz) = 3907331f6b978f15c5fdf1047bdaafcc
-SHA256 (tbb30_018oss_src.tgz) = 6a6e79ae3866ddaea664ae0e93e31563f16024a950c11be52a441c0c91ef62e7
-SIZE (tbb30_018oss_src.tgz) = 1550402
+SHA256 (tbb30_20101215oss_src.tgz) = e86026ac88314fb6429c0511d51b661db9bf17229e85702e119e7a684f6d9d69
+SIZE (tbb30_20101215oss_src.tgz) = 1743537
diff --git a/devel/tbb/pkg-plist b/devel/tbb/pkg-plist
index 320e6fdbfe81..f7a9f09faeeb 100644
--- a/devel/tbb/pkg-plist
+++ b/devel/tbb/pkg-plist
@@ -1,3 +1,5 @@
+include/tbb/concurrent_priority_queue.h
+include/tbb/graph.h
include/tbb/task.h
include/tbb/parallel_while.h
include/tbb/task_scheduler_init.h
@@ -18,6 +20,8 @@ include/tbb/queuing_rw_mutex.h
include/tbb/tick_count.h
include/tbb/parallel_for.h
include/tbb/recursive_mutex.h
+include/tbb/machine/windows_api.h
+include/tbb/machine/macos_common.h
include/tbb/machine/sunos_sparc.h
include/tbb/machine/xbox360_ppc.h
include/tbb/machine/mac_ppc.h
@@ -45,6 +49,7 @@ include/tbb/_concurrent_queue_internal.h
include/tbb/pipeline.h
include/tbb/compat/ppl.h
include/tbb/compat/thread
+include/tbb/compat/tuple
include/tbb/compat/condition_variable
include/tbb/spin_mutex.h
include/tbb/tbbmalloc_proxy.h
diff --git a/graphics/opencv/Makefile b/graphics/opencv/Makefile
index 3074374b4250..a1cb04df17f1 100644
--- a/graphics/opencv/Makefile
+++ b/graphics/opencv/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opencv
PORTVERSION= 2.1.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= SF/${PORTNAME}library/${PORTNAME}-unix/${PORTVERSION:R}
DISTNAME= OpenCV-${PORTVERSION}