aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-16 09:16:14 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-16 09:16:14 +0000
commit7b74fe8080e43be4c04d041c8c0c9d509f3112af (patch)
treeb2d3f9144303e2acd353ae28eccf966ba2bafdec
parente4eefbcbb09697f64d6ba82c62afb297c536e94c (diff)
downloadports-7b74fe8080e43be4c04d041c8c0c9d509f3112af.tar.gz
ports-7b74fe8080e43be4c04d041c8c0c9d509f3112af.zip
Notes
-rw-r--r--audio/Makefile1
-rw-r--r--audio/gmpc-lastfm/Makefile25
-rw-r--r--audio/gmpc-lastfm/distinfo3
-rw-r--r--audio/gmpc-lastfm/pkg-descr4
-rw-r--r--audio/gmpc-lastfm/pkg-plist3
5 files changed, 36 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 5f5e5e6ec333..8c9f35099ff0 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -198,6 +198,7 @@
SUBDIR += gmidimonitor
SUBDIR += gmixer
SUBDIR += gmpc
+ SUBDIR += gmpc-lastfm
SUBDIR += gmpc-magnatune
SUBDIR += gmpc-mdcover
SUBDIR += gmpc-osd
diff --git a/audio/gmpc-lastfm/Makefile b/audio/gmpc-lastfm/Makefile
new file mode 100644
index 000000000000..81861d92c784
--- /dev/null
+++ b/audio/gmpc-lastfm/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: gmpc-lastfm
+# Date created: September 14 2007
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gmpc-lastfm
+PORTVERSION= 0.15.0
+CATEGORIES= audio
+MASTER_SITES= http://download.sarine.nl/gmpc-${PORTVERSION}/plugins/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Lastfm plugin for gmpc
+
+LIB_DEPENDS= mpd:${PORTSDIR}/audio/libmpd \
+ curl.4:${PORTSDIR}/ftp/curl
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gmpc.pc:${PORTSDIR}/audio/gmpc
+RUN_DEPEND= gmpc:${PORTSDIR}/audio/gmpc
+
+GNU_CONFIGURE= yes
+USE_XLIB= yes
+USE_GNOME= gnomehack
+
+.include <bsd.port.mk>
diff --git a/audio/gmpc-lastfm/distinfo b/audio/gmpc-lastfm/distinfo
new file mode 100644
index 000000000000..0016e2fa66c6
--- /dev/null
+++ b/audio/gmpc-lastfm/distinfo
@@ -0,0 +1,3 @@
+MD5 (gmpc-lastfm-0.15.0.tar.gz) = 1e3a158c93a4ae778b44c52604e35142
+SHA256 (gmpc-lastfm-0.15.0.tar.gz) = df01df04cb29db992fb772b0d9bc3d86db73a391bc3f1c44910bc0a5ddbc6f13
+SIZE (gmpc-lastfm-0.15.0.tar.gz) = 308605
diff --git a/audio/gmpc-lastfm/pkg-descr b/audio/gmpc-lastfm/pkg-descr
new file mode 100644
index 000000000000..7dab5d34d9d3
--- /dev/null
+++ b/audio/gmpc-lastfm/pkg-descr
@@ -0,0 +1,4 @@
+The last.fm plugin can fetch artist images, from last.fm. This plugin doesn't
+scrobble your music, use a dedicated client like mpdscribble for this.
+
+WWW: http://sarine.nl/gmpc-plugins
diff --git a/audio/gmpc-lastfm/pkg-plist b/audio/gmpc-lastfm/pkg-plist
new file mode 100644
index 000000000000..07a44e8da2bd
--- /dev/null
+++ b/audio/gmpc-lastfm/pkg-plist
@@ -0,0 +1,3 @@
+share/gmpc/plugins/lastfmplugin.so
+@dirrmtry share/gmpc/plugins
+@dirrmtry share/gmpc