aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2018-04-17 13:35:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2018-04-17 13:35:46 +0000
commit7ba54f548d4fb023965e9c5220b44d4c0e385c24 (patch)
tree796132a2191a20576db668536d2d63795ea07e50
parent462ef261c0a9ac9053f25ab1428df562afc2e87b (diff)
- Add LICENSE_FILE
- Switch to USES=localbase - Switch to options helpers - Cosmetic fixes - Install documentation
Notes
Notes: svn path=/head/; revision=467602
-rw-r--r--devel/guichan/Makefile55
-rw-r--r--devel/guichan/pkg-plist18
2 files changed, 29 insertions, 44 deletions
diff --git a/devel/guichan/Makefile b/devel/guichan/Makefile
index 22392b99f34c..4c22836db667 100644
--- a/devel/guichan/Makefile
+++ b/devel/guichan/Makefile
@@ -5,51 +5,36 @@ PORTNAME= guichan
PORTVERSION= 0.8.2
PORTREVISION= 11
CATEGORIES= devel games
-MASTER_SITES= http://pkgs.fedoraproject.org/repo/pkgs/guichan/guichan-0.8.2.tar.gz/af535d7f387e774e3197cef8023ea105/
+MASTER_SITES= http://pkgs.fedoraproject.org/repo/pkgs/guichan/${DISTFILES}/af535d7f387e774e3197cef8023ea105/
MAINTAINER= ports@FreeBSD.org
COMMENT= Small, efficient C++ GUI library designed for games
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+USES= gmake pathfix libtool localbase:ldflags
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= gmake pathfix libtool
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
+PORTDOCS= AUTHORS ChangeLog NEWS README TODO
-OPTIONS_DEFINE= SDL ALLEGRO OPENGL
+OPTIONS_DEFINE= SDL ALLEGRO OPENGL DOCS
OPTIONS_DEFAULT= SDL OPENGL
-ALLEGRO_DESC= Allegro support
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MSDL}
-USE_SDL+= sdl image
-CONFIGURE_ARGS+=--enable-sdl --enable-sdlimage
-PLIST_SUB+= SDL=""
-.else
-CONFIGURE_ARGS+=--disable-sdl --disable-sdlimage
-PLIST_SUB+= SDL="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MALLEGRO}
-LIB_DEPENDS+= liballeg.so:devel/allegro
-CONFIGURE_ARGS+=--enable-allegro
-PLIST_SUB+= ALLEGRO=""
-.else
-CONFIGURE_ARGS+=--disable-allegro
-PLIST_SUB+= ALLEGRO="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MOPENGL}
-USE_GL= yes
-CONFIGURE_ARGS+=--enable-opengl
-PLIST_SUB+= GL=""
-.else
-CONFIGURE_ARGS+=--disable-opengl
-PLIST_SUB+= GL="@comment "
-.endif
+OPTIONS_SUB= yes
+
+SDL_USE= SDL=sdl,image
+SDL_CONFIGURE_ENABLE= sdl sdlimage
+
+ALLEGRO_DESC= Allegro support
+ALLEGRO_LIB_DEPENDS= liballeg.so:devel/allegro
+ALLEGRO_CONFIGURE_ENABLE=allegro
+
+OPENGL_USE= GL=gl
+OPENGL_CONFIGURE_ENABLE=opengl
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/devel/guichan/pkg-plist b/devel/guichan/pkg-plist
index 02e5f1b845dd..e67c71db60d2 100644
--- a/devel/guichan/pkg-plist
+++ b/devel/guichan/pkg-plist
@@ -58,10 +58,10 @@ include/guichan/widgets/window.hpp
%%ALLEGRO%%include/guichan/allegro/allegroimage.hpp
%%ALLEGRO%%include/guichan/allegro/allegroimageloader.hpp
%%ALLEGRO%%include/guichan/allegro/allegroinput.hpp
-%%GL%%include/guichan/opengl/openglgraphics.hpp
-%%GL%%include/guichan/opengl/openglimage.hpp
-%%GL%%include/guichan/opengl/openglallegroimageloader.hpp
-%%GL%%include/guichan/opengl/openglsdlimageloader.hpp
+%%OPENGL%%include/guichan/opengl/openglgraphics.hpp
+%%OPENGL%%include/guichan/opengl/openglimage.hpp
+%%OPENGL%%include/guichan/opengl/openglallegroimageloader.hpp
+%%OPENGL%%include/guichan/opengl/openglsdlimageloader.hpp
%%SDL%%include/guichan/sdl/sdlgraphics.hpp
%%SDL%%include/guichan/sdl/sdlimage.hpp
%%SDL%%include/guichan/sdl/sdlimageloader.hpp
@@ -76,11 +76,11 @@ libdata/pkgconfig/guichan-0.8.pc
%%ALLEGRO%%lib/libguichan_allegro.so
%%ALLEGRO%%lib/libguichan_allegro.so.1
%%ALLEGRO%%lib/libguichan_allegro.so.1.1.0
-%%GL%%lib/libguichan_opengl.a
-%%GL%%lib/libguichan_opengl.so
-%%GL%%lib/libguichan_opengl.so.1
-%%GL%%lib/libguichan_opengl.so.1.1.0
-%%GL%%libdata/pkgconfig/guichan_opengl-0.8.pc
+%%OPENGL%%lib/libguichan_opengl.a
+%%OPENGL%%lib/libguichan_opengl.so
+%%OPENGL%%lib/libguichan_opengl.so.1
+%%OPENGL%%lib/libguichan_opengl.so.1.1.0
+%%OPENGL%%libdata/pkgconfig/guichan_opengl-0.8.pc
%%SDL%%lib/libguichan_sdl.a
%%SDL%%lib/libguichan_sdl.so
%%SDL%%lib/libguichan_sdl.so.1