aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-12-28 16:00:41 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-12-28 16:00:41 +0000
commit7bda762ebb22c6ef269cb5de0ec6401d9d3fadba (patch)
tree5c2bc61dca255d093cf670f4d1828cee0f3e6058
parent8d4139c01fe9fc016ff0efd36ad7681638332acf (diff)
downloadports-7bda762ebb22c6ef269cb5de0ec6401d9d3fadba.tar.gz
ports-7bda762ebb22c6ef269cb5de0ec6401d9d3fadba.zip
Notes
-rw-r--r--textproc/Makefile5
-rw-r--r--textproc/am-aspell/Makefile17
-rw-r--r--textproc/am-aspell/pkg-descr3
-rw-r--r--textproc/aspell/Makefile11
-rw-r--r--textproc/aspell/distinfo6
-rw-r--r--textproc/aspell/files/verdict3
-rw-r--r--textproc/aspell/pkg-plist.am8
-rw-r--r--textproc/aspell/pkg-plist.nds6
-rw-r--r--textproc/aspell/pkg-plist.or6
-rw-r--r--textproc/nds-aspell/Makefile17
-rw-r--r--textproc/nds-aspell/pkg-descr3
-rw-r--r--textproc/or-aspell/Makefile17
-rw-r--r--textproc/or-aspell/pkg-descr3
13 files changed, 100 insertions, 5 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 7af79e540e54..b5887fa80c54 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -12,6 +12,7 @@
SUBDIR += aiksaurus
SUBDIR += aiksaurus-gtk
SUBDIR += align
+ SUBDIR += am-aspell
SUBDIR += ant-xinclude-task
SUBDIR += antiword
SUBDIR += ascii2pdf
@@ -100,8 +101,8 @@
SUBDIR += eo-aspell
SUBDIR += eruby
SUBDIR += es-aspell
- SUBDIR += et-aspell
SUBDIR += estraier
+ SUBDIR += et-aspell
SUBDIR += expat2
SUBDIR += exslt
SUBDIR += fa-aspell
@@ -232,6 +233,7 @@
SUBDIR += ms-aspell
SUBDIR += mt-aspell
SUBDIR += nb-aspell
+ SUBDIR += nds-aspell
SUBDIR += nfbtrans
SUBDIR += nicetext
SUBDIR += nl-aspell
@@ -248,6 +250,7 @@
SUBDIR += openjade
SUBDIR += opensched
SUBDIR += opensp
+ SUBDIR += or-aspell
SUBDIR += p5-Apache-ParseLog
SUBDIR += p5-Apache-XBEL
SUBDIR += p5-CSS-SAC
diff --git a/textproc/am-aspell/Makefile b/textproc/am-aspell/Makefile
new file mode 100644
index 000000000000..66415c534af9
--- /dev/null
+++ b/textproc/am-aspell/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: am-aspell
+# Date created: 28 December 2004
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= am-aspell
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Aspell with Amharic dictionary
+
+MASTERDIR= ${.CURDIR}/../aspell
+
+ASPELL_AM= ow
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/am-aspell/pkg-descr b/textproc/am-aspell/pkg-descr
new file mode 100644
index 000000000000..d370704bcf90
--- /dev/null
+++ b/textproc/am-aspell/pkg-descr
@@ -0,0 +1,3 @@
+Aspell with Amharic dictionary.
+
+WWW: http://aspell.net/
diff --git a/textproc/aspell/Makefile b/textproc/aspell/Makefile
index 993931e59bb9..37a49b233528 100644
--- a/textproc/aspell/Makefile
+++ b/textproc/aspell/Makefile
@@ -72,10 +72,10 @@ DESCR= ${.CURDIR}/pkg-descr
CONF_DICT_ENV= ASPELL="${PREFIX}/bin/aspell" \
WORD_LIST_COMPRESS="${PREFIX}/bin/word-list-compress"
-AVAIL_DICT= af az be bg bn br ca cs cy da de de-alt el en eo es et fa fi fo fr \
- ga gd gl gv he hr hsb hu ia id is it la lt lv mi mk mn ms mt nb nl \
- nn ny pl pt qu ro ru rw sc sk sl sv sw ta tet tl tn tr uk uz vi wa \
- yi zu
+AVAIL_DICT= af am az be bg bn br ca cs cy da de de-alt el en eo es et fa fi fo \
+ fr ga gd gl gv he hr hsb hu ia id is it la lt lv mi mk mn ms mt nb \
+ nds nl nn ny or pl pt qu ro ru rw sc sk sl sv sw ta tet tl tn tr uk \
+ uz vi wa yi zu
DICT_SUFFIX= .tar.bz2
.include <bsd.port.pre.mk>
@@ -112,6 +112,7 @@ DICTS+= ${LG}
@${ECHO_MSG} '* You can add further dictionaries: *'
@${ECHO_MSG} '* Use make-flag: *'
@${ECHO_MSG} '* - Afrikaans ASPELL_AF=yes *'
+ @${ECHO_MSG} '* - Amharic ASPELL_AM=yes *'
@${ECHO_MSG} '* - Azerbaijani ASPELL_AZ=yes *'
@${ECHO_MSG} '* - Belarusian ASPELL_BE=yes *'
@${ECHO_MSG} '* - Bengali ASPELL_BN=yes *'
@@ -143,6 +144,7 @@ DICTS+= ${LG}
@${ECHO_MSG} '* - Latin ASPELL_LA=yes *'
@${ECHO_MSG} '* - Latvian ASPELL_LV=yes *'
@${ECHO_MSG} '* - Lithuanian ASPELL_LT=yes *'
+ @${ECHO_MSG} '* - Low Saxon ASPELL_NDS=yes *'
@${ECHO_MSG} '* - Macedonian ASPELL_MK=yes *'
@${ECHO_MSG} '* - Maori ASPELL_MI=yes *'
@${ECHO_MSG} '* - Malay ASPELL_MS=yes *'
@@ -152,6 +154,7 @@ DICTS+= ${LG}
@${ECHO_MSG} '* - Norwegian Bokmal ASPELL_NB=yes *'
@${ECHO_MSG} '* - Norwegian Nynorsk ASPELL_NN=yes *'
@${ECHO_MSG} '* - Nyanja (Chichewa) ASPELL_NY=yes *'
+ @${ECHO_MSG} '* - Oriya ASPELL_OR=yes *'
@${ECHO_MSG} '* - Persian (Farsi) ASPELL_FA=yes *'
@${ECHO_MSG} '* - Polish ASPELL_PL=yes *'
@${ECHO_MSG} '* - Portuguese ASPELL_PT=yes *'
diff --git a/textproc/aspell/distinfo b/textproc/aspell/distinfo
index f5def85dfceb..9b8c0aea6c09 100644
--- a/textproc/aspell/distinfo
+++ b/textproc/aspell/distinfo
@@ -2,6 +2,8 @@ MD5 (aspell-0.60.2.tar.gz) = d067596a1d9029d127d85e5040bab0ab
SIZE (aspell-0.60.2.tar.gz) = 1577570
MD5 (aspell-af-0.50-0.tar.bz2) = bde617a195e70364f96eea71cf71a333
SIZE (aspell-af-0.50-0.tar.bz2) = 256111
+MD5 (aspell6-am-0.03-1.tar.bz2) = 7e28708b53bd4bc3008dfb04237413ac
+SIZE (aspell6-am-0.03-1.tar.bz2) = 40493
MD5 (aspell6-az-0.02-0.tar.bz2) = 24d9d46c8fc23197666a43a7962a7b0d
SIZE (aspell6-az-0.02-0.tar.bz2) = 50588
MD5 (aspell5-be-0.01.tar.bz2) = 61314a1672f98571b32d23486bbd43be
@@ -84,12 +86,16 @@ MD5 (aspell-mt-0.50-0.tar.bz2) = 6df98356e411891c956c249731b708fa
SIZE (aspell-mt-0.50-0.tar.bz2) = 124114
MD5 (aspell-nb-0.50.1-0.tar.bz2) = d1173a5ce04f39e9c93183da691e7ce8
SIZE (aspell-nb-0.50.1-0.tar.bz2) = 423161
+MD5 (aspell6-nds-0.01-0.tar.bz2) = 76b2b3f2bdeefdfc6ce75ae11c9ae149
+SIZE (aspell6-nds-0.01-0.tar.bz2) = 32658
MD5 (aspell-nl-0.50-2.tar.bz2) = c3ef9fd7dc4c47d816eee9ef5149c76a
SIZE (aspell-nl-0.50-2.tar.bz2) = 428365
MD5 (aspell-nn-0.50.1-1.tar.bz2) = 3711eb9df68f25262af10119579239bc
SIZE (aspell-nn-0.50.1-1.tar.bz2) = 335156
MD5 (aspell5-ny-0.01-0.tar.bz2) = 856906a424fcbc50cc925d692d294215
SIZE (aspell5-ny-0.01-0.tar.bz2) = 22952
+MD5 (aspell6-or-0.03-0.tar.bz2) = a99b5dd3c7960df0a4dd24d12a1adb8e
+SIZE (aspell6-or-0.03-0.tar.bz2) = 20475
MD5 (aspell-pl-0.51-0.tar.bz2) = 5435be1c9c39326a02e2798d8b4d257b
SIZE (aspell-pl-0.51-0.tar.bz2) = 624458
MD5 (aspell-pt-0.50-2.tar.bz2) = e4e15179f90b76ec0336b687d1293edd
diff --git a/textproc/aspell/files/verdict b/textproc/aspell/files/verdict
index 1ed77c76096d..890368e19b65 100644
--- a/textproc/aspell/files/verdict
+++ b/textproc/aspell/files/verdict
@@ -1,4 +1,5 @@
VERDICT_AF= -af-0.50-0
+VERDICT_AM= 6-am-0.03-1
VERDICT_AZ= 6-az-0.02-0
VERDICT_BE= 5-be-0.01
VERDICT_BG= 5-bg-4.0-0
@@ -40,9 +41,11 @@ VERDICT_MN= 6-mn-0.01-0
VERDICT_MS= -ms-0.50-0
VERDICT_MT= -mt-0.50-0
VERDICT_NB= -nb-0.50.1-0
+VERDICT_NDS= 6-nds-0.01-0
VERDICT_NL= -nl-0.50-2
VERDICT_NN= -nn-0.50.1-1
VERDICT_NY= 5-ny-0.01-0
+VERDICT_OR= 6-or-0.03-0
VERDICT_PL= -pl-0.51-0
VERDICT_PT= -pt-0.50-2
VERDICT_QU= 6-qu-0.02-0
diff --git a/textproc/aspell/pkg-plist.am b/textproc/aspell/pkg-plist.am
new file mode 100644
index 000000000000..8f43d1637f96
--- /dev/null
+++ b/textproc/aspell/pkg-plist.am
@@ -0,0 +1,8 @@
+lib/aspell-%%VER%%/am.dat
+lib/aspell-%%VER%%/am_affix.dat
+lib/aspell-%%VER%%/am_phonet.dat
+lib/aspell-%%VER%%/s-ethi.cmap
+lib/aspell-%%VER%%/s-ethi.cset
+share/aspell/am.multi
+share/aspell/am.rws
+share/aspell/amharic.alias
diff --git a/textproc/aspell/pkg-plist.nds b/textproc/aspell/pkg-plist.nds
new file mode 100644
index 000000000000..2a2c453e897c
--- /dev/null
+++ b/textproc/aspell/pkg-plist.nds
@@ -0,0 +1,6 @@
+lib/aspell-%%VER%%/nds.dat
+lib/aspell-%%VER%%/nds_affix.dat
+lib/aspell-%%VER%%/nds_phonet.dat
+share/aspell/lowsaxon.alias
+share/aspell/nds.multi
+share/aspell/nds.rws
diff --git a/textproc/aspell/pkg-plist.or b/textproc/aspell/pkg-plist.or
new file mode 100644
index 000000000000..b7133293a90b
--- /dev/null
+++ b/textproc/aspell/pkg-plist.or
@@ -0,0 +1,6 @@
+lib/aspell-%%VER%%/or.dat
+lib/aspell-%%VER%%/u-orya.cmap
+lib/aspell-%%VER%%/u-orya.cset
+share/aspell/or.multi
+share/aspell/or.rws
+share/aspell/oriya.alias
diff --git a/textproc/nds-aspell/Makefile b/textproc/nds-aspell/Makefile
new file mode 100644
index 000000000000..4b83b1b998c9
--- /dev/null
+++ b/textproc/nds-aspell/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: nds-aspell
+# Date created: 28 December 2004
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= nds-aspell
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Aspell with Low Saxon dictionary
+
+MASTERDIR= ${.CURDIR}/../aspell
+
+ASPELL_NDS= jau
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/nds-aspell/pkg-descr b/textproc/nds-aspell/pkg-descr
new file mode 100644
index 000000000000..dea2b231ba17
--- /dev/null
+++ b/textproc/nds-aspell/pkg-descr
@@ -0,0 +1,3 @@
+Aspell with Low Saxon dictionary.
+
+WWW: http://aspell.net/
diff --git a/textproc/or-aspell/Makefile b/textproc/or-aspell/Makefile
new file mode 100644
index 000000000000..52a973690a83
--- /dev/null
+++ b/textproc/or-aspell/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: or-aspell
+# Date created: 28 December 2004
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= or-aspell
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Aspell with Oriya dictionary
+
+MASTERDIR= ${.CURDIR}/../aspell
+
+ASPELL_OR= a
+
+.include "${MASTERDIR}/Makefile"
diff --git a/textproc/or-aspell/pkg-descr b/textproc/or-aspell/pkg-descr
new file mode 100644
index 000000000000..d8a520ec8f9e
--- /dev/null
+++ b/textproc/or-aspell/pkg-descr
@@ -0,0 +1,3 @@
+Aspell with Oriya dictionary.
+
+WWW: http://aspell.net/