aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-05-06 06:32:22 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-05-06 06:32:22 +0000
commit7cdc62b981ecfcc26a72eb00e704f0180853de99 (patch)
tree9e0e39ea77f4f75a3e4e404bd0bbbe59e137f66c
parentc54b783cab509fc7826a56aff6e5728e5036c17a (diff)
- adoption of USES for gettext
Approved by: portmgr (bapt@)
Notes
Notes: svn path=/head/; revision=317469
-rw-r--r--lang/python26/Makefile20
-rw-r--r--lang/python27/Makefile20
-rw-r--r--lang/python31/Makefile20
-rw-r--r--lang/python32/Makefile20
-rw-r--r--lang/python33/Makefile20
5 files changed, 55 insertions, 45 deletions
diff --git a/lang/python26/Makefile b/lang/python26/Makefile
index 7ef43154d4a2..9dce55ae6d8d 100644
--- a/lang/python26/Makefile
+++ b/lang/python26/Makefile
@@ -58,6 +58,17 @@ OPTIONS_SINGLE_UCS= UCS2 UCS4
NLS_DESC= Enable Gettext support for the locale module
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MSEM}
@@ -80,15 +91,6 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
-# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
-#LDFLAGS+= "-L${LOCALBASE}/lib"
-#CFLAGS+= "-I${LOCALBASE}/include"
-.else
-CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
-.endif
-
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
.if ${PORT_OPTIONS:MPTH}
diff --git a/lang/python27/Makefile b/lang/python27/Makefile
index fb4b92fc0f43..5f8fb7e25a5b 100644
--- a/lang/python27/Makefile
+++ b/lang/python27/Makefile
@@ -58,6 +58,17 @@ OPTIONS_SINGLE_UCS= UCS2 UCS4
NLS_DESC= Enable Gettext support for the locale module
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MSEM}
@@ -80,15 +91,6 @@ PLIST_SUB+= IF_DEFAULT=""
PLIST_SUB+= IF_DEFAULT="@comment "
.endif
-.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
-# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
-#LDFLAGS+= "-L${LOCALBASE}/lib"
-#CFLAGS+= "-I${LOCALBASE}/include"
-.else
-CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
-.endif
-
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
.if ${PORT_OPTIONS:MPTH}
diff --git a/lang/python31/Makefile b/lang/python31/Makefile
index 7709a6ffc311..998ff3a1f201 100644
--- a/lang/python31/Makefile
+++ b/lang/python31/Makefile
@@ -52,6 +52,17 @@ OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
NLS_DESC= Enable Gettext support for the locale module
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.include <bsd.port.pre.mk>
.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
@@ -67,15 +78,6 @@ PLIST_SUB+= IF_DEFAULT_MAJOR=""
PLIST_SUB+= IF_DEFAULT_MAJOR="@comment "
.endif
-.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
-# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
-#LDFLAGS+= "-L${LOCALBASE}/lib"
-#CFLAGS+= "-I${LOCALBASE}/include"
-.else
-CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
-.endif
-
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads
diff --git a/lang/python32/Makefile b/lang/python32/Makefile
index 5208a60c49a7..7a571d38f971 100644
--- a/lang/python32/Makefile
+++ b/lang/python32/Makefile
@@ -53,6 +53,17 @@ OPTIONS_DEFAULT= THREADS UCS4 PYMALLOC IPV6
NLS_DESC= Enable Gettext support for the locale module
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.include <bsd.port.pre.mk>
.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
@@ -68,15 +79,6 @@ PLIST_SUB+= IF_DEFAULT_MAJOR=""
PLIST_SUB+= IF_DEFAULT_MAJOR="@comment "
.endif
-.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
-# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
-#LDFLAGS+= "-L${LOCALBASE}/lib"
-#CFLAGS+= "-I${LOCALBASE}/include"
-.else
-CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
-.endif
-
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads
diff --git a/lang/python33/Makefile b/lang/python33/Makefile
index d30fcbb9b3e0..d52fc7e63672 100644
--- a/lang/python33/Makefile
+++ b/lang/python33/Makefile
@@ -54,6 +54,17 @@ OPTIONS_DEFAULT= THREADS PYMALLOC IPV6
NLS_DESC= Enable Gettext support for the locale module
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USE_GETTEXT= yes
+# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
+#LDFLAGS+= "-L${LOCALBASE}/lib"
+#CFLAGS+= "-I${LOCALBASE}/include"
+.else
+CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
+.endif
+
.include <bsd.port.pre.mk>
.if ${PYTHON_VERSION} == ${PYTHON_DEFAULT_VERSION}
@@ -69,15 +80,6 @@ PLIST_SUB+= IF_DEFAULT_MAJOR=""
PLIST_SUB+= IF_DEFAULT_MAJOR="@comment "
.endif
-.if ${PORT_OPTIONS:MNLS}
-USE_GETTEXT= yes
-# XXX do not set any LDFLAGS or CFLAGS - this causes pyexpat to fail building
-#LDFLAGS+= "-L${LOCALBASE}/lib"
-#CFLAGS+= "-I${LOCALBASE}/include"
-.else
-CONFIGURE_ENV+= ac_cv_lib_intl_textdomain=no ac_cv_header_libintl_h=no
-.endif
-
.if ${PORT_OPTIONS:MTHREADS}
PLIST_SUB+= THREADS=""
CONFIGURE_ARGS+= --with-threads