aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2013-05-16 08:09:21 +0000
committerMatthias Andree <mandree@FreeBSD.org>2013-05-16 08:09:21 +0000
commit7cf4a76b15e10d22f76d2cb9e14a08273796ceaf (patch)
tree60d4c5dd0f39a11782b85beba695b4811758327e
parent95d9f61c7f08e6a2fc22ad7b0f6df266e4dcab16 (diff)
Notes
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/replicant/Makefile38
-rw-r--r--sysutils/replicant/distinfo2
-rw-r--r--sysutils/replicant/files/patch-Makefile.in11
-rw-r--r--sysutils/replicant/files/patch-common_packing.cc20
-rw-r--r--sysutils/replicant/files/patch-daemon_object_manager.cc14
-rw-r--r--sysutils/replicant/pkg-descr3
-rw-r--r--sysutils/replicant/pkg-plist17
8 files changed, 106 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 1f8d86f8cfb8..d01a7eeec1a8 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -773,6 +773,7 @@
SUBDIR += relpath
SUBDIR += rename
SUBDIR += reoback
+ SUBDIR += replicant
SUBDIR += respond
SUBDIR += retail
SUBDIR += rfstool
diff --git a/sysutils/replicant/Makefile b/sysutils/replicant/Makefile
new file mode 100644
index 000000000000..b780ef10eab5
--- /dev/null
+++ b/sysutils/replicant/Makefile
@@ -0,0 +1,38 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= replicant
+PORTVERSION= 0.2.1
+CATEGORIES= sysutils
+MASTER_SITES= http://hyperdex.org/src/
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Replicant is a tool for creating replicated state machines
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libpo6.pc:${PORTSDIR}/devel/libpo6
+LIB_DEPENDS= busybee:${PORTSDIR}/devel/busybee \
+ e:${PORTSDIR}/devel/libe \
+ glog:${PORTSDIR}/devel/glog \
+ leveldb:${PORTSDIR}/databases/leveldb \
+ popt:${PORTSDIR}/devel/popt
+
+ONLY_FOR_ARCHS= amd64
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USES= pathfix pkgconfig
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 90014 || !exists(clang++)
+# newer GCC versions than 4.6 do not work; clang 3.1 seems fine;
+# bug report to upstream at: <https://github.com/rescrv/po6/issues/5>
+USE_GCC= 4.6
+.else
+CC= clang
+CXX= clang++
+CPP= clang-cpp
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/sysutils/replicant/distinfo b/sysutils/replicant/distinfo
new file mode 100644
index 000000000000..ab14759d3c3d
--- /dev/null
+++ b/sysutils/replicant/distinfo
@@ -0,0 +1,2 @@
+SHA256 (replicant-0.2.1.tar.gz) = 1a2cc2b5eddf544ccef28efa44c659075612926ff6eb57aa32ae4c5d6ca0404c
+SIZE (replicant-0.2.1.tar.gz) = 397446
diff --git a/sysutils/replicant/files/patch-Makefile.in b/sysutils/replicant/files/patch-Makefile.in
new file mode 100644
index 000000000000..8876c3bc05d3
--- /dev/null
+++ b/sysutils/replicant/files/patch-Makefile.in
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2013-05-14 12:08:06.731909984 +0000
++++ Makefile.in 2013-05-14 12:08:13.759911180 +0000
+@@ -497,7 +497,7 @@
+ daemon/object_manager.cc \
+ daemon/settings.cc
+
+-replicant_daemon_LDADD = $(E_LIBS) $(BUSYBEE_LIBS) -lglog -lleveldb -ldl -lpthread libreplicant-state-machine.la
++replicant_daemon_LDADD = $(E_LIBS) $(BUSYBEE_LIBS) -lglog -lleveldb -lpthread libreplicant-state-machine.la
+ libreplicant_la_CXXFLAGS = $(CXXFLAGS) $(AM_CXXFLAGS)
+ libreplicant_la_SOURCES = \
+ common/bootstrap.cc \
diff --git a/sysutils/replicant/files/patch-common_packing.cc b/sysutils/replicant/files/patch-common_packing.cc
new file mode 100644
index 000000000000..64f3268e384d
--- /dev/null
+++ b/sysutils/replicant/files/patch-common_packing.cc
@@ -0,0 +1,20 @@
+--- common/packing.cc.orig 2013-05-14 11:51:52.766912852 +0000
++++ common/packing.cc 2013-05-14 11:56:57.204910871 +0000
+@@ -50,7 +50,7 @@
+ rhs.pack(&sa, 0);
+ #ifdef _MSC_VER
+ memmove(data, &sa.sin6_addr.u.Byte, 16);
+-#elif defined __APPLE__
++#elif defined __APPLE__ || defined __FreeBSD__
+ memmove(data, &sa.sin6_addr.__u6_addr.__u6_addr8, 16);
+ #else
+ memmove(data, &sa.sin6_addr.__in6_u.__u6_addr8, 16);
+@@ -90,7 +90,7 @@
+ in6_addr ia;
+ #ifdef _MSC_VER
+ memmove(ia.u.Byte, rem.data(), 16);
+-#elif defined __APPLE__
++#elif defined __APPLE__ || defined __FreeBSD__
+ memmove(ia.__u6_addr.__u6_addr8, rem.data(), 16);
+ #else
+ memmove(ia.__in6_u.__u6_addr8, rem.data(), 16);
diff --git a/sysutils/replicant/files/patch-daemon_object_manager.cc b/sysutils/replicant/files/patch-daemon_object_manager.cc
new file mode 100644
index 000000000000..4f1a4a332546
--- /dev/null
+++ b/sysutils/replicant/files/patch-daemon_object_manager.cc
@@ -0,0 +1,14 @@
+--- daemon/object_manager.cc.orig 2013-05-14 11:57:51.191911826 +0000
++++ daemon/object_manager.cc 2013-05-14 12:00:23.328908089 +0000
+@@ -60,7 +60,10 @@
+ #include "daemon/object_manager.h"
+ #include "daemon/replicant_state_machine.h"
+ #include "daemon/replicant_state_machine_context.h"
+-#if defined __APPLE__
++#if defined __APPLE__ || defined __FreeBSD__
++#ifdef __FreeBSD__
++#include <sys/stat.h>
++#endif
+ #include "daemon/memstream.h"
+ #endif
+
diff --git a/sysutils/replicant/pkg-descr b/sysutils/replicant/pkg-descr
new file mode 100644
index 000000000000..98f3d5623324
--- /dev/null
+++ b/sysutils/replicant/pkg-descr
@@ -0,0 +1,3 @@
+Replicant is a tool for creating replicated state machines
+
+WWW: https://github.com/rescrv/Replicant
diff --git a/sysutils/replicant/pkg-plist b/sysutils/replicant/pkg-plist
new file mode 100644
index 000000000000..8e1cabbe9794
--- /dev/null
+++ b/sysutils/replicant/pkg-plist
@@ -0,0 +1,17 @@
+bin/replicant
+include/replicant.h
+include/replicant_state_machine.h
+lib/libreplicant-state-machine.a
+lib/libreplicant-state-machine.la
+lib/libreplicant-state-machine.so
+lib/libreplicant-state-machine.so.0
+lib/libreplicant.a
+lib/libreplicant.la
+lib/libreplicant.so
+lib/libreplicant.so.0
+libdata/pkgconfig/replicant.pc
+libexec/replicant-0.2.1/replicant-daemon
+libexec/replicant-0.2.1/replicant-del-object
+libexec/replicant-0.2.1/replicant-new-object
+libexec/replicant-0.2.1/replicant-repair
+@dirrm libexec/replicant-0.2.1