aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2007-01-13 22:41:06 +0000
committerNicola Vitale <nivit@FreeBSD.org>2007-01-13 22:41:06 +0000
commit7d0194493d5d76be1f2375c694962e02d37bf05a (patch)
tree49c16a465f46455e6e37e1b750a1b43bb1552021
parentadb2d8bbce394f4fcaa9504eda3c970c1ad7e9c3 (diff)
downloadports-7d0194493d5d76be1f2375c694962e02d37bf05a.tar.gz
ports-7d0194493d5d76be1f2375c694962e02d37bf05a.zip
Notes
-rw-r--r--editors/Makefile1
-rw-r--r--editors/mondrian/Makefile41
-rw-r--r--editors/mondrian/distinfo3
-rw-r--r--editors/mondrian/files/mondrian.in3
-rw-r--r--editors/mondrian/pkg-descr13
-rw-r--r--editors/mondrian/pkg-plist64
6 files changed, 125 insertions, 0 deletions
diff --git a/editors/Makefile b/editors/Makefile
index 233dbdaa9df9..08f76405c9af 100644
--- a/editors/Makefile
+++ b/editors/Makefile
@@ -100,6 +100,7 @@
SUBDIR += mined
SUBDIR += mlview
SUBDIR += mode-info
+ SUBDIR += mondrian
SUBDIR += morla
SUBDIR += mp
SUBDIR += muggy
diff --git a/editors/mondrian/Makefile b/editors/mondrian/Makefile
new file mode 100644
index 000000000000..13f43ca030b8
--- /dev/null
+++ b/editors/mondrian/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: mondrian
+# Date created: 2007-01-13
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mondrian
+PORTVERSION= 1.0.b8
+CATEGORIES= editors ruby
+MASTER_SITES= http://www.mondrian-ide.com/download/ \
+ LOCAL/nivit/${PORTNAME}/
+DISTNAME= ${PORTNAME}-v${PORTVERSION:S/.b/beta/}
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Mondrian Ruby IDE
+
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/fox12.so:${PORTSDIR}/x11-toolkits/ruby-fox-devel
+
+NO_BUILD= yes
+USE_RUBY= yes
+RUBY_NO_BUILD_DEPENDS= yes
+
+SUB_FILES= ${PORTNAME}
+SUB_LIST= RUBY=${RUBY}
+
+FIND_DIRS= -type d
+FIND_DATA= -type f
+
+RM_OPTS= -f
+RM_FILES= LICENSE CHANGELOG
+
+post-extract:
+ @cd ${WRKSRC} && ${RM} ${RM_OPTS} ${RM_FILES}
+
+do-install:
+ @cd ${WRKSRC} && ${FIND} . ${FIND_DIRS} -exec ${MKDIR} ${DATADIR}/{} ";"
+ @cd ${WRKSRC} && ${FIND} . ${FIND_DATA} -exec ${INSTALL_DATA} {} ${DATADIR}/{} ";"
+ @${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${PREFIX}/bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/editors/mondrian/distinfo b/editors/mondrian/distinfo
new file mode 100644
index 000000000000..c11945defb20
--- /dev/null
+++ b/editors/mondrian/distinfo
@@ -0,0 +1,3 @@
+MD5 (mondrian-v1.0beta8.tar.gz) = fbd34e8517339bf7ba4059c285707849
+SHA256 (mondrian-v1.0beta8.tar.gz) = 514b7991f6b2d47da4cc0e12dd62d7a2e7a0da95c93e440e6430d0728b923c9b
+SIZE (mondrian-v1.0beta8.tar.gz) = 90591
diff --git a/editors/mondrian/files/mondrian.in b/editors/mondrian/files/mondrian.in
new file mode 100644
index 000000000000..24aaeec111e5
--- /dev/null
+++ b/editors/mondrian/files/mondrian.in
@@ -0,0 +1,3 @@
+#!/bin/sh
+# $FreeBSD$
+exec %%RUBY%% %%DATADIR%%/Mondrian.rbw
diff --git a/editors/mondrian/pkg-descr b/editors/mondrian/pkg-descr
new file mode 100644
index 000000000000..83190766edce
--- /dev/null
+++ b/editors/mondrian/pkg-descr
@@ -0,0 +1,13 @@
+Mondrian is a cross-platform project-manager and editor
+for the Ruby language.
+Written in 100% native Ruby using the FOX GUI toolkit,
+Mondrian has the familiar look and feel of a modern IDE.
+Some features include:
+
+ * a dynamic object browser
+ * runtime error integration
+ * a full-featured project manager
+ * syntax highlighting
+ * runs identically on Windows and Linux
+
+WWW: http://www.mondrian-ide.com/
diff --git a/editors/mondrian/pkg-plist b/editors/mondrian/pkg-plist
new file mode 100644
index 000000000000..8053c296ffc5
--- /dev/null
+++ b/editors/mondrian/pkg-plist
@@ -0,0 +1,64 @@
+@comment $FreeBSD$
+bin/mondrian
+%%DATADIR%%/CreateProjectDialog.rb
+%%DATADIR%%/DockFrame.rb
+%%DATADIR%%/EditBook.rb
+%%DATADIR%%/ExecutionManager.rb
+%%DATADIR%%/ExecutionMonitor.rb
+%%DATADIR%%/FileManager.rb
+%%DATADIR%%/FindReplaceDialog.rb
+%%DATADIR%%/GardenObject.rb
+%%DATADIR%%/GardenWidget.rb
+%%DATADIR%%/GuiExtensions.rb
+%%DATADIR%%/HomeViewer.rb
+%%DATADIR%%/IconManager.rb
+%%DATADIR%%/Mondrian.rbw
+%%DATADIR%%/Notifier.rb
+%%DATADIR%%/ObjectGarden.rb
+%%DATADIR%%/PreferencesDialog.rb
+%%DATADIR%%/PropertiesFrame.rb
+%%DATADIR%%/RubyAtom.rb
+%%DATADIR%%/RubyAtomExtractor.rb
+%%DATADIR%%/RubyAtomizer.rb
+%%DATADIR%%/RubyParser.rb
+%%DATADIR%%/RubyText.rb
+%%DATADIR%%/SearchFrame.rb
+%%DATADIR%%/SessionManager.rb
+%%DATADIR%%/SourceBrowser.rb
+%%DATADIR%%/icons/back.png
+%%DATADIR%%/icons/class.png
+%%DATADIR%%/icons/close.png
+%%DATADIR%%/icons/close_mini.png
+%%DATADIR%%/icons/copy.png
+%%DATADIR%%/icons/cut.png
+%%DATADIR%%/icons/file.png
+%%DATADIR%%/icons/file_view.png
+%%DATADIR%%/icons/find.png
+%%DATADIR%%/icons/find_in_project.png
+%%DATADIR%%/icons/forward.png
+%%DATADIR%%/icons/left_arrow.png
+%%DATADIR%%/icons/method.png
+%%DATADIR%%/icons/module.png
+%%DATADIR%%/icons/new.png
+%%DATADIR%%/icons/object_view.png
+%%DATADIR%%/icons/open.png
+%%DATADIR%%/icons/paste.png
+%%DATADIR%%/icons/project.png
+%%DATADIR%%/icons/project_key.png
+%%DATADIR%%/icons/redo.png
+%%DATADIR%%/icons/right_arrow.png
+%%DATADIR%%/icons/ruby_file.png
+%%DATADIR%%/icons/run.png
+%%DATADIR%%/icons/run_project.png
+%%DATADIR%%/icons/save.png
+%%DATADIR%%/icons/save_all.png
+%%DATADIR%%/icons/save_as.png
+%%DATADIR%%/icons/toolbar_separator.png
+%%DATADIR%%/icons/undo.png
+%%DATADIR%%/images/mondrian.ico
+%%DATADIR%%/images/mondrian_icon.bmp
+%%DATADIR%%/images/mondrian_icon_small.bmp
+%%DATADIR%%/images/mondrian_splash.png
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%/images
+@dirrm %%DATADIR%%