aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Rees <crees@FreeBSD.org>2014-02-19 22:01:13 +0000
committerChris Rees <crees@FreeBSD.org>2014-02-19 22:01:13 +0000
commit7d7c817973bb9fd8b8007c0d2691d91a9e0190c0 (patch)
tree2cbc6576ad52ca2af76e073782b5e55149716b4d
parentf57c3bc8fedeb7d57f997a6b7c06ce8ebc6fa487 (diff)
downloadports-7d7c817973bb9fd8b8007c0d2691d91a9e0190c0.tar.gz
ports-7d7c817973bb9fd8b8007c0d2691d91a9e0190c0.zip
Notes
-rw-r--r--www/xist/Makefile11
-rw-r--r--www/xist/files/patch-setup.py31
2 files changed, 39 insertions, 3 deletions
diff --git a/www/xist/Makefile b/www/xist/Makefile
index 8f8b228a9247..71d245e0771b 100644
--- a/www/xist/Makefile
+++ b/www/xist/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xist
PORTVERSION= 3.25
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www python
MASTER_SITES= CHEESESHOP \
http://ftp.livinglogic.de/xist/
@@ -16,14 +16,19 @@ COMMENT= XML-based extensible HTML generator
LICENSE= MIT
RUN_DEPENDS= ${PYXML} \
+ ${PYTHON_PKGNAMEPREFIX}ll-core>=1.11.1:${PORTSDIR}/devel/py-ll-core \
${PYTHON_PKGNAMEPREFIX}imaging>0:${PORTSDIR}/graphics/py-imaging \
${PYTHON_PKGNAMEPREFIX}cssutils>=0.9.7:${PORTSDIR}/www/py-cssutils
-CONFLICTS_INSTALL= py*-ll-core-1*
-
USE_BZIP2= yes
USE_PYTHON= 2
USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
+post-patch:
+.for conflictswithllcore in __init__ scripts/__init__ ansistyle astyle color \
+ daemon make misc scripts/ucp sisyphus url xml_codec
+ ${RM} ${WRKSRC}/src/ll/${conflictswithllcore}.py
+.endfor
+
.include <bsd.port.mk>
diff --git a/www/xist/files/patch-setup.py b/www/xist/files/patch-setup.py
new file mode 100644
index 000000000000..c5fd91140ed9
--- /dev/null
+++ b/www/xist/files/patch-setup.py
@@ -0,0 +1,31 @@
+$FreeBSD$
+
+Stop the port conflicting with devel/py-ll-core
+
+--- setup.py.orig 2011-08-11 11:51:22.000000000 +0100
++++ setup.py 2014-02-19 21:45:27.310309976 +0000
+@@ -241,16 +241,11 @@
+ packages=["ll", "ll.scripts", "ll.xist", "ll.xist.ns", "ll.xist.scripts", "ll.orasql", "ll.orasql.scripts"],
+ package_data={"ll.xist": ["data/js/*.js", "data/px/*.gif"]},
+ ext_modules=[
+- tools.Extension("ll._url", ["src/ll/_url.c"]),
+- tools.Extension("ll._ansistyle", ["src/ll/_ansistyle.c"]),
+- tools.Extension("ll._misc", ["src/ll/_misc.c", "src/ll/_misc_include.c"]),
+- tools.Extension("ll._xml_codec", ["src/ll/_xml_codec.c", "src/ll/_xml_codec_include.c"]),
+ tools.Extension("ll.xist.sgmlop", ["src/ll/xist/sgmlop.c"], define_macros=[("SGMLOP_UNICODE_SUPPORT", None)]),
+ ],
+ entry_points=dict(
+ console_scripts=[
+ "uls = ll.scripts.uls:main",
+- "ucp = ll.scripts.ucp:main",
+ "ucat = ll.scripts.ucat:main",
+ "uhpp = ll.xist.scripts.uhpp:main",
+ "db2ul4 = ll.scripts.db2ul4:main",
+@@ -269,7 +264,6 @@
+ ),
+ scripts=[
+ "scripts/uls.py",
+- "scripts/ucp.py",
+ "scripts/ucat.py",
+ "scripts/uhpp.py",
+ "scripts/db2ul4.py",