aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-12-15 04:40:21 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-12-15 04:40:21 +0000
commit7ddbb58780d25ae85d82bfd82b7e6396b8db5172 (patch)
tree01e11d3c324d51e5226d7797bbf0d64633988ef3
parentab9cfed5a59f8c676ec06eb83ad0dcda69284a82 (diff)
downloadports-7ddbb58780d25ae85d82bfd82b7e6396b8db5172.tar.gz
ports-7ddbb58780d25ae85d82bfd82b7e6396b8db5172.zip
www/node: Update to 5.2.0, Create www/node4, Update to 4.2.3
www/node: * Update PORTVERSION and distinfo checksum (5.2.0) [1] * Add CONFLICTS to www/node4 www/node4: * Create www/node4 port for LTS users * Update www/node4 to 4.2.3 [2] * Add CONFLICTS to www/node * Add UPDATING entry for users wishing to remain on LTS (4.x) Based on: PR: 204653 [1][2] Submitted by: Randy Westlund <rwestlun gmail com> [1][2] Approved by: maintainer <linpct gmail com>
Notes
Notes: svn path=/head/; revision=403756
-rw-r--r--UPDATING23
-rw-r--r--www/Makefile1
-rw-r--r--www/node/Makefile6
-rw-r--r--www/node/distinfo4
-rw-r--r--www/node4/Makefile63
-rw-r--r--www/node4/distinfo2
-rw-r--r--www/node4/pkg-descr3
-rw-r--r--www/node4/pkg-message1
-rw-r--r--www/node4/pkg-plist130
9 files changed, 228 insertions, 5 deletions
diff --git a/UPDATING b/UPDATING
index 551368e9218a..48634b0fbbca 100644
--- a/UPDATING
+++ b/UPDATING
@@ -5,6 +5,29 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
+20151214:
+ AFFECTS: All users of www/node
+ AUTHOR: koobs
+
+ www/node has been updated to the latest 5.x stable release, and a new port
+ www/node4 has been created for the 4.x LTS branch.
+
+ Should users want to continue to use version 4.x, replace www/node with
+ www/node4 as follows:
+
+ Using packages:
+
+ # pkg delete node
+ # pkg install node4
+
+ Using ports:
+
+ # portupgrade -o www/node4 www/node
+
+ OR
+
+ # portmaster -o www/node4 www/node
+
20151210:
AFFECTS: users of comms/gammu
AUTHOR: vanilla@FreeBSD.org
diff --git a/www/Makefile b/www/Makefile
index 74f35af290e5..494f492e830a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -564,6 +564,7 @@
SUBDIR += node-devel
SUBDIR += node010
SUBDIR += node012
+ SUBDIR += node4
SUBDIR += nostromo
SUBDIR += npapi-vlc
SUBDIR += npapi-xine
diff --git a/www/node/Makefile b/www/node/Makefile
index 103b624299de..017e89ba4cfa 100644
--- a/www/node/Makefile
+++ b/www/node/Makefile
@@ -2,13 +2,13 @@
# $FreeBSD$
PORTNAME= node
-PORTVERSION= 4.2.1
+PORTVERSION= 5.2.0
DISTVERSIONPREFIX= v
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
MAINTAINER= linpct@gmail.com
-COMMENT= V8 JavaScript for client and server
+COMMENT= V8 JavaScript for client and server (5.x)
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
@@ -19,7 +19,7 @@ USES= compiler execinfo gmake python:2
HAS_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFLICTS_INSTALL= node-0.[02-9][0-9]* node-devel-0.[0-9]* node010-[0-9]* node012-[0-9]* iojs-[0-9]*
+CONFLICTS_INSTALL= node4-* node-0.[02-9][0-9]* node-devel-0.[0-9]* node010-[0-9]* node012-[0-9]* iojs-[0-9]*
ONLY_FOR_ARCHS= i386 amd64
CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} --without-npm --shared-zlib
diff --git a/www/node/distinfo b/www/node/distinfo
index 3b20c05adbe7..1791eb4d5812 100644
--- a/www/node/distinfo
+++ b/www/node/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v4.2.1.tar.gz) = 8861b9f4c3b4db380fcda19a710c0430c3d62d03ee176c64db63eef95a672663
-SIZE (node-v4.2.1.tar.gz) = 22505860
+SHA256 (node-v5.2.0.tar.gz) = 5df5682f9fdd8e747f652e0b09fed46478a1e3df159797852787a074b8787664
+SIZE (node-v5.2.0.tar.gz) = 22445745
diff --git a/www/node4/Makefile b/www/node4/Makefile
new file mode 100644
index 000000000000..ba17b409ee25
--- /dev/null
+++ b/www/node4/Makefile
@@ -0,0 +1,63 @@
+# Created by: Jin-Sih Lin <linpct@gmail.com>
+# $FreeBSD$
+
+PORTNAME= node
+PORTVERSION= 4.2.3
+DISTVERSIONPREFIX= v
+CATEGORIES= www
+MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
+PKGNAMESUFFIX= 4
+
+MAINTAINER= linpct@gmail.com
+COMMENT= V8 JavaScript for client and server (4.x LTS)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+OPTIONS_DEFINE= DOCS
+
+USES= compiler execinfo gmake python:2
+HAS_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+CONFLICTS_INSTALL= node-* node-0.[02-9][0-9]* node-devel-0.[0-9]* node010-[0-9]* node012-[0-9]* iojs-[0-9]*
+
+ONLY_FOR_ARCHS= i386 amd64
+CONFIGURE_ARGS= --prefix=${PREFIX_RELDEST} --without-npm --shared-zlib
+PREFIX_RELDEST= ${PREFIX:S,^${DESTDIR},,}
+REINPLACE_ARGS= -i ''
+MAKE_ENV+= CC.host=${CC} CXX.host=${CXX} LINK.host=${CXX} LINK.target=${CXX}
+
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_TYPE} == clang
+MAKE_ENV+= LINK=clang++
+CFLAGS+= -Wno-unused-private-field
+.if ${COMPILER_VERSION} >= 33
+CFLAGS+= -Wno-nested-anon-types -Wno-unused-function
+.if ${COMPILER_VERSION} >= 34
+CFLAGS+= -Wno-unused-const-variable
+.endif
+.endif
+.else
+MAKE_ARGS+= strictaliasing=off
+USE_GCC= yes
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
+ ${WRKSRC}/deps/v8/tools/gyp/v8.gyp
+ @${REINPLACE_CMD} -e 's|/usr/bin/env python|${PYTHON_CMD}|' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s|python -c|${PYTHON_CMD} -c|" \
+ ${WRKSRC}/deps/v8/build/toolchain.gypi
+ @${REINPLACE_CMD} -e "s|'python',|'${PYTHON_CMD}',|" \
+ ${WRKSRC}/tools/icu/icu-generic.gyp \
+ ${WRKSRC}/deps/v8/build/shim_headers.gypi \
+ ${WRKSRC}/deps/v8/tools/gyp/v8.gyp \
+ ${WRKSRC}/deps/v8/src/d8.gyp
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/node
+
+.include <bsd.port.post.mk>
diff --git a/www/node4/distinfo b/www/node4/distinfo
new file mode 100644
index 000000000000..803c1560b933
--- /dev/null
+++ b/www/node4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (node-v4.2.3.tar.gz) = 5008ade5feb4b089f59163f66bffddc113f27de5d78edf203e39435c2c5d554f
+SIZE (node-v4.2.3.tar.gz) = 22482259
diff --git a/www/node4/pkg-descr b/www/node4/pkg-descr
new file mode 100644
index 000000000000..079aa9b45c25
--- /dev/null
+++ b/www/node4/pkg-descr
@@ -0,0 +1,3 @@
+node - evented I/O for V8 javascript
+
+WWW: http://nodejs.org/
diff --git a/www/node4/pkg-message b/www/node4/pkg-message
new file mode 100644
index 000000000000..87d7ce8d688e
--- /dev/null
+++ b/www/node4/pkg-message
@@ -0,0 +1 @@
+Note: If you need npm (Node Package Manager), please install www/npm.
diff --git a/www/node4/pkg-plist b/www/node4/pkg-plist
new file mode 100644
index 000000000000..bf262a8ea55f
--- /dev/null
+++ b/www/node4/pkg-plist
@@ -0,0 +1,130 @@
+bin/node
+include/node/android-ifaddrs.h
+include/node/ares.h
+include/node/ares_version.h
+include/node/common.gypi
+include/node/config.gypi
+include/node/libplatform/libplatform.h
+include/node/nameser.h
+include/node/node.h
+include/node/node_buffer.h
+include/node/node_internals.h
+include/node/node_object_wrap.h
+include/node/node_version.h
+include/node/openssl/aes.h
+include/node/openssl/archs/BSD-x86/opensslconf.h
+include/node/openssl/archs/BSD-x86_64/opensslconf.h
+include/node/openssl/archs/VC-WIN32/opensslconf.h
+include/node/openssl/archs/VC-WIN64A/opensslconf.h
+include/node/openssl/archs/aix-gcc/opensslconf.h
+include/node/openssl/archs/aix64-gcc/opensslconf.h
+include/node/openssl/archs/darwin-i386-cc/opensslconf.h
+include/node/openssl/archs/darwin64-x86_64-cc/opensslconf.h
+include/node/openssl/archs/linux-aarch64/opensslconf.h
+include/node/openssl/archs/linux-armv4/opensslconf.h
+include/node/openssl/archs/linux-elf/opensslconf.h
+include/node/openssl/archs/linux-ppc/opensslconf.h
+include/node/openssl/archs/linux-ppc64/opensslconf.h
+include/node/openssl/archs/linux-x32/opensslconf.h
+include/node/openssl/archs/linux-x86_64/opensslconf.h
+include/node/openssl/archs/solaris-x86-gcc/opensslconf.h
+include/node/openssl/archs/solaris64-x86_64-gcc/opensslconf.h
+include/node/openssl/asn1.h
+include/node/openssl/asn1_mac.h
+include/node/openssl/asn1t.h
+include/node/openssl/bio.h
+include/node/openssl/blowfish.h
+include/node/openssl/bn.h
+include/node/openssl/buffer.h
+include/node/openssl/camellia.h
+include/node/openssl/cast.h
+include/node/openssl/cmac.h
+include/node/openssl/cms.h
+include/node/openssl/comp.h
+include/node/openssl/conf.h
+include/node/openssl/conf_api.h
+include/node/openssl/crypto.h
+include/node/openssl/des.h
+include/node/openssl/des_old.h
+include/node/openssl/dh.h
+include/node/openssl/dsa.h
+include/node/openssl/dso.h
+include/node/openssl/dtls1.h
+include/node/openssl/e_os2.h
+include/node/openssl/ebcdic.h
+include/node/openssl/ec.h
+include/node/openssl/ecdh.h
+include/node/openssl/ecdsa.h
+include/node/openssl/engine.h
+include/node/openssl/err.h
+include/node/openssl/evp.h
+include/node/openssl/hmac.h
+include/node/openssl/idea.h
+include/node/openssl/krb5_asn.h
+include/node/openssl/kssl.h
+include/node/openssl/lhash.h
+include/node/openssl/md4.h
+include/node/openssl/md5.h
+include/node/openssl/mdc2.h
+include/node/openssl/modes.h
+include/node/openssl/obj_mac.h
+include/node/openssl/objects.h
+include/node/openssl/ocsp.h
+include/node/openssl/opensslconf.h
+include/node/openssl/opensslv.h
+include/node/openssl/ossl_typ.h
+include/node/openssl/pem.h
+include/node/openssl/pem2.h
+include/node/openssl/pkcs12.h
+include/node/openssl/pkcs7.h
+include/node/openssl/pqueue.h
+include/node/openssl/rand.h
+include/node/openssl/rc2.h
+include/node/openssl/rc4.h
+include/node/openssl/ripemd.h
+include/node/openssl/rsa.h
+include/node/openssl/safestack.h
+include/node/openssl/seed.h
+include/node/openssl/sha.h
+include/node/openssl/srp.h
+include/node/openssl/srtp.h
+include/node/openssl/ssl.h
+include/node/openssl/ssl2.h
+include/node/openssl/ssl23.h
+include/node/openssl/ssl3.h
+include/node/openssl/stack.h
+include/node/openssl/symhacks.h
+include/node/openssl/tls1.h
+include/node/openssl/ts.h
+include/node/openssl/txt_db.h
+include/node/openssl/ui.h
+include/node/openssl/ui_compat.h
+include/node/openssl/whrlpool.h
+include/node/openssl/x509.h
+include/node/openssl/x509_vfy.h
+include/node/openssl/x509v3.h
+include/node/pthread-fixes.h
+include/node/stdint-msvc2008.h
+include/node/tree.h
+include/node/uv-aix.h
+include/node/uv-bsd.h
+include/node/uv-darwin.h
+include/node/uv-errno.h
+include/node/uv-linux.h
+include/node/uv-sunos.h
+include/node/uv-threadpool.h
+include/node/uv-unix.h
+include/node/uv-version.h
+include/node/uv-win.h
+include/node/uv.h
+include/node/v8-debug.h
+include/node/v8-platform.h
+include/node/v8-profiler.h
+include/node/v8-testing.h
+include/node/v8-util.h
+include/node/v8-version.h
+include/node/v8.h
+include/node/v8config.h
+@(,,444) man/man1/node.1.gz
+%%PORTDOCS%%%%DOCSDIR%%/gdbinit
+share/systemtap/tapset/node.stp