aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2020-11-07 08:06:18 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2020-11-07 08:06:18 +0000
commit7e34278716de8dd4aef7fc8c974e6fb5e780851c (patch)
tree6394c4f1e9829822d4da3eb3fc8ea60d01fdeccc
parent139178e4cd5e08f393a46bfb11ded3edba899aad (diff)
Notes
-rw-r--r--net/Makefile1
-rw-r--r--net/gsocket/Makefile28
-rw-r--r--net/gsocket/distinfo3
-rw-r--r--net/gsocket/pkg-descr7
-rw-r--r--net/gsocket/pkg-plist10
5 files changed, 49 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f689fbac7919..b28d509409df 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -206,6 +206,7 @@
SUBDIR += grsync
SUBDIR += gscloud
SUBDIR += gsk
+ SUBDIR += gsocket
SUBDIR += gspoof
SUBDIR += gssdp
SUBDIR += gstreamer-plugins-libmms
diff --git a/net/gsocket/Makefile b/net/gsocket/Makefile
new file mode 100644
index 000000000000..e65e335f92ba
--- /dev/null
+++ b/net/gsocket/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= gsocket
+PORTVERSION= 1.4.22
+CATEGORIES= net
+
+MAINTAINER= arr@watson.org
+COMMENT= Allows two users behind NAT/Firewall to establish a TCP connection
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= autoreconf shebangfix ssl
+
+USE_GITHUB= yes
+GH_ACCOUNT= hackerschoice
+GH_TAGNAME= v${PORTVERSION}
+
+GNU_CONFIGURE= yes
+
+INSTALL_TARGET= install-strip
+
+SHEBANG_FILES= ${WRKSRC}/tools/blitz \
+ ${WRKSRC}/tools/gs_funcs \
+ ${WRKSRC}/tools/gs-mount \
+ ${WRKSRC}/tools/gs-sftp
+
+.include <bsd.port.mk>
diff --git a/net/gsocket/distinfo b/net/gsocket/distinfo
new file mode 100644
index 000000000000..8c7d4802e1a5
--- /dev/null
+++ b/net/gsocket/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1604583578
+SHA256 (hackerschoice-gsocket-1.4.22-v1.4.22_GH0.tar.gz) = b900a98e05eac2f5bde7256624263555f5e3c62530172f3338bbd2331986bf40
+SIZE (hackerschoice-gsocket-1.4.22-v1.4.22_GH0.tar.gz) = 81816
diff --git a/net/gsocket/pkg-descr b/net/gsocket/pkg-descr
new file mode 100644
index 000000000000..b608744f480d
--- /dev/null
+++ b/net/gsocket/pkg-descr
@@ -0,0 +1,7 @@
+Global Socket allows two users behind NAT/Firewall to establish a TCP
+connection with each other. Securely. Abandon the thinking that an IP Address
+is needed to communicate with somebody. Instead start thinking that two users
+should be able to communicate with each other as long as they know the same
+secret (key/password). The Global Socket library handles the rest.
+
+WWW: https://github.com/hackerschoice/gsocket
diff --git a/net/gsocket/pkg-plist b/net/gsocket/pkg-plist
new file mode 100644
index 000000000000..5d9551a0c303
--- /dev/null
+++ b/net/gsocket/pkg-plist
@@ -0,0 +1,10 @@
+bin/blitz
+bin/gs_funcs
+bin/gs_uchroot_so
+bin/gs-mount
+bin/gs-netcat
+bin/gs-sftp
+man/man1/blitz.1.gz
+man/man1/gs-mount.1.gz
+man/man1/gs-netcat.1.gz
+man/man1/gs-sftp.1.gz