aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-11-08 14:31:40 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-11-08 14:31:40 +0000
commit7ec7468932acb1dec576e51f4ace2e4029fea9a2 (patch)
treea811a5a82ceb9e468d7f4edf82b181da07f15024
parent25062e9577185b42e4c8eb98b76e7e476ee311d0 (diff)
downloadports-7ec7468932acb1dec576e51f4ace2e4029fea9a2.tar.gz
ports-7ec7468932acb1dec576e51f4ace2e4029fea9a2.zip
Notes
-rw-r--r--audio/esound/Makefile19
-rw-r--r--audio/esound/pkg-plist11
-rw-r--r--audio/libaudiofile/Makefile20
-rw-r--r--audio/libaudiofile/distinfo4
-rw-r--r--audio/libaudiofile/files/patch-ltmain.sh45
-rw-r--r--audio/libaudiofile/pkg-descr26
-rw-r--r--audio/libaudiofile/pkg-plist37
-rw-r--r--audio/musicpd/Makefile4
-rw-r--r--audio/rezound/Makefile4
-rw-r--r--audio/ruby-audiofile/Makefile3
-rw-r--r--audio/terminatorx/Makefile4
-rw-r--r--audio/xmms-audiofile/Makefile4
-rw-r--r--comms/hamfax/Makefile3
-rw-r--r--comms/soundmodem/Makefile3
-rw-r--r--emulators/fuse-utils/Makefile1
-rw-r--r--emulators/kcemu/Makefile4
-rw-r--r--games/cosmosmash/Makefile3
-rw-r--r--misc/libsupertone/Makefile1
-rw-r--r--net-im/ayttm/Makefile4
-rw-r--r--net/nxserver/Makefile4
-rw-r--r--polish/gnugadu2/Makefile4
-rw-r--r--x11/xbelld/Makefile2
22 files changed, 115 insertions, 95 deletions
diff --git a/audio/esound/Makefile b/audio/esound/Makefile
index 48df08b0ef4b..b5a727f0404e 100644
--- a/audio/esound/Makefile
+++ b/audio/esound/Makefile
@@ -4,18 +4,17 @@
PORTNAME= esound
PORTVERSION= 0.2.41
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= GNOME
DIST_SUBDIR= gnome
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A sound library for enlightenment package
+COMMENT= Sound library for enlightenment package
-LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
USE_AUTOTOOLS= libtool
-NO_STAGE= yes
USE_BZIP2= yes
USES= pathfix pkgconfig:both
USE_LDCONFIG= yes
@@ -24,20 +23,12 @@ CONFIGURE_ENV= JW=false
CONFLICTS= py*-ro-[0-9]*
-MAN1= esd-config.1 esd.1 esdcat.1 esdctl.1 esddsp.1 esdfilt.1 esdloop.1 \
- esdmon.1 esdplay.1 esdrec.1 esdsample.1
-
post-patch:
@${REINPLACE_CMD} -e 's|esdconf_DATA = esd.conf|esdconf_DATA = |g' \
${WRKSRC}/Makefile.in
post-install:
- if [ ! -f ${PREFIX}/etc/esd.conf ]; then \
- ${INSTALL_DATA} ${WRKSRC}/esd.conf ${PREFIX}/etc/esd.conf; \
- ${INSTALL_DATA} ${WRKSRC}/esd.conf ${PREFIX}/etc/esd.conf.default; \
- else \
- ${INSTALL_DATA} ${WRKSRC}/esd.conf ${PREFIX}/etc/esd.conf.default; \
- fi
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_DATA} ${WRKSRC}/esd.conf ${STAGEDIR}${PREFIX}/etc/esd.conf.default
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libesd*.so.2
.include <bsd.port.mk>
diff --git a/audio/esound/pkg-plist b/audio/esound/pkg-plist
index 6d443432f153..db4a6d4f19f5 100644
--- a/audio/esound/pkg-plist
+++ b/audio/esound/pkg-plist
@@ -22,4 +22,15 @@ lib/libesddsp.la
lib/libesddsp.so
lib/libesddsp.so.2
libdata/pkgconfig/esound.pc
+man/man1/esd-config.1.gz
+man/man1/esd.1.gz
+man/man1/esdcat.1.gz
+man/man1/esdctl.1.gz
+man/man1/esddsp.1.gz
+man/man1/esdfilt.1.gz
+man/man1/esdloop.1.gz
+man/man1/esdmon.1.gz
+man/man1/esdplay.1.gz
+man/man1/esdrec.1.gz
+man/man1/esdsample.1.gz
share/aclocal/esd.m4
diff --git a/audio/libaudiofile/Makefile b/audio/libaudiofile/Makefile
index 95822320bb86..aa8bc2bea178 100644
--- a/audio/libaudiofile/Makefile
+++ b/audio/libaudiofile/Makefile
@@ -1,22 +1,28 @@
# Created by: Vanilla I. Shu <vanilla@FreeBSD.org>
# $FreeBSD$
+# $MCom: ports/trunk/audio/libaudiofile/Makefile 18610 2013-06-30 16:33:05Z marcus $
PORTNAME= libaudiofile
-PORTVERSION= 0.2.7
+PORTVERSION= 0.3.6
CATEGORIES= audio
-MASTER_SITES= http://www.68k.org/~michael/audiofile/ \
- ftp://oss.sgi.com/projects/audiofile/download/ \
- GNOME
+MASTER_SITES= GNOME
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/lib//}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= audiofile-${PORTVERSION}
MAINTAINER= gnome@FreeBSD.org
-COMMENT= A sound library for SGI audio file
+COMMENT= Sound library for SGI audio file
+LICENSE= LGPL21
+
+CONFLICTS= osalp-0.7.*
+
+USE_XZ= yes
USE_AUTOTOOLS= libtool
-USES= pathfix
+USES= pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFLICTS= osalp-0.7.*
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libaudiofile.so.1
.include <bsd.port.mk>
diff --git a/audio/libaudiofile/distinfo b/audio/libaudiofile/distinfo
index cc5eae5cc23b..7dcac613d425 100644
--- a/audio/libaudiofile/distinfo
+++ b/audio/libaudiofile/distinfo
@@ -1,2 +1,2 @@
-SHA256 (audiofile-0.2.7.tar.gz) = a61c4036c2600a645843f16bec4be166093a9df5f15b02c85291213aa9cf15a2
-SIZE (audiofile-0.2.7.tar.gz) = 502448
+SHA256 (audiofile-0.3.6.tar.xz) = ea2449ad3f201ec590d811db9da6d02ffc5e87a677d06b92ab15363d8cb59782
+SIZE (audiofile-0.3.6.tar.xz) = 530760
diff --git a/audio/libaudiofile/files/patch-ltmain.sh b/audio/libaudiofile/files/patch-ltmain.sh
deleted file mode 100644
index 91713d2306f8..000000000000
--- a/audio/libaudiofile/files/patch-ltmain.sh
+++ /dev/null
@@ -1,45 +0,0 @@
-
-$FreeBSD$
-
---- ltmain.sh.orig Wed Jan 23 11:38:40 2002
-+++ ltmain.sh Sun Feb 3 01:44:17 2002
-@@ -1037,8 +1037,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -2412,6 +2420,9 @@
- *-*-netbsd*)
- # Don't link with libc until the a.out ld.so is fixed.
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- # Add libc to deplibs on all other systems if necessary.
- if test "$build_libtool_need_lc" = "yes"; then
-@@ -4179,10 +4190,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/audio/libaudiofile/pkg-descr b/audio/libaudiofile/pkg-descr
index f71467abaed0..85d5e0ee91e4 100644
--- a/audio/libaudiofile/pkg-descr
+++ b/audio/libaudiofile/pkg-descr
@@ -6,8 +6,28 @@ implemented. I feel, though, that this implementation of the Audio
File Library offers enough functionality to be useful for general
tasks.
-This library allows the processing of audio data to and from audio
-files of many common formats (currently AIFF, AIFC, WAVE, and
-NeXT/Sun).
+This library allows the processing of audio data to and from audio files.
+
+Support file formats:
+
+ AIFF/AIFF-C (.aiff, .aifc)
+ WAVE (.wav)
+ NeXT .snd/Sun .au (.snd, .au)
+ Berkeley/IRCAM/CARL Sound File (.sf)
+ Audio Visual Research (.avr)
+ Amiga IFF/8SVX (.iff)
+ Sample Vision (.smp)
+ Creative Voice File (.voc)
+ NIST SPHERE (.wav)
+ Core Audio Format (.caf)
+ FLAC (.flac)
+
+Supported compression formats:
+
+ G.711 mu-law and A-law
+ IMA ADPCM
+ Microsoft ADPCM
+ FLAC
+ ALAC (Apple Lossless Audio Codec)
WWW: http://www.68k.org/~michael/audiofile/
diff --git a/audio/libaudiofile/pkg-plist b/audio/libaudiofile/pkg-plist
index 87f2dcebcb9a..331c3aed2cdc 100644
--- a/audio/libaudiofile/pkg-plist
+++ b/audio/libaudiofile/pkg-plist
@@ -1,4 +1,3 @@
-bin/audiofile-config
bin/sfconvert
bin/sfinfo
include/af_vfs.h
@@ -7,6 +6,38 @@ include/aupvlist.h
lib/libaudiofile.a
lib/libaudiofile.la
lib/libaudiofile.so
-lib/libaudiofile.so.0
+lib/libaudiofile.so.1
libdata/pkgconfig/audiofile.pc
-share/aclocal/audiofile.m4
+man/man1/sfconvert.1.gz
+man/man1/sfinfo.1.gz
+man/man3/afCloseFile.3.gz
+man/man3/afGetDataOffset.3.gz
+man/man3/afGetFrameCount.3.gz
+man/man3/afGetFrameSize.3.gz
+man/man3/afGetTrackBytes.3.gz
+man/man3/afInitAESChannelData.3.gz
+man/man3/afInitAESChannelDataTo.3.gz
+man/man3/afInitByteOrder.3.gz
+man/man3/afInitChannels.3.gz
+man/man3/afInitCompression.3.gz
+man/man3/afInitFileFormat.3.gz
+man/man3/afInitRate.3.gz
+man/man3/afInitSampleFormat.3.gz
+man/man3/afNewFileSetup.3.gz
+man/man3/afOpenFile.3.gz
+man/man3/afQuery.3.gz
+man/man3/afQueryDouble.3.gz
+man/man3/afQueryLong.3.gz
+man/man3/afQueryPointer.3.gz
+man/man3/afReadFrames.3.gz
+man/man3/afReadMisc.3.gz
+man/man3/afSeekFrame.3.gz
+man/man3/afSeekMisc.3.gz
+man/man3/afSetErrorHandler.3.gz
+man/man3/afSetVirtualByteOrder.3.gz
+man/man3/afSetVirtualChannels.3.gz
+man/man3/afSetVirtualPCMMapping.3.gz
+man/man3/afSetVirtualSampleFormat.3.gz
+man/man3/afTellFrame.3.gz
+man/man3/afWriteFrames.3.gz
+man/man3/afWriteMisc.3.gz
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index af610cb8d8df..19e5b41b2e07 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= musicpd
PORTVERSION= 0.17.3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio ipv6
MASTER_SITES= SF/${PORTNAME}/mpd/${PORTVERSION}
DISTNAME= mpd-${PORTVERSION}
@@ -114,7 +114,7 @@ CONFIGURE_ARGS+=--disable-httpd-output
.endif
.if ${PORT_OPTIONS:MWAV}
-LIB_DEPENDS+= audiofile.0:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS+= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
.else
CONFIGURE_ARGS+=--disable-audiofile
.endif
diff --git a/audio/rezound/Makefile b/audio/rezound/Makefile
index a17cb040e153..0a66d2850275 100644
--- a/audio/rezound/Makefile
+++ b/audio/rezound/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rezound
DISTVERSION= 0.12.3beta
-PORTREVISION= 18
+PORTREVISION= 19
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/ReZound/${DISTVERSION}
@@ -44,7 +44,7 @@ LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
.endif
.if ${PORT_OPTIONS:MAUDIOFILE}
-LIB_DEPENDS+= audiofile:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS+= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
.endif
.if ${PORT_OPTIONS:MPORTAUDIO}
diff --git a/audio/ruby-audiofile/Makefile b/audio/ruby-audiofile/Makefile
index baae5e60d3f8..4942f6fe4146 100644
--- a/audio/ruby-audiofile/Makefile
+++ b/audio/ruby-audiofile/Makefile
@@ -3,6 +3,7 @@
PORTNAME= audiofile
PORTVERSION= 0.2.4
+PORTREVISION= 1
CATEGORIES= audio ruby
MASTER_SITES= SF/ruby-${PORTNAME}/ruby-${PORTNAME}/${PORTVERSION}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -13,7 +14,7 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby binding to the audiofile library
-LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
USE_RUBY= yes
NO_STAGE= yes
diff --git a/audio/terminatorx/Makefile b/audio/terminatorx/Makefile
index 89e3120b8788..23cf96c8c3dc 100644
--- a/audio/terminatorx/Makefile
+++ b/audio/terminatorx/Makefile
@@ -4,7 +4,7 @@
PORTNAME= terminatorx
PORTVERSION= 3.84
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= audio
MASTER_SITES= http://terminatorx.org/dist/
DISTNAME= terminatorX-${PORTVERSION}
@@ -17,7 +17,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa \
rarian-sk-config:${PORTSDIR}/textproc/rarian
-LIB_DEPENDS= audiofile:${PORTSDIR}/audio/libaudiofile \
+LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile \
lrdf:${PORTSDIR}/textproc/liblrdf
OPTIONS_DEFINE= ALSA JACK MPG123 SOX VORBIS MAD
diff --git a/audio/xmms-audiofile/Makefile b/audio/xmms-audiofile/Makefile
index 009bba0d5fef..14486884cc3d 100644
--- a/audio/xmms-audiofile/Makefile
+++ b/audio/xmms-audiofile/Makefile
@@ -3,14 +3,14 @@
PORTNAME= xmms-audiofile
PORTVERSION= 0.1
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= audio
MASTER_SITES= http://www.68k.org/~michael/xmms/
MAINTAINER= ports@FreeBSD.org
COMMENT= XMMS plugin to allow playing libaudiofile supported files
-LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
BUILD_DEPENDS= xmms-config:${PORTSDIR}/multimedia/xmms
RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
diff --git a/comms/hamfax/Makefile b/comms/hamfax/Makefile
index ad19aeffbf27..edcd8d41307a 100644
--- a/comms/hamfax/Makefile
+++ b/comms/hamfax/Makefile
@@ -3,13 +3,14 @@
PORTNAME= hamfax
PORTVERSION= 0.8.1
+PORTREVISION= 1
CATEGORIES= comms audio hamradio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
MAINTAINER= carl@stagecraft.cx
COMMENT= QT application for sending and receiving facsimiles over radio
-LIB_DEPENDS= audiofile:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
USE_QT4= gui moc_build
GNU_CONFIGURE= yes
diff --git a/comms/soundmodem/Makefile b/comms/soundmodem/Makefile
index e150e86adc44..a705e2f7b64f 100644
--- a/comms/soundmodem/Makefile
+++ b/comms/soundmodem/Makefile
@@ -2,6 +2,7 @@
PORTNAME= soundmodem
PORTVERSION= 0.17
+PORTREVISION= 1
CATEGORIES= comms hamradio
MASTER_SITES= http://www.baycom.org/~tom/ham/soundmodem/ \
http://chronos.org.uk/distfiles/
@@ -9,7 +10,7 @@ MASTER_SITES= http://www.baycom.org/~tom/ham/soundmodem/ \
MAINTAINER= db@FreeBSD.org
COMMENT= Amateur Radio sound modem
-LIB_DEPENDS= audiofile:${PORTSDIR}/audio/libaudiofile
+LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile
CONFIGURE_ARGS= --disable-alsatest
WRKSRC= ${WRKDIR}/${DISTNAME}
diff --git a/emulators/fuse-utils/Makefile b/emulators/fuse-utils/Makefile
index 282ee9a708d1..3e9f46d4e10e 100644
--- a/emulators/fuse-utils/Makefile
+++ b/emulators/fuse-utils/Makefile
@@ -3,6 +3,7 @@
PORTNAME= fuse-utils
PORTVERSION= 1.1.1
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= SF/fuse-emulator/${PORTNAME}/${PORTVERSION}
diff --git a/emulators/kcemu/Makefile b/emulators/kcemu/Makefile
index d5bb0634c438..cba2411c324c 100644
--- a/emulators/kcemu/Makefile
+++ b/emulators/kcemu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kcemu
PORTVERSION= 0.5.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/KCemu/KCemu-${PORTVERSION}
DISTNAME= KCemu-${PORTVERSION}
@@ -12,7 +12,7 @@ MAINTAINER= hardy.schumacher@gmx.de
COMMENT= KC85 emulator
BUILD_DEPENDS= pngtopnm:${PORTSDIR}/graphics/netpbm
-LIB_DEPENDS= audiofile:${PORTSDIR}/audio/libaudiofile \
+LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile \
avformat.1:${PORTSDIR}/multimedia/ffmpeg \
dirac_encoder.1:${PORTSDIR}/multimedia/dirac \
schroedinger-1.0:${PORTSDIR}/multimedia/schroedinger \
diff --git a/games/cosmosmash/Makefile b/games/cosmosmash/Makefile
index 2f783a2cc221..5e52ea26aadc 100644
--- a/games/cosmosmash/Makefile
+++ b/games/cosmosmash/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cosmosmash
DISTVERSION= 1.4.7
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://perso.b2b2c.ca/sarrazip/dev/ \
LOCAL/martymac
@@ -15,7 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= flatzebra:${PORTSDIR}/devel/flatzebra \
aa:${PORTSDIR}/graphics/aalib \
mikmod:${PORTSDIR}/audio/libmikmod \
- audiofile:${PORTSDIR}/audio/libaudiofile
+ libaudiofile.so:${PORTSDIR}/audio/libaudiofile
USE_SDL= sdl image mixer
USE_XORG= x11 xau xdmcp
diff --git a/misc/libsupertone/Makefile b/misc/libsupertone/Makefile
index b309b683825d..4b3bbc4b31b5 100644
--- a/misc/libsupertone/Makefile
+++ b/misc/libsupertone/Makefile
@@ -3,6 +3,7 @@
PORTNAME= libsupertone
PORTVERSION= 0.0.2
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://www.soft-switch.org/downloads/unicall/
EXTRACT_SUFX= .tgz
diff --git a/net-im/ayttm/Makefile b/net-im/ayttm/Makefile
index 51c905fc54fb..e3f05ce2ec8b 100644
--- a/net-im/ayttm/Makefile
+++ b/net-im/ayttm/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ayttm
PORTVERSION= 0.5.0.111
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= net-im
MASTER_SITES= SF/ayttm/ayttm/${PORTVERSION:R}-${PORTVERSION:E}/
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
@@ -11,7 +11,7 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= unixmania@gmail.com
COMMENT= A "chat" program that combines AIM, ICQ, and Yahoo! Chat into one
-LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
+LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile \
jasper.4:${PORTSDIR}/graphics/jasper \
libgpgme.so:${PORTSDIR}/security/gpgme \
pspell.16:${PORTSDIR}/textproc/aspell
diff --git a/net/nxserver/Makefile b/net/nxserver/Makefile
index 9fb16d7d50f1..bbfb8fcdbd70 100644
--- a/net/nxserver/Makefile
+++ b/net/nxserver/Makefile
@@ -3,7 +3,7 @@
PORTNAME= nxserver
PORTVERSION= 2.1.0
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= net
MASTER_SITES= http://web04.nomachine.com/download/${PORTVERSION}/sources/
DISTFILES= nx-X11-${PORTVERSION}-3.tar.gz \
@@ -21,7 +21,7 @@ DIST_SUBDIR= NX
MAINTAINER= freenx@deweyonline.com
COMMENT= Low-bandwidth X network server
-LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
+LIB_DEPENDS= libaudiofile.so:${PORTSDIR}/audio/libaudiofile \
jpeg.11:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png
diff --git a/polish/gnugadu2/Makefile b/polish/gnugadu2/Makefile
index eeca0fcae003..200433ca6505 100644
--- a/polish/gnugadu2/Makefile
+++ b/polish/gnugadu2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gnugadu2
PORTVERSION= 2.3.0
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= polish net-im
MASTER_SITES= SF/ggadu/gg2/${PORTVERSION}
DISTNAME= gg2-${PORTVERSION}
@@ -12,7 +12,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Gadu-Gadu IM network client
LIB_DEPENDS= gadu.3:${PORTSDIR}/polish/libgadu \
- audiofile.0:${PORTSDIR}/audio/libaudiofile
+ libaudiofile.so:${PORTSDIR}/audio/libaudiofile
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
diff --git a/x11/xbelld/Makefile b/x11/xbelld/Makefile
index 217f6da7890e..0f715f35a336 100644
--- a/x11/xbelld/Makefile
+++ b/x11/xbelld/Makefile
@@ -3,7 +3,7 @@
PORTNAME= xbelld
PORTVERSION= 0.2b2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11
MASTER_SITES= http://www.meowfishies.com/code/
DISTNAME= ${PORTNAME}-0.2beta2